summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-bash-completion2
-rw-r--r--composer.spec23
-rw-r--r--installed.json84
3 files changed, 56 insertions, 53 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index 76b1486..53e0f7e 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.5.1")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.5.2")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.spec b/composer.spec
index 1d9b88e..df10031 100644
--- a/composer.spec
+++ b/composer.spec
@@ -1,7 +1,7 @@
# remirepo/fedora spec file for composer
#
-# Copyright (c) 2015-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 923278ad13e1621946eb76ab2882655d2cc396a4
+%global gh_commit c76c013c555160410af47c03a0e173518e3f5796
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.3.0
%global run_version 2.2.2
-%global upstream_version 2.5.1
+%global upstream_version 2.5.2
#global upstream_prever RC1
#global upstream_lower rc1
@@ -80,7 +80,7 @@ Requires: php-cli
Requires: ca-certificates
# Bundled libraries
# License MIT
-Provides: bundled(php-composer-ca-bundle) = 1.3.4
+Provides: bundled(php-composer-ca-bundle) = 1.3.5
Provides: bundled(php-composer-class-map-generator) = 1.0.0
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
Provides: bundled(php-composer-pcre) = 2.1.0
@@ -94,10 +94,10 @@ Provides: bundled(php-react-promise) = v2.9.0
Provides: bundled(php-seld-jsonlint) = 1.9.0
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.1
-Provides: bundled(php-symfony-console) = v5.4.16
+Provides: bundled(php-symfony-console) = v5.4.19
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
-Provides: bundled(php-symfony-filesystem) = v5.4.13
-Provides: bundled(php-symfony-finder) = v5.4.11
+Provides: bundled(php-symfony-filesystem) = v5.4.19
+Provides: bundled(php-symfony-finder) = v5.4.19
Provides: bundled(php-symfony-polyfill-ctype) = v1.27.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.27.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.27.0
@@ -105,9 +105,9 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
-Provides: bundled(php-symfony-process) = v5.4.11
+Provides: bundled(php-symfony-process) = v5.4.19
Provides: bundled(php-symfony-service-contracts) = v2.5.2
-Provides: bundled(php-symfony-string) = v5.4.15
+Provides: bundled(php-symfony-string) = v5.4.19
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -249,6 +249,9 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Mon Feb 6 2023 Remi Collet <remi@remirepo.net> - 2.5.2-1
+- update to 2.5.2
+
* Thu Dec 22 2022 Remi Collet <remi@remirepo.net> - 2.5.1-1
- update to 2.5.1
diff --git a/installed.json b/installed.json
index d1b46be..56ae93d 100644
--- a/installed.json
+++ b/installed.json
@@ -2,17 +2,17 @@
"packages": [
{
"name": "composer/ca-bundle",
- "version": "1.3.4",
- "version_normalized": "1.3.4.0",
+ "version": "1.3.5",
+ "version_normalized": "1.3.5.0",
"source": {
"type": "git",
"url": "https://github.com/composer/ca-bundle.git",
- "reference": "69098eca243998b53eed7a48d82dedd28b447cd5"
+ "reference": "74780ccf8c19d6acb8d65c5f39cd72110e132bbd"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/ca-bundle/zipball/69098eca243998b53eed7a48d82dedd28b447cd5",
- "reference": "69098eca243998b53eed7a48d82dedd28b447cd5",
+ "url": "https://api.github.com/repos/composer/ca-bundle/zipball/74780ccf8c19d6acb8d65c5f39cd72110e132bbd",
+ "reference": "74780ccf8c19d6acb8d65c5f39cd72110e132bbd",
"shasum": ""
},
"require": {
@@ -26,7 +26,7 @@
"symfony/phpunit-bridge": "^4.2 || ^5",
"symfony/process": "^2.5 || ^3.0 || ^4.0 || ^5.0 || ^6.0"
},
- "time": "2022-10-12T12:08:29+00:00",
+ "time": "2023-01-11T08:27:00+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -61,7 +61,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/ca-bundle/issues",
- "source": "https://github.com/composer/ca-bundle/tree/1.3.4"
+ "source": "https://github.com/composer/ca-bundle/tree/1.3.5"
},
"funding": [
{
@@ -977,17 +977,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.16",
- "version_normalized": "5.4.16.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "8e9b9c8dfb33af6057c94e1b44846bee700dc5ef"
+ "reference": "dccb8d251a9017d5994c988b034d3e18aaabf740"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/8e9b9c8dfb33af6057c94e1b44846bee700dc5ef",
- "reference": "8e9b9c8dfb33af6057c94e1b44846bee700dc5ef",
+ "url": "https://api.github.com/repos/symfony/console/zipball/dccb8d251a9017d5994c988b034d3e18aaabf740",
+ "reference": "dccb8d251a9017d5994c988b034d3e18aaabf740",
"shasum": ""
},
"require": {
@@ -1025,7 +1025,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2022-11-25T14:09:27+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1059,7 +1059,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.16"
+ "source": "https://github.com/symfony/console/tree/v5.4.19"
},
"funding": [
{
@@ -1149,17 +1149,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.13",
- "version_normalized": "5.4.13.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "ac09569844a9109a5966b9438fc29113ce77cf51"
+ "reference": "648bfaca6a494f3e22378123bcee2894045dc9d8"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/ac09569844a9109a5966b9438fc29113ce77cf51",
- "reference": "ac09569844a9109a5966b9438fc29113ce77cf51",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/648bfaca6a494f3e22378123bcee2894045dc9d8",
+ "reference": "648bfaca6a494f3e22378123bcee2894045dc9d8",
"shasum": ""
},
"require": {
@@ -1168,7 +1168,7 @@
"symfony/polyfill-mbstring": "~1.8",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-09-21T19:53:16+00:00",
+ "time": "2023-01-14T19:14:44+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1196,7 +1196,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.13"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.19"
},
"funding": [
{
@@ -1216,17 +1216,17 @@
},
{
"name": "symfony/finder",
- "version": "v5.4.11",
- "version_normalized": "5.4.11.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "7872a66f57caffa2916a584db1aa7f12adc76f8c"
+ "reference": "6071aebf810ad13fe8200c224f36103abb37cf1f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/7872a66f57caffa2916a584db1aa7f12adc76f8c",
- "reference": "7872a66f57caffa2916a584db1aa7f12adc76f8c",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/6071aebf810ad13fe8200c224f36103abb37cf1f",
+ "reference": "6071aebf810ad13fe8200c224f36103abb37cf1f",
"shasum": ""
},
"require": {
@@ -1234,7 +1234,7 @@
"symfony/deprecation-contracts": "^2.1|^3",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-07-29T07:37:50+00:00",
+ "time": "2023-01-14T19:14:44+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1262,7 +1262,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v5.4.11"
+ "source": "https://github.com/symfony/finder/tree/v5.4.19"
},
"funding": [
{
@@ -1874,24 +1874,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.11",
- "version_normalized": "5.4.11.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "6e75fe6874cbc7e4773d049616ab450eff537bf1"
+ "reference": "c5ba874c9b636dbccf761e22ce750e88ec3f55e1"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/6e75fe6874cbc7e4773d049616ab450eff537bf1",
- "reference": "6e75fe6874cbc7e4773d049616ab450eff537bf1",
+ "url": "https://api.github.com/repos/symfony/process/zipball/c5ba874c9b636dbccf761e22ce750e88ec3f55e1",
+ "reference": "c5ba874c9b636dbccf761e22ce750e88ec3f55e1",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-06-27T16:58:25+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1919,7 +1919,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.11"
+ "source": "https://github.com/symfony/process/tree/v5.4.19"
},
"funding": [
{
@@ -2025,17 +2025,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.15",
- "version_normalized": "5.4.15.0",
+ "version": "v5.4.19",
+ "version_normalized": "5.4.19.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "571334ce9f687e3e6af72db4d3b2a9431e4fd9ed"
+ "reference": "0a01071610fd861cc160dfb7e2682ceec66064cb"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/571334ce9f687e3e6af72db4d3b2a9431e4fd9ed",
- "reference": "571334ce9f687e3e6af72db4d3b2a9431e4fd9ed",
+ "url": "https://api.github.com/repos/symfony/string/zipball/0a01071610fd861cc160dfb7e2682ceec66064cb",
+ "reference": "0a01071610fd861cc160dfb7e2682ceec66064cb",
"shasum": ""
},
"require": {
@@ -2055,7 +2055,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2022-10-05T15:16:54+00:00",
+ "time": "2023-01-01T08:32:19+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2094,7 +2094,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.15"
+ "source": "https://github.com/symfony/string/tree/v5.4.19"
},
"funding": [
{