summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-bash-completion2
-rw-r--r--composer.spec24
-rw-r--r--installed.json96
3 files changed, 60 insertions, 62 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index c7e5ec9..c088bc4 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.5.5")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.5.6")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.spec b/composer.spec
index 2959fa3..4432bbb 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit c7cffaad16a60636a776017eac5bd8cd0095c32f
+%global gh_commit f7c05db8b0a66d046203faf3c187e319cd211fae
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.3.0
%global run_version 2.2.2
-%global upstream_version 2.5.5
+%global upstream_version 2.5.6
#global upstream_prever RC1
#global upstream_lower rc1
@@ -80,7 +80,6 @@ Requires: php-cli
Requires: ca-certificates
# Bundled libraries
# License MIT
-Provides: bundled(php-composer-ca-bundle) = 1.3.5
Provides: bundled(php-composer-class-map-generator) = 1.0.0
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
Provides: bundled(php-composer-pcre) = 2.1.0
@@ -90,13 +89,13 @@ Provides: bundled(php-composer-xdebug-handler) = 3.0.3
Provides: bundled(php-justinrainbow-json-schema) = 5.2.12
Provides: bundled(php-psr-container) = 1.1.1
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-react-promise) = v2.9.0
-Provides: bundled(php-seld-jsonlint) = 1.9.0
+Provides: bundled(php-react-promise) = v2.10.0
+Provides: bundled(php-seld-jsonlint) = 1.10.0
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.1
-Provides: bundled(php-symfony-console) = v5.4.21
+Provides: bundled(php-symfony-console) = v5.4.23
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
-Provides: bundled(php-symfony-filesystem) = v5.4.21
+Provides: bundled(php-symfony-filesystem) = v5.4.23
Provides: bundled(php-symfony-finder) = v5.4.21
Provides: bundled(php-symfony-polyfill-ctype) = v1.27.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.27.0
@@ -105,9 +104,9 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
-Provides: bundled(php-symfony-process) = v5.4.21
+Provides: bundled(php-symfony-process) = v5.4.23
Provides: bundled(php-symfony-service-contracts) = v2.5.2
-Provides: bundled(php-symfony-string) = v5.4.21
+Provides: bundled(php-symfony-string) = v5.4.22
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -155,8 +154,8 @@ Documentation: https://getcomposer.org/doc/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .rpm
-%patch1 -p1 -b .noxdg
+%patch -P0 -p1 -b .rpm
+%patch -P1 -p1 -b .noxdg
find . \( -name \*.rpm -o -name \*noxdg \) -delete -print
if grep -r '\.\./res'; then
@@ -249,6 +248,9 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Wed May 24 2023 Remi Collet <remi@remirepo.net> - 2.5.6-1
+- update to 2.5.6
+
* Tue Mar 21 2023 Remi Collet <remi@remirepo.net> - 2.5.5-1
- update to 2.5.5
diff --git a/installed.json b/installed.json
index 30dc88f..6b8ce8f 100644
--- a/installed.json
+++ b/installed.json
@@ -716,26 +716,26 @@
},
{
"name": "react/promise",
- "version": "v2.9.0",
- "version_normalized": "2.9.0.0",
+ "version": "v2.10.0",
+ "version_normalized": "2.10.0.0",
"source": {
"type": "git",
"url": "https://github.com/reactphp/promise.git",
- "reference": "234f8fd1023c9158e2314fa9d7d0e6a83db42910"
+ "reference": "f913fb8cceba1e6644b7b90c4bfb678ed8a3ef38"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/reactphp/promise/zipball/234f8fd1023c9158e2314fa9d7d0e6a83db42910",
- "reference": "234f8fd1023c9158e2314fa9d7d0e6a83db42910",
+ "url": "https://api.github.com/repos/reactphp/promise/zipball/f913fb8cceba1e6644b7b90c4bfb678ed8a3ef38",
+ "reference": "f913fb8cceba1e6644b7b90c4bfb678ed8a3ef38",
"shasum": ""
},
"require": {
"php": ">=5.4.0"
},
"require-dev": {
- "phpunit/phpunit": "^9.3 || ^5.7 || ^4.8.36"
+ "phpunit/phpunit": "^9.5 || ^5.7 || ^4.8.36"
},
- "time": "2022-02-11T10:27:51+00:00",
+ "time": "2023-05-02T15:15:43+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -779,33 +779,29 @@
],
"support": {
"issues": "https://github.com/reactphp/promise/issues",
- "source": "https://github.com/reactphp/promise/tree/v2.9.0"
+ "source": "https://github.com/reactphp/promise/tree/v2.10.0"
},
"funding": [
{
- "url": "https://github.com/WyriHaximus",
- "type": "github"
- },
- {
- "url": "https://github.com/clue",
- "type": "github"
+ "url": "https://opencollective.com/reactphp",
+ "type": "open_collective"
}
],
"install-path": "../react/promise"
},
{
"name": "seld/jsonlint",
- "version": "1.9.0",
- "version_normalized": "1.9.0.0",
+ "version": "1.10.0",
+ "version_normalized": "1.10.0.0",
"source": {
"type": "git",
"url": "https://github.com/Seldaek/jsonlint.git",
- "reference": "4211420d25eba80712bff236a98960ef68b866b7"
+ "reference": "594fd6462aad8ecee0b45ca5045acea4776667f1"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/Seldaek/jsonlint/zipball/4211420d25eba80712bff236a98960ef68b866b7",
- "reference": "4211420d25eba80712bff236a98960ef68b866b7",
+ "url": "https://api.github.com/repos/Seldaek/jsonlint/zipball/594fd6462aad8ecee0b45ca5045acea4776667f1",
+ "reference": "594fd6462aad8ecee0b45ca5045acea4776667f1",
"shasum": ""
},
"require": {
@@ -815,7 +811,7 @@
"phpstan/phpstan": "^1.5",
"phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.0 || ^8.5.13"
},
- "time": "2022-04-01T13:37:23+00:00",
+ "time": "2023-05-11T13:16:46+00:00",
"bin": [
"bin/jsonlint"
],
@@ -846,7 +842,7 @@
],
"support": {
"issues": "https://github.com/Seldaek/jsonlint/issues",
- "source": "https://github.com/Seldaek/jsonlint/tree/1.9.0"
+ "source": "https://github.com/Seldaek/jsonlint/tree/1.10.0"
},
"funding": [
{
@@ -977,17 +973,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.21",
- "version_normalized": "5.4.21.0",
+ "version": "v5.4.23",
+ "version_normalized": "5.4.23.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "c77433ddc6cdc689caf48065d9ea22ca0853fbd9"
+ "reference": "90f21e27d0d88ce38720556dd164d4a1e4c3934c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/c77433ddc6cdc689caf48065d9ea22ca0853fbd9",
- "reference": "c77433ddc6cdc689caf48065d9ea22ca0853fbd9",
+ "url": "https://api.github.com/repos/symfony/console/zipball/90f21e27d0d88ce38720556dd164d4a1e4c3934c",
+ "reference": "90f21e27d0d88ce38720556dd164d4a1e4c3934c",
"shasum": ""
},
"require": {
@@ -1025,7 +1021,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2023-02-25T16:59:41+00:00",
+ "time": "2023-04-24T18:47:29+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1054,12 +1050,12 @@
"homepage": "https://symfony.com",
"keywords": [
"cli",
- "command line",
+ "command-line",
"console",
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.21"
+ "source": "https://github.com/symfony/console/tree/v5.4.23"
},
"funding": [
{
@@ -1149,17 +1145,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.21",
- "version_normalized": "5.4.21.0",
+ "version": "v5.4.23",
+ "version_normalized": "5.4.23.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "e75960b1bbfd2b8c9e483e0d74811d555ca3de9f"
+ "reference": "b2f79d86cd9e7de0fff6d03baa80eaed7a5f38b5"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/e75960b1bbfd2b8c9e483e0d74811d555ca3de9f",
- "reference": "e75960b1bbfd2b8c9e483e0d74811d555ca3de9f",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/b2f79d86cd9e7de0fff6d03baa80eaed7a5f38b5",
+ "reference": "b2f79d86cd9e7de0fff6d03baa80eaed7a5f38b5",
"shasum": ""
},
"require": {
@@ -1168,7 +1164,7 @@
"symfony/polyfill-mbstring": "~1.8",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2023-02-14T08:03:56+00:00",
+ "time": "2023-03-02T11:38:35+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1196,7 +1192,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.21"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.23"
},
"funding": [
{
@@ -1874,24 +1870,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.21",
- "version_normalized": "5.4.21.0",
+ "version": "v5.4.23",
+ "version_normalized": "5.4.23.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "d4ce417ebcb0b7d090b4c178ed6d3accc518e8bd"
+ "reference": "4b842fc4b61609e0a155a114082bd94e31e98287"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/d4ce417ebcb0b7d090b4c178ed6d3accc518e8bd",
- "reference": "d4ce417ebcb0b7d090b4c178ed6d3accc518e8bd",
+ "url": "https://api.github.com/repos/symfony/process/zipball/4b842fc4b61609e0a155a114082bd94e31e98287",
+ "reference": "4b842fc4b61609e0a155a114082bd94e31e98287",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2023-02-21T19:46:44+00:00",
+ "time": "2023-04-18T13:50:24+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1919,7 +1915,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.21"
+ "source": "https://github.com/symfony/process/tree/v5.4.23"
},
"funding": [
{
@@ -2025,17 +2021,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.21",
- "version_normalized": "5.4.21.0",
+ "version": "v5.4.22",
+ "version_normalized": "5.4.22.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "edac10d167b78b1d90f46a80320d632de0bd9f2f"
+ "reference": "8036a4c76c0dd29e60b6a7cafcacc50cf088ea62"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/edac10d167b78b1d90f46a80320d632de0bd9f2f",
- "reference": "edac10d167b78b1d90f46a80320d632de0bd9f2f",
+ "url": "https://api.github.com/repos/symfony/string/zipball/8036a4c76c0dd29e60b6a7cafcacc50cf088ea62",
+ "reference": "8036a4c76c0dd29e60b6a7cafcacc50cf088ea62",
"shasum": ""
},
"require": {
@@ -2055,7 +2051,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2023-02-22T08:00:55+00:00",
+ "time": "2023-03-14T06:11:53+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2094,7 +2090,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.21"
+ "source": "https://github.com/symfony/string/tree/v5.4.22"
},
"funding": [
{