summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.spec29
-rw-r--r--installed.json122
2 files changed, 77 insertions, 74 deletions
diff --git a/composer.spec b/composer.spec
index 8e661d9..c3075da 100644
--- a/composer.spec
+++ b/composer.spec
@@ -18,7 +18,7 @@
%bcond_with syslib
%endif
-%global gh_commit 061d154dfdde157cbf453c4695e6af21c0e93903
+%global gh_commit 26a587345daa2772bbe2006f13cd9d7f92b242eb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -26,7 +26,7 @@
%global api_version 2.2.0
%global run_version 2.2.2
-%global upstream_version 2.2.7
+%global upstream_version 2.2.8
#global upstream_prever RC1
#global upstream_lower rc1
@@ -162,26 +162,26 @@ Requires: ca-certificates
Provides: bundled(php-composer-ca-bundle) = 1.3.1
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
Provides: bundled(php-composer-pcre) = 1.0.1
-Provides: bundled(php-composer-semver) = 3.2.9
+Provides: bundled(php-composer-semver) = 3.3.0
Provides: bundled(php-composer-spdx-licenses) = 1.5.6
-Provides: bundled(php-composer-xdebug-handler) = 3.0.2
+Provides: bundled(php-composer-xdebug-handler) = 3.0.3
Provides: bundled(php-justinrainbow-json-schema) = 5.2.11
Provides: bundled(php-psr-container) = 1.1.1
Provides: bundled(php-psr-log) = 1.1.4
Provides: bundled(php-react-promise) = v2.9.0
Provides: bundled(php-seld-jsonlint) = 1.8.3
Provides: bundled(php-seld-phar-utils) = 1.2.0
-Provides: bundled(php-symfony-console) = v5.4.3
+Provides: bundled(php-symfony-console) = v5.4.5
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.0
-Provides: bundled(php-symfony-filesystem) = v5.4.3
+Provides: bundled(php-symfony-filesystem) = v5.4.6
Provides: bundled(php-symfony-finder) = v5.4.3
-Provides: bundled(php-symfony-polyfill-ctype) = v1.24.0
-Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.24.0
-Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.24.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.24.0
-Provides: bundled(php-symfony-polyfill-php73) = v1.24.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.24.0
-Provides: bundled(php-symfony-process) = v5.4.3
+Provides: bundled(php-symfony-polyfill-ctype) = v1.25.0
+Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.25.0
+Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.25.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.25.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.25.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.25.0
+Provides: bundled(php-symfony-process) = v5.4.5
Provides: bundled(php-symfony-service-contracts) = v2.5.0
Provides: bundled(php-symfony-string) = v5.4.3
%endif
@@ -408,6 +408,9 @@ exit $ret
%changelog
+* Tue Mar 15 2022 Remi Collet <remi@remirepo.net> - 2.2.8-1
+- update to 2.2.8
+
* Fri Feb 25 2022 Remi Collet <remi@remirepo.net> - 2.2.7-1
- update to 2.2.7
diff --git a/installed.json b/installed.json
index 779b137..b9fa2c7 100644
--- a/installed.json
+++ b/installed.json
@@ -227,17 +227,17 @@
},
{
"name": "composer/semver",
- "version": "3.2.9",
- "version_normalized": "3.2.9.0",
+ "version": "3.3.0",
+ "version_normalized": "3.3.0.0",
"source": {
"type": "git",
"url": "https://github.com/composer/semver.git",
- "reference": "a951f614bd64dcd26137bc9b7b2637ddcfc57649"
+ "reference": "f79c90ad4e9b41ac4dfc5d77bf398cf61fbd718b"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/semver/zipball/a951f614bd64dcd26137bc9b7b2637ddcfc57649",
- "reference": "a951f614bd64dcd26137bc9b7b2637ddcfc57649",
+ "url": "https://api.github.com/repos/composer/semver/zipball/f79c90ad4e9b41ac4dfc5d77bf398cf61fbd718b",
+ "reference": "f79c90ad4e9b41ac4dfc5d77bf398cf61fbd718b",
"shasum": ""
},
"require": {
@@ -247,7 +247,7 @@
"phpstan/phpstan": "^1.4",
"symfony/phpunit-bridge": "^4.2 || ^5"
},
- "time": "2022-02-04T13:58:43+00:00",
+ "time": "2022-03-15T08:35:57+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -291,7 +291,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/semver/issues",
- "source": "https://github.com/composer/semver/tree/3.2.9"
+ "source": "https://github.com/composer/semver/tree/3.3.0"
},
"funding": [
{
@@ -394,21 +394,21 @@
},
{
"name": "composer/xdebug-handler",
- "version": "3.0.2",
- "version_normalized": "3.0.2.0",
+ "version": "3.0.3",
+ "version_normalized": "3.0.3.0",
"source": {
"type": "git",
"url": "https://github.com/composer/xdebug-handler.git",
- "reference": "b11b961ef6b11e380e81a20b27c8cad54eeefe61"
+ "reference": "ced299686f41dce890debac69273b47ffe98a40c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/xdebug-handler/zipball/b11b961ef6b11e380e81a20b27c8cad54eeefe61",
- "reference": "b11b961ef6b11e380e81a20b27c8cad54eeefe61",
+ "url": "https://api.github.com/repos/composer/xdebug-handler/zipball/ced299686f41dce890debac69273b47ffe98a40c",
+ "reference": "ced299686f41dce890debac69273b47ffe98a40c",
"shasum": ""
},
"require": {
- "composer/pcre": "^1",
+ "composer/pcre": "^1 || ^2 || ^3",
"php": "^7.2.5 || ^8.0",
"psr/log": "^1 || ^2 || ^3"
},
@@ -417,7 +417,7 @@
"phpstan/phpstan-strict-rules": "^1.1",
"symfony/phpunit-bridge": "^6.0"
},
- "time": "2022-02-24T20:53:32+00:00",
+ "time": "2022-02-25T21:32:43+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -443,7 +443,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/xdebug-handler/issues",
- "source": "https://github.com/composer/xdebug-handler/tree/3.0.2"
+ "source": "https://github.com/composer/xdebug-handler/tree/3.0.3"
},
"funding": [
{
@@ -836,17 +836,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.3",
- "version_normalized": "5.4.3.0",
+ "version": "v5.4.5",
+ "version_normalized": "5.4.5.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "a2a86ec353d825c75856c6fd14fac416a7bdb6b8"
+ "reference": "d8111acc99876953f52fe16d4c50eb60940d49ad"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/a2a86ec353d825c75856c6fd14fac416a7bdb6b8",
- "reference": "a2a86ec353d825c75856c6fd14fac416a7bdb6b8",
+ "url": "https://api.github.com/repos/symfony/console/zipball/d8111acc99876953f52fe16d4c50eb60940d49ad",
+ "reference": "d8111acc99876953f52fe16d4c50eb60940d49ad",
"shasum": ""
},
"require": {
@@ -884,7 +884,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2022-01-26T16:28:35+00:00",
+ "time": "2022-02-24T12:45:35+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -918,7 +918,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.3"
+ "source": "https://github.com/symfony/console/tree/v5.4.5"
},
"funding": [
{
@@ -1008,17 +1008,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.3",
- "version_normalized": "5.4.3.0",
+ "version": "v5.4.6",
+ "version_normalized": "5.4.6.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "0f0c4bf1840420f4aef3f32044a9dbb24682731b"
+ "reference": "d53a45039974952af7f7ebc461ccdd4295e29440"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/0f0c4bf1840420f4aef3f32044a9dbb24682731b",
- "reference": "0f0c4bf1840420f4aef3f32044a9dbb24682731b",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/d53a45039974952af7f7ebc461ccdd4295e29440",
+ "reference": "d53a45039974952af7f7ebc461ccdd4295e29440",
"shasum": ""
},
"require": {
@@ -1027,7 +1027,7 @@
"symfony/polyfill-mbstring": "~1.8",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-01-02T09:53:40+00:00",
+ "time": "2022-03-02T12:42:23+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1055,7 +1055,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.3"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.6"
},
"funding": [
{
@@ -1141,8 +1141,8 @@
},
{
"name": "symfony/polyfill-ctype",
- "version": "v1.24.0",
- "version_normalized": "1.24.0.0",
+ "version": "v1.25.0",
+ "version_normalized": "1.25.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-ctype.git",
@@ -1206,7 +1206,7 @@
"portable"
],
"support": {
- "source": "https://github.com/symfony/polyfill-ctype/tree/v1.24.0"
+ "source": "https://github.com/symfony/polyfill-ctype/tree/v1.25.0"
},
"funding": [
{
@@ -1226,8 +1226,8 @@
},
{
"name": "symfony/polyfill-intl-grapheme",
- "version": "v1.24.0",
- "version_normalized": "1.24.0.0",
+ "version": "v1.25.0",
+ "version_normalized": "1.25.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-grapheme.git",
@@ -1290,7 +1290,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.24.0"
+ "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.25.0"
},
"funding": [
{
@@ -1310,8 +1310,8 @@
},
{
"name": "symfony/polyfill-intl-normalizer",
- "version": "v1.24.0",
- "version_normalized": "1.24.0.0",
+ "version": "v1.25.0",
+ "version_normalized": "1.25.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-normalizer.git",
@@ -1377,7 +1377,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.24.0"
+ "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.25.0"
},
"funding": [
{
@@ -1397,8 +1397,8 @@
},
{
"name": "symfony/polyfill-mbstring",
- "version": "v1.24.0",
- "version_normalized": "1.24.0.0",
+ "version": "v1.25.0",
+ "version_normalized": "1.25.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-mbstring.git",
@@ -1463,7 +1463,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.24.0"
+ "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.25.0"
},
"funding": [
{
@@ -1483,8 +1483,8 @@
},
{
"name": "symfony/polyfill-php73",
- "version": "v1.24.0",
- "version_normalized": "1.24.0.0",
+ "version": "v1.25.0",
+ "version_normalized": "1.25.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php73.git",
@@ -1545,7 +1545,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php73/tree/v1.24.0"
+ "source": "https://github.com/symfony/polyfill-php73/tree/v1.25.0"
},
"funding": [
{
@@ -1565,23 +1565,23 @@
},
{
"name": "symfony/polyfill-php80",
- "version": "v1.24.0",
- "version_normalized": "1.24.0.0",
+ "version": "v1.25.0",
+ "version_normalized": "1.25.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php80.git",
- "reference": "57b712b08eddb97c762a8caa32c84e037892d2e9"
+ "reference": "4407588e0d3f1f52efb65fbe92babe41f37fe50c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/57b712b08eddb97c762a8caa32c84e037892d2e9",
- "reference": "57b712b08eddb97c762a8caa32c84e037892d2e9",
+ "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/4407588e0d3f1f52efb65fbe92babe41f37fe50c",
+ "reference": "4407588e0d3f1f52efb65fbe92babe41f37fe50c",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2021-09-13T13:58:33+00:00",
+ "time": "2022-03-04T08:16:47+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -1631,7 +1631,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php80/tree/v1.24.0"
+ "source": "https://github.com/symfony/polyfill-php80/tree/v1.25.0"
},
"funding": [
{
@@ -1651,24 +1651,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.3",
- "version_normalized": "5.4.3.0",
+ "version": "v5.4.5",
+ "version_normalized": "5.4.5.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "553f50487389a977eb31cf6b37faae56da00f753"
+ "reference": "95440409896f90a5f85db07a32b517ecec17fa4c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/553f50487389a977eb31cf6b37faae56da00f753",
- "reference": "553f50487389a977eb31cf6b37faae56da00f753",
+ "url": "https://api.github.com/repos/symfony/process/zipball/95440409896f90a5f85db07a32b517ecec17fa4c",
+ "reference": "95440409896f90a5f85db07a32b517ecec17fa4c",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-01-26T16:28:35+00:00",
+ "time": "2022-01-30T18:16:22+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1696,7 +1696,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.3"
+ "source": "https://github.com/symfony/process/tree/v5.4.5"
},
"funding": [
{
@@ -1836,12 +1836,12 @@
"type": "library",
"installation-source": "dist",
"autoload": {
- "psr-4": {
- "Symfony\\Component\\String\\": ""
- },
"files": [
"Resources/functions.php"
],
+ "psr-4": {
+ "Symfony\\Component\\String\\": ""
+ },
"exclude-from-classmap": [
"/Tests/"
]