summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-01 14:01:56 +0200
committerRemi Collet <remi@php.net>2022-07-01 14:01:56 +0200
commitf41724738a5b4b4eb598d214da5980c4ece801a8 (patch)
treee0a3c4e0957662318805702a9e64df46cc83bfbf
parent6b54f6b62f0585ceb45f8f5ab33df3521461dcf2 (diff)
update to 2.3.8
-rw-r--r--composer-bash-completion2
-rw-r--r--composer.spec17
-rw-r--r--installed.json48
3 files changed, 35 insertions, 32 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index a921aa7..f24f512 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -22,7 +22,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "-sbash" "-c$cword" "-S2.3.7")
+ local completecmd=("$sf_cmd" "_complete" "-sbash" "-c$cword" "-S2.3.8")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.spec b/composer.spec
index 9acb522..75508a9 100644
--- a/composer.spec
+++ b/composer.spec
@@ -18,7 +18,7 @@
%bcond_with syslib
%endif
-%global gh_commit 10cd375cf85dede2ff417ceab517ef9a0dc55407
+%global gh_commit f69e63262dadd02b3b6edade339c7badda2939c2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -26,7 +26,7 @@
%global api_version 2.3.0
%global run_version 2.2.2
-%global upstream_version 2.3.7
+%global upstream_version 2.3.8
#global upstream_prever RC2
#global upstream_lower rc2
@@ -41,7 +41,7 @@
Name: composer
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: Dependency Manager for PHP
# composer and all dependencies are MIT
@@ -179,8 +179,8 @@ Provides: bundled(php-psr-log) = 1.1.4
Provides: bundled(php-react-promise) = v2.9.0
Provides: bundled(php-seld-jsonlint) = 1.9.0
Provides: bundled(php-seld-phar-utils) = 1.2.0
-Provides: bundled(php-symfony-console) = v5.4.9
-Provides: bundled(php-symfony-deprecation-contracts) = v2.5.1
+Provides: bundled(php-symfony-console) = v5.4.10
+Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
Provides: bundled(php-symfony-filesystem) = v5.4.9
Provides: bundled(php-symfony-finder) = v5.4.8
Provides: bundled(php-symfony-polyfill-ctype) = v1.26.0
@@ -190,8 +190,8 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.26.0
Provides: bundled(php-symfony-polyfill-php73) = v1.26.0
Provides: bundled(php-symfony-polyfill-php80) = v1.26.0
Provides: bundled(php-symfony-process) = v5.4.8
-Provides: bundled(php-symfony-service-contracts) = v2.5.1
-Provides: bundled(php-symfony-string) = v5.4.9
+Provides: bundled(php-symfony-service-contracts) = v2.5.2
+Provides: bundled(php-symfony-string) = v5.4.10
%endif
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -424,6 +424,9 @@ exit $ret
%changelog
+* Fri Jul 1 2022 Remi Collet <remi@remirepo.net> - 2.3.8-1
+- update to 2.3.8
+
* Wed Jun 22 2022 Remi Collet <remi@remirepo.net> - 2.3.7-2
- add bash completion file
diff --git a/installed.json b/installed.json
index b71f19b..17c3a7e 100644
--- a/installed.json
+++ b/installed.json
@@ -837,17 +837,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.9",
- "version_normalized": "5.4.9.0",
+ "version": "v5.4.10",
+ "version_normalized": "5.4.10.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "829d5d1bf60b2efeb0887b7436873becc71a45eb"
+ "reference": "4d671ab4ddac94ee439ea73649c69d9d200b5000"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/829d5d1bf60b2efeb0887b7436873becc71a45eb",
- "reference": "829d5d1bf60b2efeb0887b7436873becc71a45eb",
+ "url": "https://api.github.com/repos/symfony/console/zipball/4d671ab4ddac94ee439ea73649c69d9d200b5000",
+ "reference": "4d671ab4ddac94ee439ea73649c69d9d200b5000",
"shasum": ""
},
"require": {
@@ -885,7 +885,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2022-05-18T06:17:34+00:00",
+ "time": "2022-06-26T13:00:04+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -919,7 +919,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.9"
+ "source": "https://github.com/symfony/console/tree/v5.4.10"
},
"funding": [
{
@@ -939,8 +939,8 @@
},
{
"name": "symfony/deprecation-contracts",
- "version": "v2.5.1",
- "version_normalized": "2.5.1.0",
+ "version": "v2.5.2",
+ "version_normalized": "2.5.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/deprecation-contracts.git",
@@ -989,7 +989,7 @@
"description": "A generic function and convention to trigger deprecation notices",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/deprecation-contracts/tree/v2.5.1"
+ "source": "https://github.com/symfony/deprecation-contracts/tree/v2.5.2"
},
"funding": [
{
@@ -1717,17 +1717,17 @@
},
{
"name": "symfony/service-contracts",
- "version": "v2.5.1",
- "version_normalized": "2.5.1.0",
+ "version": "v2.5.2",
+ "version_normalized": "2.5.2.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/service-contracts.git",
- "reference": "24d9dc654b83e91aa59f9d167b131bc3b5bea24c"
+ "reference": "4b426aac47d6427cc1a1d0f7e2ac724627f5966c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/service-contracts/zipball/24d9dc654b83e91aa59f9d167b131bc3b5bea24c",
- "reference": "24d9dc654b83e91aa59f9d167b131bc3b5bea24c",
+ "url": "https://api.github.com/repos/symfony/service-contracts/zipball/4b426aac47d6427cc1a1d0f7e2ac724627f5966c",
+ "reference": "4b426aac47d6427cc1a1d0f7e2ac724627f5966c",
"shasum": ""
},
"require": {
@@ -1741,7 +1741,7 @@
"suggest": {
"symfony/service-implementation": ""
},
- "time": "2022-03-13T20:07:29+00:00",
+ "time": "2022-05-30T19:17:29+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -1783,7 +1783,7 @@
"standards"
],
"support": {
- "source": "https://github.com/symfony/service-contracts/tree/v2.5.1"
+ "source": "https://github.com/symfony/service-contracts/tree/v2.5.2"
},
"funding": [
{
@@ -1803,17 +1803,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.9",
- "version_normalized": "5.4.9.0",
+ "version": "v5.4.10",
+ "version_normalized": "5.4.10.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "985e6a9703ef5ce32ba617c9c7d97873bb7b2a99"
+ "reference": "4432bc7df82a554b3e413a8570ce2fea90e94097"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/985e6a9703ef5ce32ba617c9c7d97873bb7b2a99",
- "reference": "985e6a9703ef5ce32ba617c9c7d97873bb7b2a99",
+ "url": "https://api.github.com/repos/symfony/string/zipball/4432bc7df82a554b3e413a8570ce2fea90e94097",
+ "reference": "4432bc7df82a554b3e413a8570ce2fea90e94097",
"shasum": ""
},
"require": {
@@ -1833,7 +1833,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2022-04-19T10:40:37+00:00",
+ "time": "2022-06-26T15:57:47+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1872,7 +1872,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.9"
+ "source": "https://github.com/symfony/string/tree/v5.4.10"
},
"funding": [
{