summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-09-29 14:21:19 +0200
committerRemi Collet <remi@php.net>2023-09-29 14:21:19 +0200
commitedf3b8f6a41d3ebf1e2a0f7aeb34d19f8a954634 (patch)
treeca19f44323fc890b6d314e9b1da484adaafc1917
parent90465bb548610cbcf3587f366975a05bcba5f3c4 (diff)
update to 2.6.4
-rw-r--r--composer-bash-completion2
-rw-r--r--composer.spec9
-rw-r--r--installed.json14
3 files changed, 14 insertions, 11 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index 1ea6ff2..5da62d0 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.6.3")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.6.4")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.spec b/composer.spec
index 514202a..8305293 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit ff477832e6d838a736556d4a39a3b80f4412abfd
+%global gh_commit d75d17c16a863438027d1d96401cddcd6aa5bb60
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.6.0
%global run_version 2.2.2
-%global upstream_version 2.6.3
+%global upstream_version 2.6.4
#global upstream_prever RC1
#global upstream_lower rc1
@@ -87,7 +87,7 @@ Provides: bundled(php-composer-pcre) = 2.1.0
Provides: bundled(php-composer-semver) = 3.4.0
Provides: bundled(php-composer-spdx-licenses) = 1.5.7
Provides: bundled(php-composer-xdebug-handler) = 3.0.3
-Provides: bundled(php-justinrainbow-json-schema) = 5.2.12
+Provides: bundled(php-justinrainbow-json-schema) = v5.2.13
Provides: bundled(php-psr-container) = 1.1.1
Provides: bundled(php-psr-log) = 1.1.4
Provides: bundled(php-react-promise) = v3.0.0
@@ -249,6 +249,9 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Fri Sep 29 2023 Remi Collet <remi@remirepo.net> - 2.6.4-1
+- update to 2.6.4
+
* Fri Sep 15 2023 Remi Collet <remi@remirepo.net> - 2.6.3-1
- update to 2.6.3
diff --git a/installed.json b/installed.json
index fdd00df..9ed1ced 100644
--- a/installed.json
+++ b/installed.json
@@ -539,17 +539,17 @@
},
{
"name": "justinrainbow/json-schema",
- "version": "5.2.12",
- "version_normalized": "5.2.12.0",
+ "version": "v5.2.13",
+ "version_normalized": "5.2.13.0",
"source": {
"type": "git",
"url": "https://github.com/justinrainbow/json-schema.git",
- "reference": "ad87d5a5ca981228e0e205c2bc7dfb8e24559b60"
+ "reference": "fbbe7e5d79f618997bc3332a6f49246036c45793"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/justinrainbow/json-schema/zipball/ad87d5a5ca981228e0e205c2bc7dfb8e24559b60",
- "reference": "ad87d5a5ca981228e0e205c2bc7dfb8e24559b60",
+ "url": "https://api.github.com/repos/justinrainbow/json-schema/zipball/fbbe7e5d79f618997bc3332a6f49246036c45793",
+ "reference": "fbbe7e5d79f618997bc3332a6f49246036c45793",
"shasum": ""
},
"require": {
@@ -560,7 +560,7 @@
"json-schema/json-schema-test-suite": "1.2.0",
"phpunit/phpunit": "^4.8.35"
},
- "time": "2022-04-13T08:02:27+00:00",
+ "time": "2023-09-26T02:20:38+00:00",
"bin": [
"bin/validate-json"
],
@@ -606,7 +606,7 @@
],
"support": {
"issues": "https://github.com/justinrainbow/json-schema/issues",
- "source": "https://github.com/justinrainbow/json-schema/tree/5.2.12"
+ "source": "https://github.com/justinrainbow/json-schema/tree/v5.2.13"
},
"install-path": "../justinrainbow/json-schema"
},