summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-04-20 12:41:06 +0200
committerRemi Collet <remi@php.net>2024-04-20 12:41:06 +0200
commitd7b5339e3ce046e7d21fd2585d9bd669f02ef982 (patch)
treeef3bf58b95b1d0cf59fb59e69c230c28a4fccfb9
parentaed1b1b8b9b6694c59ea2de2278b62592841f384 (diff)
update to 2.7.3
-rw-r--r--composer-bash-completion2
-rw-r--r--composer-noxdg.patch8
-rw-r--r--composer.spec21
-rw-r--r--installed.json108
4 files changed, 71 insertions, 68 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index 7b1d166..8e97096 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.7.2")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.7.3")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer-noxdg.patch b/composer-noxdg.patch
index 73195e7..8971527 100644
--- a/composer-noxdg.patch
+++ b/composer-noxdg.patch
@@ -1,7 +1,7 @@
diff -up ./src/Composer/Factory.php.noxdg ./src/Composer/Factory.php
---- ./src/Composer/Factory.php.noxdg 2022-03-16 09:51:30.398977729 +0100
-+++ ./src/Composer/Factory.php 2022-03-16 09:52:14.113841110 +0100
-@@ -665,6 +665,10 @@ class Factory
+--- ./src/Composer/Factory.php.noxdg 2024-04-20 12:34:54.442117723 +0200
++++ ./src/Composer/Factory.php 2024-04-20 12:35:39.497640757 +0200
+@@ -680,6 +680,10 @@ class Factory
private static function useXdg(): bool
{
@@ -10,5 +10,5 @@ diff -up ./src/Composer/Factory.php.noxdg ./src/Composer/Factory.php
+ return false;
+
foreach (array_keys($_SERVER) as $key) {
- if (strpos($key, 'XDG_') === 0) {
+ if (strpos((string) $key, 'XDG_') === 0) {
return true;
diff --git a/composer.spec b/composer.spec
index 3d04281..d0c7095 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit b826edb791571ab1eaf281eb1bd6e181a1192adc
+%global gh_commit e49be96f3bccd183c9ff1313686c06cf898ba4be
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.6.0
%global run_version 2.2.2
-%global upstream_version 2.7.2
+%global upstream_version 2.7.3
#global upstream_prever RC1
#global upstream_lower rc1
@@ -80,13 +80,13 @@ Requires: php-cli
Requires: ca-certificates
# Bundled libraries
# License MIT
-Provides: bundled(php-composer-ca-bundle) = 1.4.1
-Provides: bundled(php-composer-class-map-generator) = 1.1.0
+Provides: bundled(php-composer-ca-bundle) = 1.5.0
+Provides: bundled(php-composer-class-map-generator) = 1.1.1
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
-Provides: bundled(php-composer-pcre) = 2.1.2
+Provides: bundled(php-composer-pcre) = 2.1.3
Provides: bundled(php-composer-semver) = 3.4.0
Provides: bundled(php-composer-spdx-licenses) = 1.5.8
-Provides: bundled(php-composer-xdebug-handler) = 3.0.3
+Provides: bundled(php-composer-xdebug-handler) = 3.0.4
Provides: bundled(php-justinrainbow-json-schema) = v5.2.13
Provides: bundled(php-psr-container) = 1.1.1
Provides: bundled(php-psr-log) = 1.1.4
@@ -95,8 +95,8 @@ Provides: bundled(php-seld-jsonlint) = 1.10.2
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.2
Provides: bundled(php-symfony-console) = v5.4.36
-Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
-Provides: bundled(php-symfony-filesystem) = v5.4.35
+Provides: bundled(php-symfony-deprecation-contracts) = v2.5.3
+Provides: bundled(php-symfony-filesystem) = v5.4.38
Provides: bundled(php-symfony-finder) = v5.4.35
Provides: bundled(php-symfony-polyfill-ctype) = v1.29.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.29.0
@@ -106,7 +106,7 @@ Provides: bundled(php-symfony-polyfill-php73) = v1.29.0
Provides: bundled(php-symfony-polyfill-php80) = v1.29.0
Provides: bundled(php-symfony-polyfill-php81) = v1.29.0
Provides: bundled(php-symfony-process) = v5.4.36
-Provides: bundled(php-symfony-service-contracts) = v2.5.2
+Provides: bundled(php-symfony-service-contracts) = v2.5.3
Provides: bundled(php-symfony-string) = v5.4.36
# From composer.json, suggest
@@ -249,6 +249,9 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Sat Apr 20 2024 Remi Collet <remi@remirepo.net> - 2.7.3-1
+- update to 2.7.3
+
* Tue Mar 12 2024 Remi Collet <remi@remirepo.net> - 2.7.2-1
- update to 2.7.2
diff --git a/installed.json b/installed.json
index 2cce862..903fb91 100644
--- a/installed.json
+++ b/installed.json
@@ -2,31 +2,31 @@
"packages": [
{
"name": "composer/ca-bundle",
- "version": "1.4.1",
- "version_normalized": "1.4.1.0",
+ "version": "1.5.0",
+ "version_normalized": "1.5.0.0",
"source": {
"type": "git",
"url": "https://github.com/composer/ca-bundle.git",
- "reference": "3ce240142f6d59b808dd65c1f52f7a1c252e6cfd"
+ "reference": "0c5ccfcfea312b5c5a190a21ac5cef93f74baf99"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/ca-bundle/zipball/3ce240142f6d59b808dd65c1f52f7a1c252e6cfd",
- "reference": "3ce240142f6d59b808dd65c1f52f7a1c252e6cfd",
+ "url": "https://api.github.com/repos/composer/ca-bundle/zipball/0c5ccfcfea312b5c5a190a21ac5cef93f74baf99",
+ "reference": "0c5ccfcfea312b5c5a190a21ac5cef93f74baf99",
"shasum": ""
},
"require": {
"ext-openssl": "*",
"ext-pcre": "*",
- "php": "^5.3.2 || ^7.0 || ^8.0"
+ "php": "^7.2 || ^8.0"
},
"require-dev": {
- "phpstan/phpstan": "^0.12.55",
+ "phpstan/phpstan": "^1.10",
"psr/log": "^1.0",
"symfony/phpunit-bridge": "^4.2 || ^5",
- "symfony/process": "^2.5 || ^3.0 || ^4.0 || ^5.0 || ^6.0 || ^7.0"
+ "symfony/process": "^4.0 || ^5.0 || ^6.0 || ^7.0"
},
- "time": "2024-02-23T10:16:52+00:00",
+ "time": "2024-03-15T14:00:32+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -61,7 +61,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/ca-bundle/issues",
- "source": "https://github.com/composer/ca-bundle/tree/1.4.1"
+ "source": "https://github.com/composer/ca-bundle/tree/1.5.0"
},
"funding": [
{
@@ -81,17 +81,17 @@
},
{
"name": "composer/class-map-generator",
- "version": "1.1.0",
- "version_normalized": "1.1.0.0",
+ "version": "1.1.1",
+ "version_normalized": "1.1.1.0",
"source": {
"type": "git",
"url": "https://github.com/composer/class-map-generator.git",
- "reference": "953cc4ea32e0c31f2185549c7d216d7921f03da9"
+ "reference": "8286a62d243312ed99b3eee20d5005c961adb311"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/class-map-generator/zipball/953cc4ea32e0c31f2185549c7d216d7921f03da9",
- "reference": "953cc4ea32e0c31f2185549c7d216d7921f03da9",
+ "url": "https://api.github.com/repos/composer/class-map-generator/zipball/8286a62d243312ed99b3eee20d5005c961adb311",
+ "reference": "8286a62d243312ed99b3eee20d5005c961adb311",
"shasum": ""
},
"require": {
@@ -107,7 +107,7 @@
"symfony/filesystem": "^5.4 || ^6",
"symfony/phpunit-bridge": "^5"
},
- "time": "2023-06-30T13:58:57+00:00",
+ "time": "2024-03-15T12:53:41+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -137,7 +137,7 @@
],
"support": {
"issues": "https://github.com/composer/class-map-generator/issues",
- "source": "https://github.com/composer/class-map-generator/tree/1.1.0"
+ "source": "https://github.com/composer/class-map-generator/tree/1.1.1"
},
"funding": [
{
@@ -229,17 +229,17 @@
},
{
"name": "composer/pcre",
- "version": "2.1.2",
- "version_normalized": "2.1.2.0",
+ "version": "2.1.3",
+ "version_normalized": "2.1.3.0",
"source": {
"type": "git",
"url": "https://github.com/composer/pcre.git",
- "reference": "02b8774a434b1b71edd8824440ceac1e3e49ee2b"
+ "reference": "540af382c97b83c628227d5f87cf56466d476191"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/pcre/zipball/02b8774a434b1b71edd8824440ceac1e3e49ee2b",
- "reference": "02b8774a434b1b71edd8824440ceac1e3e49ee2b",
+ "url": "https://api.github.com/repos/composer/pcre/zipball/540af382c97b83c628227d5f87cf56466d476191",
+ "reference": "540af382c97b83c628227d5f87cf56466d476191",
"shasum": ""
},
"require": {
@@ -250,7 +250,7 @@
"phpstan/phpstan-strict-rules": "^1.1",
"symfony/phpunit-bridge": "^5"
},
- "time": "2024-03-07T14:52:56+00:00",
+ "time": "2024-03-19T09:03:05+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -283,7 +283,7 @@
],
"support": {
"issues": "https://github.com/composer/pcre/issues",
- "source": "https://github.com/composer/pcre/tree/2.1.2"
+ "source": "https://github.com/composer/pcre/tree/2.1.3"
},
"funding": [
{
@@ -470,17 +470,17 @@
},
{
"name": "composer/xdebug-handler",
- "version": "3.0.3",
- "version_normalized": "3.0.3.0",
+ "version": "3.0.4",
+ "version_normalized": "3.0.4.0",
"source": {
"type": "git",
"url": "https://github.com/composer/xdebug-handler.git",
- "reference": "ced299686f41dce890debac69273b47ffe98a40c"
+ "reference": "4f988f8fdf580d53bdb2d1278fe93d1ed5462255"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/xdebug-handler/zipball/ced299686f41dce890debac69273b47ffe98a40c",
- "reference": "ced299686f41dce890debac69273b47ffe98a40c",
+ "url": "https://api.github.com/repos/composer/xdebug-handler/zipball/4f988f8fdf580d53bdb2d1278fe93d1ed5462255",
+ "reference": "4f988f8fdf580d53bdb2d1278fe93d1ed5462255",
"shasum": ""
},
"require": {
@@ -491,9 +491,9 @@
"require-dev": {
"phpstan/phpstan": "^1.0",
"phpstan/phpstan-strict-rules": "^1.1",
- "symfony/phpunit-bridge": "^6.0"
+ "phpunit/phpunit": "^8.5 || ^9.6 || ^10.5"
},
- "time": "2022-02-25T21:32:43+00:00",
+ "time": "2024-03-26T18:29:49+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -517,9 +517,9 @@
"performance"
],
"support": {
- "irc": "irc://irc.freenode.org/composer",
+ "irc": "ircs://irc.libera.chat:6697/composer",
"issues": "https://github.com/composer/xdebug-handler/issues",
- "source": "https://github.com/composer/xdebug-handler/tree/3.0.3"
+ "source": "https://github.com/composer/xdebug-handler/tree/3.0.4"
},
"funding": [
{
@@ -1076,23 +1076,23 @@
},
{
"name": "symfony/deprecation-contracts",
- "version": "v2.5.2",
- "version_normalized": "2.5.2.0",
+ "version": "v2.5.3",
+ "version_normalized": "2.5.3.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/deprecation-contracts.git",
- "reference": "e8b495ea28c1d97b5e0c121748d6f9b53d075c66"
+ "reference": "80d075412b557d41002320b96a096ca65aa2c98d"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/deprecation-contracts/zipball/e8b495ea28c1d97b5e0c121748d6f9b53d075c66",
- "reference": "e8b495ea28c1d97b5e0c121748d6f9b53d075c66",
+ "url": "https://api.github.com/repos/symfony/deprecation-contracts/zipball/80d075412b557d41002320b96a096ca65aa2c98d",
+ "reference": "80d075412b557d41002320b96a096ca65aa2c98d",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2022-01-02T09:53:40+00:00",
+ "time": "2023-01-24T14:02:46+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -1126,7 +1126,7 @@
"description": "A generic function and convention to trigger deprecation notices",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/deprecation-contracts/tree/v2.5.2"
+ "source": "https://github.com/symfony/deprecation-contracts/tree/v2.5.3"
},
"funding": [
{
@@ -1146,17 +1146,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.35",
- "version_normalized": "5.4.35.0",
+ "version": "v5.4.38",
+ "version_normalized": "5.4.38.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "5a553607d4ffbfa9c0ab62facadea296c9db7086"
+ "reference": "899330a01056077271e2f614c7b28b0379a671eb"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/5a553607d4ffbfa9c0ab62facadea296c9db7086",
- "reference": "5a553607d4ffbfa9c0ab62facadea296c9db7086",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/899330a01056077271e2f614c7b28b0379a671eb",
+ "reference": "899330a01056077271e2f614c7b28b0379a671eb",
"shasum": ""
},
"require": {
@@ -1165,7 +1165,7 @@
"symfony/polyfill-mbstring": "~1.8",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2024-01-23T13:51:25+00:00",
+ "time": "2024-03-21T08:05:07+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1193,7 +1193,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.35"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.38"
},
"funding": [
{
@@ -1915,17 +1915,17 @@
},
{
"name": "symfony/service-contracts",
- "version": "v2.5.2",
- "version_normalized": "2.5.2.0",
+ "version": "v2.5.3",
+ "version_normalized": "2.5.3.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/service-contracts.git",
- "reference": "4b426aac47d6427cc1a1d0f7e2ac724627f5966c"
+ "reference": "a2329596ddc8fd568900e3fc76cba42489ecc7f3"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/service-contracts/zipball/4b426aac47d6427cc1a1d0f7e2ac724627f5966c",
- "reference": "4b426aac47d6427cc1a1d0f7e2ac724627f5966c",
+ "url": "https://api.github.com/repos/symfony/service-contracts/zipball/a2329596ddc8fd568900e3fc76cba42489ecc7f3",
+ "reference": "a2329596ddc8fd568900e3fc76cba42489ecc7f3",
"shasum": ""
},
"require": {
@@ -1939,7 +1939,7 @@
"suggest": {
"symfony/service-implementation": ""
},
- "time": "2022-05-30T19:17:29+00:00",
+ "time": "2023-04-21T15:04:16+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -1981,7 +1981,7 @@
"standards"
],
"support": {
- "source": "https://github.com/symfony/service-contracts/tree/v2.5.2"
+ "source": "https://github.com/symfony/service-contracts/tree/v2.5.3"
},
"funding": [
{