summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-10-03 07:39:40 +0200
committerRemi Collet <remi@php.net>2024-10-03 07:39:40 +0200
commitc817ff603ecc44676b45cc7b21c92397e0b2603f (patch)
treef9f068a868b4073b37decf92ef16306095fce612
parent7f4d1b75d381c9d4c3ec95fec4f2fa9856bb526d (diff)
update to 2.8.0
-rw-r--r--composer-bash-completion2
-rw-r--r--composer-rpm.patch46
-rw-r--r--composer.json2
-rw-r--r--composer.spec47
-rw-r--r--installed.json202
5 files changed, 158 insertions, 141 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index 1397e05..0e546e7 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.7.9")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.8.0")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer-rpm.patch b/composer-rpm.patch
index 162dcdd..52ed07b 100644
--- a/composer-rpm.patch
+++ b/composer-rpm.patch
@@ -1,7 +1,7 @@
diff -up ./bin/composer.rpm ./bin/composer
---- ./bin/composer.rpm 2023-09-01 11:05:16.000000000 +0200
-+++ ./bin/composer 2023-09-01 11:05:28.156309389 +0200
-@@ -11,7 +11,7 @@ if (PHP_VERSION_ID < 70205) {
+--- ./bin/composer.rpm 2024-10-03 07:10:57.000000000 +0200
++++ ./bin/composer 2024-10-03 07:11:10.751092365 +0200
+@@ -16,7 +16,7 @@ if (PHP_VERSION_ID < 70205) {
}
setlocale(LC_ALL, 'C');
@@ -11,9 +11,9 @@ diff -up ./bin/composer.rpm ./bin/composer
use Composer\Console\Application;
use Composer\XdebugHandler\XdebugHandler;
diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autoload/AutoloadGenerator.php
---- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2023-09-01 11:05:16.000000000 +0200
-+++ ./src/Composer/Autoload/AutoloadGenerator.php 2023-09-01 11:05:28.156309389 +0200
-@@ -448,7 +448,7 @@ EOF;
+--- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2024-10-03 07:10:57.000000000 +0200
++++ ./src/Composer/Autoload/AutoloadGenerator.php 2024-10-03 07:11:10.752092401 +0200
+@@ -458,7 +458,7 @@ EOF;
$filesystem->filePutContentsIfModified($targetDir.'/autoload_real.php', $this->getAutoloadRealFile(true, (bool) $includePathFileContents, $targetDirLoader, (bool) $includeFilesFileContents, $vendorPathCode, $appBaseDirCode, $suffix, $useGlobalIncludePath, $prependAutoloader, $checkPlatform));
$filesystem->safeCopy(__DIR__.'/ClassLoader.php', $targetDir.'/ClassLoader.php');
@@ -23,8 +23,8 @@ diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autolo
if ($this->runScripts) {
$this->eventDispatcher->dispatchScript(ScriptEvents::POST_AUTOLOAD_DUMP, $this->devMode, [], [
diff -up ./src/Composer/Compiler.php.rpm ./src/Composer/Compiler.php
---- ./src/Composer/Compiler.php.rpm 2023-09-01 11:05:16.000000000 +0200
-+++ ./src/Composer/Compiler.php 2023-09-01 11:05:28.156309389 +0200
+--- ./src/Composer/Compiler.php.rpm 2024-10-03 07:10:57.000000000 +0200
++++ ./src/Composer/Compiler.php 2024-10-03 07:11:10.752092401 +0200
@@ -105,7 +105,7 @@ class Compiler
// Add Composer resources
$finder = new Finder();
@@ -35,8 +35,8 @@ diff -up ./src/Composer/Compiler.php.rpm ./src/Composer/Compiler.php
;
foreach ($finder as $file) {
diff -up ./src/Composer/InstalledVersions.php.rpm ./src/Composer/InstalledVersions.php
---- ./src/Composer/InstalledVersions.php.rpm 2023-09-01 11:05:16.000000000 +0200
-+++ ./src/Composer/InstalledVersions.php 2023-09-01 11:05:28.156309389 +0200
+--- ./src/Composer/InstalledVersions.php.rpm 2024-10-03 07:10:57.000000000 +0200
++++ ./src/Composer/InstalledVersions.php 2024-10-03 07:11:10.752092401 +0200
@@ -266,7 +266,7 @@ class InstalledVersions
if (null === self::$installed) {
// only require the installed.php file if this file is loaded from its dumped location,
@@ -56,29 +56,35 @@ diff -up ./src/Composer/InstalledVersions.php.rpm ./src/Composer/InstalledVersio
$required = require __DIR__ . '/installed.php';
self::$installed = $required;
diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
---- ./src/Composer/Json/JsonFile.php.rpm 2023-09-01 11:05:16.000000000 +0200
-+++ ./src/Composer/Json/JsonFile.php 2023-09-01 11:06:16.767233012 +0200
-@@ -40,7 +40,7 @@ class JsonFile
+--- ./src/Composer/Json/JsonFile.php.rpm 2024-10-03 07:11:10.752092401 +0200
++++ ./src/Composer/Json/JsonFile.php 2024-10-03 07:14:54.219192080 +0200
+@@ -41,8 +41,8 @@ class JsonFile
/** @deprecated Use \JSON_UNESCAPED_UNICODE */
public const JSON_UNESCAPED_UNICODE = 256;
- public const COMPOSER_SCHEMA_PATH = __DIR__ . '/../../../res/composer-schema.json';
+- public const LOCK_SCHEMA_PATH = __DIR__ . '/../../../res/composer-lock-schema.json';
+ public const COMPOSER_SCHEMA_PATH = '/usr/share/composer/res/composer-schema.json';
++ public const LOCK_SCHEMA_PATH = '/usr/share/composer/res/composer-lock-schema.json';
public const INDENT_DEFAULT = ' ';
-@@ -229,7 +229,7 @@ class JsonFile
+@@ -231,10 +231,10 @@ class JsonFile
$isComposerSchemaFile = false;
if (null === $schemaFile) {
- $isComposerSchemaFile = true;
-- $schemaFile = self::COMPOSER_SCHEMA_PATH;
-+ $schemaFile = (getenv('BUILDROOT')?:'') . self::COMPOSER_SCHEMA_PATH;
+ if ($schema === self::LOCK_SCHEMA) {
+- $schemaFile = self::LOCK_SCHEMA_PATH;
++ $schemaFile = (getenv('BUILDROOT')?:'') . self::LOCK_SCHEMA_PATH;
+ } else {
+ $isComposerSchemaFile = true;
+- $schemaFile = self::COMPOSER_SCHEMA_PATH;
++ $schemaFile = (getenv('BUILDROOT')?:'') . self::COMPOSER_SCHEMA_PATH;
+ }
}
- // Prepend with file:// only when not using a special schema already (e.g. in the phar)
diff -up ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php.rpm ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php
---- ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php.rpm 2023-08-30 11:31:38.000000000 +0200
-+++ ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php 2023-09-01 11:05:28.156309389 +0200
+--- ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php.rpm 2024-09-25 09:49:53.000000000 +0200
++++ ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php 2024-10-03 07:11:10.752092401 +0200
@@ -125,7 +125,7 @@ class CaBundle
*/
public static function getBundledCaBundlePath()
diff --git a/composer.json b/composer.json
index 7ca64f0..060b41d 100644
--- a/composer.json
+++ b/composer.json
@@ -65,7 +65,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "2.7-dev"
+ "dev-main": "2.8-dev"
},
"phpstan": {
"includes": [
diff --git a/composer.spec b/composer.spec
index 474c371..ab88805 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit e30ccdd665828ae66eb1be78f056e39e1d5f55ab
+%global gh_commit d5e75c21ceeb6829918a75ed63b56c576b4a6261
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.6.0
%global run_version 2.2.2
-%global upstream_version 2.7.9
+%global upstream_version 2.8.0
#global upstream_prever RC1
#global upstream_lower rc1
@@ -80,11 +80,11 @@ Requires: php-cli
Requires: ca-certificates
# Bundled libraries
# License MIT
-Provides: bundled(php-composer-ca-bundle) = 1.5.1
+Provides: bundled(php-composer-ca-bundle) = 1.5.2
Provides: bundled(php-composer-class-map-generator) = 1.3.4
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
Provides: bundled(php-composer-pcre) = 2.3.1
-Provides: bundled(php-composer-semver) = 3.4.2
+Provides: bundled(php-composer-semver) = 3.4.3
Provides: bundled(php-composer-spdx-licenses) = 1.5.8
Provides: bundled(php-composer-xdebug-handler) = 3.0.5
Provides: bundled(php-justinrainbow-json-schema) = 5.3.0
@@ -94,20 +94,20 @@ Provides: bundled(php-react-promise) = v3.2.0
Provides: bundled(php-seld-jsonlint) = 1.11.0
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.2
-Provides: bundled(php-symfony-console) = v5.4.43
+Provides: bundled(php-symfony-console) = v5.4.44
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.3
-Provides: bundled(php-symfony-filesystem) = v5.4.41
+Provides: bundled(php-symfony-filesystem) = v5.4.44
Provides: bundled(php-symfony-finder) = v5.4.43
-Provides: bundled(php-symfony-polyfill-ctype) = v1.30.0
-Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.30.0
-Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.30.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.30.0
-Provides: bundled(php-symfony-polyfill-php73) = v1.30.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.30.0
-Provides: bundled(php-symfony-polyfill-php81) = v1.30.0
-Provides: bundled(php-symfony-process) = v5.4.40
+Provides: bundled(php-symfony-polyfill-ctype) = v1.31.0
+Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.31.0
+Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.31.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.31.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.31.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.31.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.31.0
+Provides: bundled(php-symfony-process) = v5.4.44
Provides: bundled(php-symfony-service-contracts) = v2.5.3
-Provides: bundled(php-symfony-string) = v5.4.43
+Provides: bundled(php-symfony-string) = v5.4.44
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -230,14 +230,22 @@ mkdir -p %{buildroot}%{_datadir}/%{name}
cp -pr res %{buildroot}%{_datadir}/%{name}/res
cp -p LICENSE %{buildroot}%{_datadir}/%{name}/LICENSE
-ln -sf %{_datadir}/%{name}/LICENSE LICENSE
-
: Command
install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
+: Licenses
+ln -sf ../../%{name}/LICENSE LICENSE
+cd src/Composer/vendor
+for lic in */*/LICENSE
+do dir=$(dirname $lic)
+ own=$(dirname $dir)
+ prj=$(basename $dir)
+ ln -sf ../../php/Composer/vendor/$own/$prj/LICENSE ../../../$own-$prj-LICENSE
+done
+
%files
-%license LICENSE
+%license *LICENSE
%doc *.md doc
%doc composer.json
%config(noreplace) %{_sysconfdir}/profile.d/%{name}.*
@@ -248,6 +256,9 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Thu Oct 3 2024 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+
* Wed Sep 4 2024 Remi Collet <remi@remirepo.net> - 2.7.9-1
- update to 2.7.9
diff --git a/installed.json b/installed.json
index 5806978..aa4adb4 100644
--- a/installed.json
+++ b/installed.json
@@ -2,17 +2,17 @@
"packages": [
{
"name": "composer/ca-bundle",
- "version": "1.5.1",
- "version_normalized": "1.5.1.0",
+ "version": "1.5.2",
+ "version_normalized": "1.5.2.0",
"source": {
"type": "git",
"url": "https://github.com/composer/ca-bundle.git",
- "reference": "063d9aa8696582f5a41dffbbaf3c81024f0a604a"
+ "reference": "48a792895a2b7a6ee65dd5442c299d7b835b6137"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/ca-bundle/zipball/063d9aa8696582f5a41dffbbaf3c81024f0a604a",
- "reference": "063d9aa8696582f5a41dffbbaf3c81024f0a604a",
+ "url": "https://api.github.com/repos/composer/ca-bundle/zipball/48a792895a2b7a6ee65dd5442c299d7b835b6137",
+ "reference": "48a792895a2b7a6ee65dd5442c299d7b835b6137",
"shasum": ""
},
"require": {
@@ -22,11 +22,11 @@
},
"require-dev": {
"phpstan/phpstan": "^1.10",
+ "phpunit/phpunit": "^8 || ^9",
"psr/log": "^1.0 || ^2.0 || ^3.0",
- "symfony/phpunit-bridge": "^4.2 || ^5",
"symfony/process": "^4.0 || ^5.0 || ^6.0 || ^7.0"
},
- "time": "2024-07-08T15:28:20+00:00",
+ "time": "2024-09-25T07:49:53+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -61,7 +61,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/ca-bundle/issues",
- "source": "https://github.com/composer/ca-bundle/tree/1.5.1"
+ "source": "https://github.com/composer/ca-bundle/tree/1.5.2"
},
"funding": [
{
@@ -311,27 +311,27 @@
},
{
"name": "composer/semver",
- "version": "3.4.2",
- "version_normalized": "3.4.2.0",
+ "version": "3.4.3",
+ "version_normalized": "3.4.3.0",
"source": {
"type": "git",
"url": "https://github.com/composer/semver.git",
- "reference": "c51258e759afdb17f1fd1fe83bc12baaef6309d6"
+ "reference": "4313d26ada5e0c4edfbd1dc481a92ff7bff91f12"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/semver/zipball/c51258e759afdb17f1fd1fe83bc12baaef6309d6",
- "reference": "c51258e759afdb17f1fd1fe83bc12baaef6309d6",
+ "url": "https://api.github.com/repos/composer/semver/zipball/4313d26ada5e0c4edfbd1dc481a92ff7bff91f12",
+ "reference": "4313d26ada5e0c4edfbd1dc481a92ff7bff91f12",
"shasum": ""
},
"require": {
"php": "^5.3.2 || ^7.0 || ^8.0"
},
"require-dev": {
- "phpstan/phpstan": "^1.4",
- "symfony/phpunit-bridge": "^4.2 || ^5"
+ "phpstan/phpstan": "^1.11",
+ "symfony/phpunit-bridge": "^3 || ^7"
},
- "time": "2024-07-12T11:35:52+00:00",
+ "time": "2024-09-19T14:15:21+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -375,7 +375,7 @@
"support": {
"irc": "ircs://irc.libera.chat:6697/composer",
"issues": "https://github.com/composer/semver/issues",
- "source": "https://github.com/composer/semver/tree/3.4.2"
+ "source": "https://github.com/composer/semver/tree/3.4.3"
},
"funding": [
{
@@ -977,17 +977,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.43",
- "version_normalized": "5.4.43.0",
+ "version": "v5.4.44",
+ "version_normalized": "5.4.44.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "e86f8554de667c16dde8aeb89a3990cfde924df9"
+ "reference": "5b5a0aa66e3296e303e22490f90f521551835a83"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/e86f8554de667c16dde8aeb89a3990cfde924df9",
- "reference": "e86f8554de667c16dde8aeb89a3990cfde924df9",
+ "url": "https://api.github.com/repos/symfony/console/zipball/5b5a0aa66e3296e303e22490f90f521551835a83",
+ "reference": "5b5a0aa66e3296e303e22490f90f521551835a83",
"shasum": ""
},
"require": {
@@ -1025,7 +1025,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2024-08-13T16:31:56+00:00",
+ "time": "2024-09-20T07:56:40+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1059,7 +1059,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.43"
+ "source": "https://github.com/symfony/console/tree/v5.4.44"
},
"funding": [
{
@@ -1149,17 +1149,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.41",
- "version_normalized": "5.4.41.0",
+ "version": "v5.4.44",
+ "version_normalized": "5.4.44.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "6d29dd9340b372fa603f04e6df4dd76bb808591e"
+ "reference": "76c3818964e9d32be3862c9318ae3ba9aa280ddc"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/6d29dd9340b372fa603f04e6df4dd76bb808591e",
- "reference": "6d29dd9340b372fa603f04e6df4dd76bb808591e",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/76c3818964e9d32be3862c9318ae3ba9aa280ddc",
+ "reference": "76c3818964e9d32be3862c9318ae3ba9aa280ddc",
"shasum": ""
},
"require": {
@@ -1171,7 +1171,7 @@
"require-dev": {
"symfony/process": "^5.4|^6.4"
},
- "time": "2024-06-28T09:36:24+00:00",
+ "time": "2024-09-16T14:52:48+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1199,7 +1199,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.41"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.44"
},
"funding": [
{
@@ -1285,21 +1285,21 @@
},
{
"name": "symfony/polyfill-ctype",
- "version": "v1.30.0",
- "version_normalized": "1.30.0.0",
+ "version": "v1.31.0",
+ "version_normalized": "1.31.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-ctype.git",
- "reference": "0424dff1c58f028c451efff2045f5d92410bd540"
+ "reference": "a3cc8b044a6ea513310cbd48ef7333b384945638"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/0424dff1c58f028c451efff2045f5d92410bd540",
- "reference": "0424dff1c58f028c451efff2045f5d92410bd540",
+ "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/a3cc8b044a6ea513310cbd48ef7333b384945638",
+ "reference": "a3cc8b044a6ea513310cbd48ef7333b384945638",
"shasum": ""
},
"require": {
- "php": ">=7.1"
+ "php": ">=7.2"
},
"provide": {
"ext-ctype": "*"
@@ -1307,7 +1307,7 @@
"suggest": {
"ext-ctype": "For best performance"
},
- "time": "2024-05-31T15:07:36+00:00",
+ "time": "2024-09-09T11:45:10+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1347,7 +1347,7 @@
"portable"
],
"support": {
- "source": "https://github.com/symfony/polyfill-ctype/tree/v1.30.0"
+ "source": "https://github.com/symfony/polyfill-ctype/tree/v1.31.0"
},
"funding": [
{
@@ -1367,26 +1367,26 @@
},
{
"name": "symfony/polyfill-intl-grapheme",
- "version": "v1.30.0",
- "version_normalized": "1.30.0.0",
+ "version": "v1.31.0",
+ "version_normalized": "1.31.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-grapheme.git",
- "reference": "64647a7c30b2283f5d49b874d84a18fc22054b7a"
+ "reference": "b9123926e3b7bc2f98c02ad54f6a4b02b91a8abe"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/64647a7c30b2283f5d49b874d84a18fc22054b7a",
- "reference": "64647a7c30b2283f5d49b874d84a18fc22054b7a",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/b9123926e3b7bc2f98c02ad54f6a4b02b91a8abe",
+ "reference": "b9123926e3b7bc2f98c02ad54f6a4b02b91a8abe",
"shasum": ""
},
"require": {
- "php": ">=7.1"
+ "php": ">=7.2"
},
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2024-05-31T15:07:36+00:00",
+ "time": "2024-09-09T11:45:10+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1428,7 +1428,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.30.0"
+ "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.31.0"
},
"funding": [
{
@@ -1448,26 +1448,26 @@
},
{
"name": "symfony/polyfill-intl-normalizer",
- "version": "v1.30.0",
- "version_normalized": "1.30.0.0",
+ "version": "v1.31.0",
+ "version_normalized": "1.31.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-normalizer.git",
- "reference": "a95281b0be0d9ab48050ebd988b967875cdb9fdb"
+ "reference": "3833d7255cc303546435cb650316bff708a1c75c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/a95281b0be0d9ab48050ebd988b967875cdb9fdb",
- "reference": "a95281b0be0d9ab48050ebd988b967875cdb9fdb",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/3833d7255cc303546435cb650316bff708a1c75c",
+ "reference": "3833d7255cc303546435cb650316bff708a1c75c",
"shasum": ""
},
"require": {
- "php": ">=7.1"
+ "php": ">=7.2"
},
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2024-05-31T15:07:36+00:00",
+ "time": "2024-09-09T11:45:10+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1512,7 +1512,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.30.0"
+ "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.31.0"
},
"funding": [
{
@@ -1532,21 +1532,21 @@
},
{
"name": "symfony/polyfill-mbstring",
- "version": "v1.30.0",
- "version_normalized": "1.30.0.0",
+ "version": "v1.31.0",
+ "version_normalized": "1.31.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-mbstring.git",
- "reference": "fd22ab50000ef01661e2a31d850ebaa297f8e03c"
+ "reference": "85181ba99b2345b0ef10ce42ecac37612d9fd341"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/fd22ab50000ef01661e2a31d850ebaa297f8e03c",
- "reference": "fd22ab50000ef01661e2a31d850ebaa297f8e03c",
+ "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/85181ba99b2345b0ef10ce42ecac37612d9fd341",
+ "reference": "85181ba99b2345b0ef10ce42ecac37612d9fd341",
"shasum": ""
},
"require": {
- "php": ">=7.1"
+ "php": ">=7.2"
},
"provide": {
"ext-mbstring": "*"
@@ -1554,7 +1554,7 @@
"suggest": {
"ext-mbstring": "For best performance"
},
- "time": "2024-06-19T12:30:46+00:00",
+ "time": "2024-09-09T11:45:10+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1595,7 +1595,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.30.0"
+ "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.31.0"
},
"funding": [
{
@@ -1615,23 +1615,23 @@
},
{
"name": "symfony/polyfill-php73",
- "version": "v1.30.0",
- "version_normalized": "1.30.0.0",
+ "version": "v1.31.0",
+ "version_normalized": "1.31.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php73.git",
- "reference": "ec444d3f3f6505bb28d11afa41e75faadebc10a1"
+ "reference": "0f68c03565dcaaf25a890667542e8bd75fe7e5bb"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php73/zipball/ec444d3f3f6505bb28d11afa41e75faadebc10a1",
- "reference": "ec444d3f3f6505bb28d11afa41e75faadebc10a1",
+ "url": "https://api.github.com/repos/symfony/polyfill-php73/zipball/0f68c03565dcaaf25a890667542e8bd75fe7e5bb",
+ "reference": "0f68c03565dcaaf25a890667542e8bd75fe7e5bb",
"shasum": ""
},
"require": {
- "php": ">=7.1"
+ "php": ">=7.2"
},
- "time": "2024-05-31T15:07:36+00:00",
+ "time": "2024-09-09T11:45:10+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1674,7 +1674,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php73/tree/v1.30.0"
+ "source": "https://github.com/symfony/polyfill-php73/tree/v1.31.0"
},
"funding": [
{
@@ -1694,23 +1694,23 @@
},
{
"name": "symfony/polyfill-php80",
- "version": "v1.30.0",
- "version_normalized": "1.30.0.0",
+ "version": "v1.31.0",
+ "version_normalized": "1.31.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php80.git",
- "reference": "77fa7995ac1b21ab60769b7323d600a991a90433"
+ "reference": "60328e362d4c2c802a54fcbf04f9d3fb892b4cf8"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/77fa7995ac1b21ab60769b7323d600a991a90433",
- "reference": "77fa7995ac1b21ab60769b7323d600a991a90433",
+ "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/60328e362d4c2c802a54fcbf04f9d3fb892b4cf8",
+ "reference": "60328e362d4c2c802a54fcbf04f9d3fb892b4cf8",
"shasum": ""
},
"require": {
- "php": ">=7.1"
+ "php": ">=7.2"
},
- "time": "2024-05-31T15:07:36+00:00",
+ "time": "2024-09-09T11:45:10+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1757,7 +1757,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php80/tree/v1.30.0"
+ "source": "https://github.com/symfony/polyfill-php80/tree/v1.31.0"
},
"funding": [
{
@@ -1777,23 +1777,23 @@
},
{
"name": "symfony/polyfill-php81",
- "version": "v1.30.0",
- "version_normalized": "1.30.0.0",
+ "version": "v1.31.0",
+ "version_normalized": "1.31.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php81.git",
- "reference": "3fb075789fb91f9ad9af537c4012d523085bd5af"
+ "reference": "4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/3fb075789fb91f9ad9af537c4012d523085bd5af",
- "reference": "3fb075789fb91f9ad9af537c4012d523085bd5af",
+ "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c",
+ "reference": "4a4cfc2d253c21a5ad0e53071df248ed48c6ce5c",
"shasum": ""
},
"require": {
- "php": ">=7.1"
+ "php": ">=7.2"
},
- "time": "2024-06-19T12:30:46+00:00",
+ "time": "2024-09-09T11:45:10+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1836,7 +1836,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php81/tree/v1.30.0"
+ "source": "https://github.com/symfony/polyfill-php81/tree/v1.31.0"
},
"funding": [
{
@@ -1856,24 +1856,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.40",
- "version_normalized": "5.4.40.0",
+ "version": "v5.4.44",
+ "version_normalized": "5.4.44.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "deedcb3bb4669cae2148bc920eafd2b16dc7c046"
+ "reference": "1b9fa82b5c62cd49da8c9e3952dd8531ada65096"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/deedcb3bb4669cae2148bc920eafd2b16dc7c046",
- "reference": "deedcb3bb4669cae2148bc920eafd2b16dc7c046",
+ "url": "https://api.github.com/repos/symfony/process/zipball/1b9fa82b5c62cd49da8c9e3952dd8531ada65096",
+ "reference": "1b9fa82b5c62cd49da8c9e3952dd8531ada65096",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2024-05-31T14:33:22+00:00",
+ "time": "2024-09-17T12:46:43+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1901,7 +1901,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.40"
+ "source": "https://github.com/symfony/process/tree/v5.4.44"
},
"funding": [
{
@@ -2007,17 +2007,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.43",
- "version_normalized": "5.4.43.0",
+ "version": "v5.4.44",
+ "version_normalized": "5.4.44.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "8be1d484951ff5ca995eaf8edcbcb8b9a5888450"
+ "reference": "832caa16b6d9aac6bf11747315225f5aba384c24"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/8be1d484951ff5ca995eaf8edcbcb8b9a5888450",
- "reference": "8be1d484951ff5ca995eaf8edcbcb8b9a5888450",
+ "url": "https://api.github.com/repos/symfony/string/zipball/832caa16b6d9aac6bf11747315225f5aba384c24",
+ "reference": "832caa16b6d9aac6bf11747315225f5aba384c24",
"shasum": ""
},
"require": {
@@ -2037,7 +2037,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2024-08-01T10:24:28+00:00",
+ "time": "2024-09-20T07:56:40+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2076,7 +2076,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.43"
+ "source": "https://github.com/symfony/string/tree/v5.4.44"
},
"funding": [
{