summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-14 15:54:31 +0100
committerRemi Collet <remi@remirepo.net>2020-02-14 15:54:31 +0100
commit97ff948239fc5c34431b19412b9dd89c7f545087 (patch)
tree2173a076f35313fe99f40fd6a487fe685fc53a41
parentef7b76840e7799a45c89e869e1aaac409e2b54b2 (diff)
update to 1.10.0-RC
-rw-r--r--composer-rpm.patch26
-rw-r--r--composer.json16
-rw-r--r--composer.spec23
3 files changed, 34 insertions, 31 deletions
diff --git a/composer-rpm.patch b/composer-rpm.patch
index b6bccfb..ec7ff9b 100644
--- a/composer-rpm.patch
+++ b/composer-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./bin/composer.rpm ./bin/composer
---- ./bin/composer.rpm 2019-08-03 10:30:10.000000000 +0200
-+++ ./bin/composer 2019-08-03 10:30:42.907772543 +0200
+--- ./bin/composer.rpm 2020-02-14 15:37:41.000000000 +0100
++++ ./bin/composer 2020-02-14 15:37:43.336528140 +0100
@@ -6,7 +6,7 @@ if (PHP_SAPI !== 'cli' && PHP_SAPI !== '
}
@@ -11,10 +11,10 @@ diff -up ./bin/composer.rpm ./bin/composer
use Composer\Console\Application;
use Composer\XdebugHandler\XdebugHandler;
diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autoload/AutoloadGenerator.php
---- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2019-08-03 10:30:10.000000000 +0200
-+++ ./src/Composer/Autoload/AutoloadGenerator.php 2019-08-03 10:30:42.908772550 +0200
-@@ -306,7 +306,7 @@ EOF;
- file_put_contents($targetDir.'/autoload_real.php', $this->getAutoloadRealFile(true, (bool) $includePathFileContents, $targetDirLoader, (bool) $includeFilesFileContents, $vendorPathCode, $appBaseDirCode, $suffix, $useGlobalIncludePath, $prependAutoloader, $staticPhpVersion));
+--- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2020-02-14 15:37:43.336528140 +0100
++++ ./src/Composer/Autoload/AutoloadGenerator.php 2020-02-14 15:38:56.710201606 +0100
+@@ -305,7 +305,7 @@ EOF;
+ $this->filePutContentsIfModified($targetDir.'/autoload_real.php', $this->getAutoloadRealFile(true, (bool) $includePathFileContents, $targetDirLoader, (bool) $includeFilesFileContents, $vendorPathCode, $appBaseDirCode, $suffix, $useGlobalIncludePath, $prependAutoloader, $staticPhpVersion));
$this->safeCopy(__DIR__.'/ClassLoader.php', $targetDir.'/ClassLoader.php');
- $this->safeCopy(__DIR__.'/../../../LICENSE', $targetDir.'/LICENSE');
@@ -23,8 +23,8 @@ diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autolo
if ($this->runScripts) {
$this->eventDispatcher->dispatchScript(ScriptEvents::POST_AUTOLOAD_DUMP, $this->devMode, array(), array(
diff -up ./src/Composer/Compiler.php.rpm ./src/Composer/Compiler.php
---- ./src/Composer/Compiler.php.rpm 2019-08-03 10:30:10.000000000 +0200
-+++ ./src/Composer/Compiler.php 2019-08-03 10:30:42.908772550 +0200
+--- ./src/Composer/Compiler.php.rpm 2020-02-14 15:37:41.000000000 +0100
++++ ./src/Composer/Compiler.php 2020-02-14 15:37:43.336528140 +0100
@@ -97,7 +97,7 @@ class Compiler
$finder = new Finder();
$finder->files()
@@ -35,8 +35,8 @@ diff -up ./src/Composer/Compiler.php.rpm ./src/Composer/Compiler.php
->sort($finderSort)
;
diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
---- ./src/Composer/Json/JsonFile.php.rpm 2019-08-03 10:30:42.908772550 +0200
-+++ ./src/Composer/Json/JsonFile.php 2019-08-03 10:32:48.919630077 +0200
+--- ./src/Composer/Json/JsonFile.php.rpm 2020-02-14 15:37:41.000000000 +0100
++++ ./src/Composer/Json/JsonFile.php 2020-02-14 15:37:43.336528140 +0100
@@ -34,7 +34,7 @@ class JsonFile
const JSON_PRETTY_PRINT = 128;
const JSON_UNESCAPED_UNICODE = 256;
@@ -46,7 +46,7 @@ diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
private $path;
private $rfs;
-@@ -160,7 +160,7 @@ class JsonFile
+@@ -173,7 +173,7 @@ class JsonFile
}
if (null === $schemaFile) {
@@ -56,8 +56,8 @@ diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
// Prepend with file:// only when not using a special schema already (e.g. in the phar)
diff -up ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm ./tests/Composer/Test/Json/ComposerSchemaTest.php
---- ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm 2019-08-03 10:30:10.000000000 +0200
-+++ ./tests/Composer/Test/Json/ComposerSchemaTest.php 2019-08-03 10:30:42.908772550 +0200
+--- ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm 2020-02-14 15:37:41.000000000 +0100
++++ ./tests/Composer/Test/Json/ComposerSchemaTest.php 2020-02-14 15:37:43.336528140 +0100
@@ -97,7 +97,8 @@ class ComposerSchemaTest extends TestCas
private function check($json)
{
diff --git a/composer.json b/composer.json
index 0878f5b..97b271d 100644
--- a/composer.json
+++ b/composer.json
@@ -31,17 +31,17 @@
"psr/log": "^1.0",
"seld/jsonlint": "^1.4",
"seld/phar-utils": "^1.0",
- "symfony/console": "^2.7 || ^3.0 || ^4.0",
- "symfony/filesystem": "^2.7 || ^3.0 || ^4.0",
- "symfony/finder": "^2.7 || ^3.0 || ^4.0",
- "symfony/process": "^2.7 || ^3.0 || ^4.0"
+ "symfony/console": "^2.7 || ^3.0 || ^4.0 || ^5.0",
+ "symfony/filesystem": "^2.7 || ^3.0 || ^4.0 || ^5.0",
+ "symfony/finder": "^2.7 || ^3.0 || ^4.0 || ^5.0",
+ "symfony/process": "^2.7 || ^3.0 || ^4.0 || ^5.0"
},
"conflict": {
"symfony/console": "2.8.38"
},
"require-dev": {
- "phpunit/phpunit": "^4.8.35 || ^5.7",
- "phpunit/phpunit-mock-objects": "^2.3 || ^3.0"
+ "symfony/phpunit-bridge": "^3.4",
+ "phpspec/prophecy": "^1.10"
},
"suggest": {
"ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -55,7 +55,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "1.9-dev"
+ "dev-master": "1.10-dev"
}
},
"autoload": {
@@ -73,7 +73,7 @@
],
"scripts": {
"compile": "@php -dphar.readonly=0 bin/compile",
- "test": "phpunit"
+ "test": "simple-phpunit"
},
"scripts-descriptions": {
"compile": "Compile composer.phar",
diff --git a/composer.spec b/composer.spec
index cdcdc48..fccd7a3 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 1291a16ce3f48bfdeca39d64fca4875098af4d7b
+%global gh_commit ec39b4cbb5e012365d70cd95969ea11780d3c1fc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 1.0-dev
%global gh_owner composer
@@ -18,8 +18,8 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
%global api_version 1.1.0
-%global upstream_version 1.9.3
-#global upstream_prever RC
+%global upstream_version 1.10.0
+%global upstream_prever RC
%if 0
# see https://forum.remirepo.net/viewtopic.php?id=3677
@@ -81,9 +81,9 @@ BuildRequires: %{symfony_prefix}-filesystem
BuildRequires: %{symfony_prefix}-process
BuildRequires: php-zip
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^4.8.35 || ^5.7",
-# "phpunit/phpunit-mock-objects": "^2.3 || ^3.0"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8.35
+# "symfony/phpunit-bridge": "^3.4",
+# "phpspec/prophecy": "^1.10"
+BuildRequires: phpunit
# For autoloader
BuildRequires: php-composer(fedora/autoloader) >= 0.1.2
BuildRequires: php-seld-phar-utils >= 1.0.1
@@ -100,10 +100,10 @@ BuildRequires: php-PsrLog >= 1.0.0-8
# "psr/log": "^1.0"
# "seld/jsonlint": "~1.4",
# "seld/phar-utils": "^1.0",
-# "symfony/console": "^2.7 || ^3.0 || ^4.0",
-# "symfony/filesystem": "^2.7 || ^3.0 || ^4.0",
-# "symfony/finder": "^2.7 || ^3.0 || ^4.0",
-# "symfony/process": "^2.7 || ^3.0 || ^4.0",
+# "symfony/console": "^2.7 || ^3.0 || ^4.0 || ^5.0",
+# "symfony/filesystem": "^2.7 || ^3.0 || ^4.0 || ^5.0",
+# "symfony/finder": "^2.7 || ^3.0 || ^4.0 || ^5.0",
+# "symfony/process": "^2.7 || ^3.0 || ^4.0 || ^5.0",
Requires: php(language) >= 5.3.2
Requires: php-cli
Requires: php-justinrainbow-json-schema5
@@ -283,6 +283,9 @@ exit $ret
%changelog
+* Fri Feb 14 2020 Remi Collet <remi@remirepo.net> - 1.10.0-1
+- update to 1.10.0-RC
+
* Tue Feb 4 2020 Remi Collet <remi@remirepo.net> - 1.9.3-1
- update to 1.9.3