summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-22 08:18:01 +0200
committerRemi Collet <remi@php.net>2022-07-22 08:18:01 +0200
commit7f36f919df16a02987669603153685c74d8502dd (patch)
tree665ceb8d5ea2467d24f5f3866675a7050be54a99
parent3763cc67cef6536302ed8c994de0a0c6bfa6923c (diff)
open https://github.com/symfony/symfony/pull/47022 fix command path
-rw-r--r--composer-bash-completion4
-rw-r--r--composer.json8
-rw-r--r--composer.spec15
-rw-r--r--installed.json154
4 files changed, 165 insertions, 16 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index 5d484cc..6b3d1ea 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -13,6 +13,8 @@ _sf_composer() {
# for an alias, get the real script behind it
if [[ $(type -t $sf_cmd) == "alias" ]]; then
sf_cmd=$(alias $sf_cmd | sed -E "s/alias $sf_cmd='(.*)'/\1/")
+ else
+ sf_cmd=$(type -p $sf_cmd)
fi
if [ ! -f "$sf_cmd" ]; then
@@ -22,7 +24,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "-sbash" "-c$cword" "-S2.3.10")
+ local completecmd=("$sf_cmd" "_complete" "-sbash" "-c$cword" "-S2.4.0-RC1")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.json b/composer.json
index c346aa0..bc9792e 100644
--- a/composer.json
+++ b/composer.json
@@ -24,9 +24,10 @@
"require": {
"php": "^7.2.5 || ^8.0",
"composer/ca-bundle": "^1.0",
+ "composer/class-map-generator": "^1.0",
"composer/metadata-minifier": "^1.0",
"composer/semver": "^3.0",
- "composer/spdx-licenses": "^1.2",
+ "composer/spdx-licenses": "^1.5.7",
"composer/xdebug-handler": "^2.0.2 || ^3.0.3",
"justinrainbow/json-schema": "^5.2.11",
"psr/log": "^1.0 || ^2.0 || ^3.0",
@@ -39,7 +40,8 @@
"react/promise": "^2.8",
"composer/pcre": "^2 || ^3",
"symfony/polyfill-php73": "^1.24",
- "symfony/polyfill-php80": "^1.24"
+ "symfony/polyfill-php80": "^1.24",
+ "seld/signal-handler": "^2.0"
},
"require-dev": {
"symfony/phpunit-bridge": "^6.0",
@@ -62,7 +64,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "2.3-dev"
+ "dev-main": "2.4-dev"
},
"phpstan": {
"includes": [
diff --git a/composer.spec b/composer.spec
index bf5644f..bedf285 100644
--- a/composer.spec
+++ b/composer.spec
@@ -18,7 +18,7 @@
%bcond_with syslib
%endif
-%global gh_commit ebac357c0a41359f3981098729042ed6dedc97ba
+%global gh_commit c08cac5f67ae4cf6f988758c95dd30a6c8107063
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -26,9 +26,9 @@
%global api_version 2.3.0
%global run_version 2.2.2
-%global upstream_version 2.3.10
-#global upstream_prever RC2
-#global upstream_lower rc2
+%global upstream_version 2.4.0
+%global upstream_prever RC1
+%global upstream_lower rc1
%global symfony_prefix php-symfony5
%global symfony_path %{_datadir}/php/Symfony5
@@ -167,7 +167,8 @@ Requires: php-composer(fedora/autoloader)
Requires: ca-certificates
# Bundled libraries
# License MIT
-Provides: bundled(php-composer-ca-bundle) = 1.3.2
+Provides: bundled(php-composer-ca-bundle) = 1.3.3
+Provides: bundled(php-composer-class-map-generator) = 1.0.0
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
Provides: bundled(php-composer-pcre) = 2.0.0
Provides: bundled(php-composer-semver) = 3.3.2
@@ -179,6 +180,7 @@ Provides: bundled(php-psr-log) = 1.1.4
Provides: bundled(php-react-promise) = v2.9.0
Provides: bundled(php-seld-jsonlint) = 1.9.0
Provides: bundled(php-seld-phar-utils) = 1.2.0
+Provides: bundled(php-seld-signal-handler) = 2.0.1
Provides: bundled(php-symfony-console) = v5.4.10
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
Provides: bundled(php-symfony-filesystem) = v5.4.9
@@ -424,6 +426,9 @@ exit $ret
%changelog
+* Fri Jul 22 2022 Remi Collet <remi@remirepo.net> - 2.4.0~rc1-1
+- open https://github.com/symfony/symfony/pull/47022 fix command path
+
* Thu Jul 14 2022 Remi Collet <remi@remirepo.net> - 2.3.10-1
- update to 2.3.10
diff --git a/installed.json b/installed.json
index 17c3a7e..636dc0d 100644
--- a/installed.json
+++ b/installed.json
@@ -2,17 +2,17 @@
"packages": [
{
"name": "composer/ca-bundle",
- "version": "1.3.2",
- "version_normalized": "1.3.2.0",
+ "version": "1.3.3",
+ "version_normalized": "1.3.3.0",
"source": {
"type": "git",
"url": "https://github.com/composer/ca-bundle.git",
- "reference": "fd5dd441932a7e10ca6e5b490e272d34c8430640"
+ "reference": "30897edbfb15e784fe55587b4f73ceefd3c4d98c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/ca-bundle/zipball/fd5dd441932a7e10ca6e5b490e272d34c8430640",
- "reference": "fd5dd441932a7e10ca6e5b490e272d34c8430640",
+ "url": "https://api.github.com/repos/composer/ca-bundle/zipball/30897edbfb15e784fe55587b4f73ceefd3c4d98c",
+ "reference": "30897edbfb15e784fe55587b4f73ceefd3c4d98c",
"shasum": ""
},
"require": {
@@ -26,7 +26,7 @@
"symfony/phpunit-bridge": "^4.2 || ^5",
"symfony/process": "^2.5 || ^3.0 || ^4.0 || ^5.0 || ^6.0"
},
- "time": "2022-05-24T11:56:16+00:00",
+ "time": "2022-07-20T07:14:26+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -61,7 +61,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/ca-bundle/issues",
- "source": "https://github.com/composer/ca-bundle/tree/1.3.2"
+ "source": "https://github.com/composer/ca-bundle/tree/1.3.3"
},
"funding": [
{
@@ -80,6 +80,82 @@
"install-path": "./ca-bundle"
},
{
+ "name": "composer/class-map-generator",
+ "version": "1.0.0",
+ "version_normalized": "1.0.0.0",
+ "source": {
+ "type": "git",
+ "url": "https://github.com/composer/class-map-generator.git",
+ "reference": "1e1cb2b791facb2dfe32932a7718cf2571187513"
+ },
+ "dist": {
+ "type": "zip",
+ "url": "https://api.github.com/repos/composer/class-map-generator/zipball/1e1cb2b791facb2dfe32932a7718cf2571187513",
+ "reference": "1e1cb2b791facb2dfe32932a7718cf2571187513",
+ "shasum": ""
+ },
+ "require": {
+ "composer/pcre": "^2 || ^3",
+ "php": "^7.2 || ^8.0",
+ "symfony/finder": "^4.4 || ^5.3 || ^6"
+ },
+ "require-dev": {
+ "phpstan/phpstan": "^1.6",
+ "phpstan/phpstan-deprecation-rules": "^1",
+ "phpstan/phpstan-phpunit": "^1",
+ "phpstan/phpstan-strict-rules": "^1.1",
+ "symfony/filesystem": "^5.4 || ^6",
+ "symfony/phpunit-bridge": "^5"
+ },
+ "time": "2022-06-19T11:31:27+00:00",
+ "type": "library",
+ "extra": {
+ "branch-alias": {
+ "dev-main": "1.x-dev"
+ }
+ },
+ "installation-source": "dist",
+ "autoload": {
+ "psr-4": {
+ "Composer\\ClassMapGenerator\\": "src"
+ }
+ },
+ "notification-url": "https://packagist.org/downloads/",
+ "license": [
+ "MIT"
+ ],
+ "authors": [
+ {
+ "name": "Jordi Boggiano",
+ "email": "j.boggiano@seld.be",
+ "homepage": "https://seld.be"
+ }
+ ],
+ "description": "Utilities to scan PHP code and generate class maps.",
+ "keywords": [
+ "classmap"
+ ],
+ "support": {
+ "issues": "https://github.com/composer/class-map-generator/issues",
+ "source": "https://github.com/composer/class-map-generator/tree/1.0.0"
+ },
+ "funding": [
+ {
+ "url": "https://packagist.com",
+ "type": "custom"
+ },
+ {
+ "url": "https://github.com/composer",
+ "type": "github"
+ },
+ {
+ "url": "https://tidelift.com/funding/github/packagist/composer/composer",
+ "type": "tidelift"
+ }
+ ],
+ "install-path": "./class-map-generator"
+ },
+ {
"name": "composer/metadata-minifier",
"version": "1.0.0",
"version_normalized": "1.0.0.0",
@@ -836,6 +912,70 @@
"install-path": "../seld/phar-utils"
},
{
+ "name": "seld/signal-handler",
+ "version": "2.0.1",
+ "version_normalized": "2.0.1.0",
+ "source": {
+ "type": "git",
+ "url": "https://github.com/Seldaek/signal-handler.git",
+ "reference": "f69d119511dc0360440cdbdaa71829c149b7be75"
+ },
+ "dist": {
+ "type": "zip",
+ "url": "https://api.github.com/repos/Seldaek/signal-handler/zipball/f69d119511dc0360440cdbdaa71829c149b7be75",
+ "reference": "f69d119511dc0360440cdbdaa71829c149b7be75",
+ "shasum": ""
+ },
+ "require": {
+ "php": ">=7.2.0"
+ },
+ "require-dev": {
+ "phpstan/phpstan": "^1",
+ "phpstan/phpstan-deprecation-rules": "^1.0",
+ "phpstan/phpstan-phpunit": "^1",
+ "phpstan/phpstan-strict-rules": "^1.3",
+ "phpunit/phpunit": "^7.5.20 || ^8.5.23",
+ "psr/log": "^1 || ^2 || ^3"
+ },
+ "time": "2022-07-20T18:31:45+00:00",
+ "type": "library",
+ "extra": {
+ "branch-alias": {
+ "dev-main": "2.x-dev"
+ }
+ },
+ "installation-source": "dist",
+ "autoload": {
+ "psr-4": {
+ "Seld\\Signal\\": "src/"
+ }
+ },
+ "notification-url": "https://packagist.org/downloads/",
+ "license": [
+ "MIT"
+ ],
+ "authors": [
+ {
+ "name": "Jordi Boggiano",
+ "email": "j.boggiano@seld.be",
+ "homepage": "http://seld.be"
+ }
+ ],
+ "description": "Simple unix signal handler that silently fails where signals are not supported for easy cross-platform development",
+ "keywords": [
+ "posix",
+ "sigint",
+ "signal",
+ "sigterm",
+ "unix"
+ ],
+ "support": {
+ "issues": "https://github.com/Seldaek/signal-handler/issues",
+ "source": "https://github.com/Seldaek/signal-handler/tree/2.0.1"
+ },
+ "install-path": "../seld/signal-handler"
+ },
+ {
"name": "symfony/console",
"version": "v5.4.10",
"version_normalized": "5.4.10.0",