summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-21 17:42:22 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-21 17:42:22 +0200
commit64fd9381d6789429bbf2b497571aedf88af391e5 (patch)
tree624017dd97b1a70486068500f8a90354d51cde28
parent6990c45d17552208a81ab56e35585b4ad6367555 (diff)
composer-1.0.0-0.10.20150920git9f2e562
-rw-r--r--composer-rpm.patch32
-rw-r--r--composer.spec14
2 files changed, 27 insertions, 19 deletions
diff --git a/composer-rpm.patch b/composer-rpm.patch
index 35246d0..b6775b7 100644
--- a/composer-rpm.patch
+++ b/composer-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./bin/composer.rpm ./bin/composer
---- ./bin/composer.rpm 2015-07-14 14:37:15.000000000 +0200
-+++ ./bin/composer 2015-07-16 08:58:33.415021590 +0200
+--- ./bin/composer.rpm 2015-09-20 20:44:55.000000000 +0200
++++ ./bin/composer 2015-09-21 17:38:08.532640919 +0200
@@ -5,7 +5,7 @@ if (PHP_SAPI !== 'cli') {
echo 'Warning: Composer should be invoked via the CLI version of PHP, not the '.PHP_SAPI.' SAPI'.PHP_EOL;
}
@@ -10,9 +10,21 @@ diff -up ./bin/composer.rpm ./bin/composer
use Composer\Console\Application;
+diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autoload/AutoloadGenerator.php
+--- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2015-09-21 17:38:08.532640919 +0200
++++ ./src/Composer/Autoload/AutoloadGenerator.php 2015-09-21 17:38:58.418873383 +0200
+@@ -290,7 +290,7 @@ EOF;
+ file_put_contents($targetDir.'/autoload_real.php', $this->getAutoloadRealFile(true, (bool) $includePathFileContents, $targetDirLoader, (bool) $includeFilesFileContents, $vendorPathCode, $appBaseDirCode, $suffix, $useGlobalIncludePath, $prependAutoloader));
+
+ $this->safeCopy(__DIR__.'/ClassLoader.php', $targetDir.'/ClassLoader.php');
+- $this->safeCopy(__DIR__.'/../../../LICENSE', $targetDir.'/LICENSE');
++ $this->safeCopy((getenv('BUILDROOT')?:'') . '/usr/share/composer/LICENSE', $targetDir.'/LICENSE');
+
+ $this->eventDispatcher->dispatchScript(ScriptEvents::POST_AUTOLOAD_DUMP, $this->devMode, array(), array(
+ 'optimize' => (bool) $scanPsr0Packages,
diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
---- ./src/Composer/Json/JsonFile.php.rpm 2015-07-14 14:37:15.000000000 +0200
-+++ ./src/Composer/Json/JsonFile.php 2015-07-16 08:58:33.415021590 +0200
+--- ./src/Composer/Json/JsonFile.php.rpm 2015-09-20 20:44:55.000000000 +0200
++++ ./src/Composer/Json/JsonFile.php 2015-09-21 17:38:08.532640919 +0200
@@ -149,7 +149,7 @@ class JsonFile
self::validateSyntax($content, $this->path);
}
@@ -22,15 +34,3 @@ diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
$schemaData = json_decode(file_get_contents($schemaFile));
if ($schema === self::LAX_SCHEMA) {
-diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autoload/AutoloadGenerator.php
---- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2015-08-23 08:55:33.537606407 +0200
-+++ ./src/Composer/Autoload/AutoloadGenerator.php 2015-08-23 08:56:17.341809277 +0200
-@@ -268,7 +268,7 @@ EOF;
- file_put_contents($targetDir.'/autoload_real.php', $this->getAutoloadRealFile(true, (bool) $includePathFileContents, $targetDirLoader, (bool) $includeFilesFileContents, $vendorPathCode, $appBaseDirCode, $suffix, $useGlobalIncludePath, $prependAutoloader, $classMapAuthoritative));
-
- $this->safeCopy(__DIR__.'/ClassLoader.php', $targetDir.'/ClassLoader.php');
-- $this->safeCopy(__DIR__.'/../../../LICENSE', $targetDir.'/LICENSE');
-+ $this->safeCopy((getenv('BUILDROOT')?:'') . '/usr/share/composer/LICENSE', $targetDir.'/LICENSE');
-
- $this->eventDispatcher->dispatchScript(ScriptEvents::POST_AUTOLOAD_DUMP, $this->devMode, array(), array(
- 'optimize' => (bool) $scanPsr0Packages,
diff --git a/composer.spec b/composer.spec
index acfa596..6e55ebe 100644
--- a/composer.spec
+++ b/composer.spec
@@ -6,17 +6,17 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 9f6fdfd703f433bd0777fd89fb4684908a6c4f06
+%global gh_commit 9f2e562e48145f10bf224f93f561e762df980638
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 1.0-dev
-%global gh_date 20150907
+%global gh_date 20150920
%global gh_owner composer
%global gh_project composer
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: composer
Version: 1.0.0
-Release: 0.9.%{gh_date}git%{gh_short}%{?dist}
+Release: 0.10.%{gh_date}git%{gh_short}%{?dist}
Summary: Dependency Manager for PHP
Group: Development/Libraries
@@ -37,6 +37,7 @@ BuildRequires: php-composer(composer/spdx-licenses) >= 1.0
BuildRequires: php-composer(seld/jsonlint) >= 1.0
BuildRequires: php-composer(symfony/console) >= 2.5
BuildRequires: php-composer(symfony/finder) >= 2.2
+BuildRequires: php-composer(symfony/filesystem) >= 2.5
BuildRequires: php-composer(symfony/process) >= 2.1
BuildRequires: php-composer(symfony/class-loader)
BuildRequires: %{_bindir}/phpunit
@@ -51,6 +52,7 @@ BuildRequires: php-zip
# "symfony/console": "~2.5",
# "symfony/finder": "~2.2",
# "symfony/process": "~2.1",
+# "symfony/filesystem": "~2.5",
# "seld/phar-utils": "~1.0",
# "seld/cli-prompt": "~1.0"
Requires: php(language) >= 5.3.2
@@ -71,6 +73,8 @@ Requires: php-composer(symfony/finder) >= 2.2
Requires: php-composer(symfony/finder) < 3
Requires: php-composer(symfony/process) >= 2.1
Requires: php-composer(symfony/process) < 3
+Requires: php-composer(symfony/filesystem) >= 2.5
+Requires: php-composer(symfony/filesystem) < 3
# From composer.json, suggest
# "ext-zip": "Enabling the zip extension allows you to unzip archives, and allows gzip compression of all internet traffic",
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages"
@@ -174,6 +178,10 @@ rm -rf %{buildroot}
%changelog
+* Mon Sep 21 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.9.20150920git9f2e562
+- new snapshot
+- add dependency on symfony/filesystem
+
* Tue Sep 8 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.9.20150907git9f6fdfd
- new snapshot