summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-10 07:58:43 +0200
committerRemi Collet <remi@php.net>2023-06-10 07:58:43 +0200
commit5e426f1e2376d6a89952205db82b16c655eff1e2 (patch)
tree81a37b3a3a0d9e9cbe9b13ea4cb3a4e2b0ab1cd9
parent6352127b6c4db92ff6cfd46666cdc7ab62f6cf19 (diff)
update to 2.5.8
-rw-r--r--composer-bash-completion2
-rw-r--r--composer.spec12
-rw-r--r--installed.json42
3 files changed, 30 insertions, 26 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index 43ed18f..b059ebf 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.5.7")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.5.8")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.spec b/composer.spec
index fb8f2c7..3e0a9c4 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit d477018d3f2ebd76dede3d3988a0b1a7add4d81e
+%global gh_commit 4c516146167d1392c8b9b269bb7c24115d262164
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.3.0
%global run_version 2.2.2
-%global upstream_version 2.5.7
+%global upstream_version 2.5.8
#global upstream_prever RC1
#global upstream_lower rc1
@@ -80,6 +80,7 @@ Requires: php-cli
Requires: ca-certificates
# Bundled libraries
# License MIT
+Provides: bundled(php-composer-ca-bundle) = 1.3.6
Provides: bundled(php-composer-class-map-generator) = 1.0.0
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
Provides: bundled(php-composer-pcre) = 2.1.0
@@ -93,7 +94,7 @@ Provides: bundled(php-react-promise) = v2.10.0
Provides: bundled(php-seld-jsonlint) = 1.10.0
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.1
-Provides: bundled(php-symfony-console) = v5.4.23
+Provides: bundled(php-symfony-console) = v5.4.24
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
Provides: bundled(php-symfony-filesystem) = v5.4.23
Provides: bundled(php-symfony-finder) = v5.4.21
@@ -104,7 +105,7 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
-Provides: bundled(php-symfony-process) = v5.4.23
+Provides: bundled(php-symfony-process) = v5.4.24
Provides: bundled(php-symfony-service-contracts) = v2.5.2
Provides: bundled(php-symfony-string) = v5.4.22
@@ -248,6 +249,9 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Sat Jun 10 2023 Remi Collet <remi@remirepo.net> - 2.5.8-1
+- update to 2.5.8
+
* Wed May 24 2023 Remi Collet <remi@remirepo.net> - 2.5.7-1
- update to 2.5.7
diff --git a/installed.json b/installed.json
index 6b8ce8f..de406a0 100644
--- a/installed.json
+++ b/installed.json
@@ -2,17 +2,17 @@
"packages": [
{
"name": "composer/ca-bundle",
- "version": "1.3.5",
- "version_normalized": "1.3.5.0",
+ "version": "1.3.6",
+ "version_normalized": "1.3.6.0",
"source": {
"type": "git",
"url": "https://github.com/composer/ca-bundle.git",
- "reference": "74780ccf8c19d6acb8d65c5f39cd72110e132bbd"
+ "reference": "90d087e988ff194065333d16bc5cf649872d9cdb"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/ca-bundle/zipball/74780ccf8c19d6acb8d65c5f39cd72110e132bbd",
- "reference": "74780ccf8c19d6acb8d65c5f39cd72110e132bbd",
+ "url": "https://api.github.com/repos/composer/ca-bundle/zipball/90d087e988ff194065333d16bc5cf649872d9cdb",
+ "reference": "90d087e988ff194065333d16bc5cf649872d9cdb",
"shasum": ""
},
"require": {
@@ -26,7 +26,7 @@
"symfony/phpunit-bridge": "^4.2 || ^5",
"symfony/process": "^2.5 || ^3.0 || ^4.0 || ^5.0 || ^6.0"
},
- "time": "2023-01-11T08:27:00+00:00",
+ "time": "2023-06-06T12:02:59+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -61,7 +61,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/ca-bundle/issues",
- "source": "https://github.com/composer/ca-bundle/tree/1.3.5"
+ "source": "https://github.com/composer/ca-bundle/tree/1.3.6"
},
"funding": [
{
@@ -973,17 +973,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.23",
- "version_normalized": "5.4.23.0",
+ "version": "v5.4.24",
+ "version_normalized": "5.4.24.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "90f21e27d0d88ce38720556dd164d4a1e4c3934c"
+ "reference": "560fc3ed7a43e6d30ea94a07d77f9a60b8ed0fb8"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/90f21e27d0d88ce38720556dd164d4a1e4c3934c",
- "reference": "90f21e27d0d88ce38720556dd164d4a1e4c3934c",
+ "url": "https://api.github.com/repos/symfony/console/zipball/560fc3ed7a43e6d30ea94a07d77f9a60b8ed0fb8",
+ "reference": "560fc3ed7a43e6d30ea94a07d77f9a60b8ed0fb8",
"shasum": ""
},
"require": {
@@ -1021,7 +1021,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2023-04-24T18:47:29+00:00",
+ "time": "2023-05-26T05:13:16+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1055,7 +1055,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.23"
+ "source": "https://github.com/symfony/console/tree/v5.4.24"
},
"funding": [
{
@@ -1870,24 +1870,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.23",
- "version_normalized": "5.4.23.0",
+ "version": "v5.4.24",
+ "version_normalized": "5.4.24.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "4b842fc4b61609e0a155a114082bd94e31e98287"
+ "reference": "e3c46cc5689c8782944274bb30702106ecbe3b64"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/4b842fc4b61609e0a155a114082bd94e31e98287",
- "reference": "4b842fc4b61609e0a155a114082bd94e31e98287",
+ "url": "https://api.github.com/repos/symfony/process/zipball/e3c46cc5689c8782944274bb30702106ecbe3b64",
+ "reference": "e3c46cc5689c8782944274bb30702106ecbe3b64",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2023-04-18T13:50:24+00:00",
+ "time": "2023-05-17T11:26:05+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1915,7 +1915,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.23"
+ "source": "https://github.com/symfony/process/tree/v5.4.24"
},
"funding": [
{