summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-21 07:35:10 +0100
committerRemi Collet <remi@php.net>2022-03-21 07:35:10 +0100
commit54fa358da0c9b15e0b44424cb30ec42c3f94fe70 (patch)
tree87093720bd51bafd94972b0336e075710108f65d
parentd9eb80211b61646ea28c69e716c43f8e09368aea (diff)
update to 2.3.0RC2
-rw-r--r--composer-noxdg.patch10
-rw-r--r--composer-rpm.patch114
-rw-r--r--composer.json52
-rw-r--r--composer.spec85
-rw-r--r--installed.json34
5 files changed, 131 insertions, 164 deletions
diff --git a/composer-noxdg.patch b/composer-noxdg.patch
index 607e449..73195e7 100644
--- a/composer-noxdg.patch
+++ b/composer-noxdg.patch
@@ -1,9 +1,9 @@
diff -up ./src/Composer/Factory.php.noxdg ./src/Composer/Factory.php
---- ./src/Composer/Factory.php.noxdg 2022-01-25 09:39:15.000000000 +0100
-+++ ./src/Composer/Factory.php 2022-01-25 09:50:21.374957261 +0100
-@@ -701,6 +701,10 @@ class Factory
- */
- private static function useXdg()
+--- ./src/Composer/Factory.php.noxdg 2022-03-16 09:51:30.398977729 +0100
++++ ./src/Composer/Factory.php 2022-03-16 09:52:14.113841110 +0100
+@@ -665,6 +665,10 @@ class Factory
+
+ private static function useXdg(): bool
{
+ // As XDG is very patially implemted
+ // resulting in command/code in ~/.config
diff --git a/composer-rpm.patch b/composer-rpm.patch
index bdf807b..26ee894 100644
--- a/composer-rpm.patch
+++ b/composer-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./bin/composer.rpm ./bin/composer
---- ./bin/composer.rpm 2022-01-25 09:39:15.000000000 +0100
-+++ ./bin/composer 2022-01-25 09:50:21.372957269 +0100
+--- ./bin/composer.rpm 2022-03-16 09:47:01.000000000 +0100
++++ ./bin/composer 2022-03-16 09:53:25.479618079 +0100
@@ -6,7 +6,7 @@ if (PHP_SAPI !== 'cli' && PHP_SAPI !== '
}
@@ -11,10 +11,10 @@ diff -up ./bin/composer.rpm ./bin/composer
use Composer\Console\Application;
use Composer\XdebugHandler\XdebugHandler;
diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autoload/AutoloadGenerator.php
---- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2022-01-25 09:39:15.000000000 +0100
-+++ ./src/Composer/Autoload/AutoloadGenerator.php 2022-01-25 09:50:21.373957265 +0100
-@@ -419,7 +419,7 @@ EOF;
- $filesystem->filePutContentsIfModified($targetDir.'/autoload_real.php', $this->getAutoloadRealFile(true, (bool) $includePathFileContents, $targetDirLoader, (bool) $includeFilesFileContents, $vendorPathCode, $appBaseDirCode, $suffix, $useGlobalIncludePath, $prependAutoloader, $staticPhpVersion, $checkPlatform));
+--- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2022-03-16 09:47:01.000000000 +0100
++++ ./src/Composer/Autoload/AutoloadGenerator.php 2022-03-16 09:53:25.479618079 +0100
+@@ -418,7 +418,7 @@ EOF;
+ $filesystem->filePutContentsIfModified($targetDir.'/autoload_real.php', $this->getAutoloadRealFile(true, (bool) $includePathFileContents, $targetDirLoader, (bool) $includeFilesFileContents, $vendorPathCode, $appBaseDirCode, $suffix, $useGlobalIncludePath, $prependAutoloader, $checkPlatform));
$filesystem->safeCopy(__DIR__.'/ClassLoader.php', $targetDir.'/ClassLoader.php');
- $filesystem->safeCopy(__DIR__.'/../../../LICENSE', $targetDir.'/LICENSE');
@@ -23,9 +23,9 @@ diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autolo
if ($this->runScripts) {
$this->eventDispatcher->dispatchScript(ScriptEvents::POST_AUTOLOAD_DUMP, $this->devMode, array(), array(
diff -up ./src/Composer/Compiler.php.rpm ./src/Composer/Compiler.php
---- ./src/Composer/Compiler.php.rpm 2022-01-25 09:39:15.000000000 +0100
-+++ ./src/Composer/Compiler.php 2022-01-25 09:50:21.373957265 +0100
-@@ -125,7 +125,7 @@ class Compiler
+--- ./src/Composer/Compiler.php.rpm 2022-03-16 09:47:01.000000000 +0100
++++ ./src/Composer/Compiler.php 2022-03-16 09:53:25.480618076 +0100
+@@ -107,7 +107,7 @@ class Compiler
// Add Composer resources
$finder = new Finder();
$finder->files()
@@ -35,9 +35,9 @@ diff -up ./src/Composer/Compiler.php.rpm ./src/Composer/Compiler.php
;
foreach ($finder as $file) {
diff -up ./src/Composer/InstalledVersions.php.rpm ./src/Composer/InstalledVersions.php
---- ./src/Composer/InstalledVersions.php.rpm 2022-01-25 09:39:15.000000000 +0100
-+++ ./src/Composer/InstalledVersions.php 2022-01-25 09:50:21.373957265 +0100
-@@ -264,7 +264,7 @@ class InstalledVersions
+--- ./src/Composer/InstalledVersions.php.rpm 2022-03-16 09:47:01.000000000 +0100
++++ ./src/Composer/InstalledVersions.php 2022-03-16 09:53:25.480618076 +0100
+@@ -266,7 +266,7 @@ class InstalledVersions
if (null === self::$installed) {
// only require the installed.php file if this file is loaded from its dumped location,
// and not from its source location in the composer/composer package, see https://github.com/composer/composer/issues/9937
@@ -46,7 +46,7 @@ diff -up ./src/Composer/InstalledVersions.php.rpm ./src/Composer/InstalledVersio
self::$installed = include __DIR__ . '/installed.php';
} else {
self::$installed = array();
-@@ -337,7 +337,7 @@ class InstalledVersions
+@@ -339,7 +339,7 @@ class InstalledVersions
if (null === self::$installed) {
// only require the installed.php file if this file is loaded from its dumped location,
// and not from its source location in the composer/composer package, see https://github.com/composer/composer/issues/9937
@@ -56,82 +56,29 @@ diff -up ./src/Composer/InstalledVersions.php.rpm ./src/Composer/InstalledVersio
} else {
self::$installed = array();
diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
---- ./src/Composer/Json/JsonFile.php.rpm 2022-01-25 09:39:15.000000000 +0100
-+++ ./src/Composer/Json/JsonFile.php 2022-01-25 09:50:21.373957265 +0100
-@@ -35,7 +35,7 @@ class JsonFile
- const JSON_PRETTY_PRINT = 128;
- const JSON_UNESCAPED_UNICODE = 256;
+--- ./src/Composer/Json/JsonFile.php.rpm 2022-03-16 09:54:28.547422853 +0100
++++ ./src/Composer/Json/JsonFile.php 2022-03-16 09:56:07.126118722 +0100
+@@ -38,7 +38,7 @@ class JsonFile
+ /** @deprecated Use \JSON_UNESCAPED_UNICODE */
+ public const JSON_UNESCAPED_UNICODE = 256;
-- const COMPOSER_SCHEMA_PATH = '/../../../res/composer-schema.json';
-+ const COMPOSER_SCHEMA_PATH = '/usr/share/composer/res/composer-schema.json';
+- public const COMPOSER_SCHEMA_PATH = __DIR__ . '/../../../res/composer-schema.json';
++ public const COMPOSER_SCHEMA_PATH = '/usr/share/composer/res/composer-schema.json';
/** @var string */
private $path;
-@@ -197,7 +197,7 @@ class JsonFile
+@@ -200,7 +200,7 @@ class JsonFile
$isComposerSchemaFile = false;
if (null === $schemaFile) {
$isComposerSchemaFile = true;
-- $schemaFile = __DIR__ . self::COMPOSER_SCHEMA_PATH;
+- $schemaFile = self::COMPOSER_SCHEMA_PATH;
+ $schemaFile = (getenv('BUILDROOT')?:'') . self::COMPOSER_SCHEMA_PATH;
}
// Prepend with file:// only when not using a special schema already (e.g. in the phar)
-diff -up ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm ./tests/Composer/Test/Json/ComposerSchemaTest.php
---- ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm 2022-01-25 09:39:15.000000000 +0100
-+++ ./tests/Composer/Test/Json/ComposerSchemaTest.php 2022-01-25 09:50:21.373957265 +0100
-@@ -97,7 +97,8 @@ class ComposerSchemaTest extends TestCas
- private function check($json)
- {
- $validator = new Validator();
-- $validator->check(json_decode($json), (object) array('$ref' => 'file://' . __DIR__ . '/../../../../res/composer-schema.json'));
-+ $f = (getenv('BUILDROOT')?:'') . '/usr/share/composer/res/composer-schema.json';
-+ $validator->check(json_decode($json), (object) array('$ref' => 'file://' . $f));
-
- if (!$validator->isValid()) {
- $errors = $validator->getErrors();
-diff -up ./tests/Composer/Test/PolyfillTestCase.php.rpm ./tests/Composer/Test/PolyfillTestCase.php
---- ./tests/Composer/Test/PolyfillTestCase.php.rpm 2022-01-25 09:39:15.000000000 +0100
-+++ ./tests/Composer/Test/PolyfillTestCase.php 2022-01-25 09:50:21.373957265 +0100
-@@ -15,10 +15,35 @@ namespace Composer\Test {
- use PHPUnit\Framework\Constraint\LogicalNot;
- use PHPUnit\Framework\Constraint\StringContains;
-
-- if (method_exists('PHPUnit\Framework\TestCase', 'assertStringContainsString')) {
-+ if (method_exists('PHPUnit\Framework\TestCase', 'assertFileDoesNotExist')) {
- abstract class PolyfillTestCase extends TestCase
- {
- }
-+ } else if (method_exists('PHPUnit\Framework\TestCase', 'assertStringContainsString')) {
-+ abstract class PolyfillTestCase extends TestCase {
-+ /**
-+ * @param string $filename
-+ * @param string $message
-+ *
-+ * @return void
-+ */
-+ public static function assertFileDoesNotExist($filename, $message = '')
-+ {
-+ static::assertFileNotExists($filename, $message);
-+ }
-+
-+ /**
-+ * @param string $pattern
-+ * @param string $string
-+ * @param string $message
-+ *
-+ * @return void
-+ */
-+ public static function assertMatchesRegularExpression($pattern, $string, $message = '')
-+ {
-+ static::assertRegExp($pattern, $string, $message);
-+ }
-+ }
- } else {
- abstract class PolyfillTestCase extends TestCase
- {
diff -up ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php.rpm ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php
---- ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php.rpm 2022-01-25 09:50:57.595802751 +0100
-+++ ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php 2022-01-25 09:51:36.038638770 +0100
+--- ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php.rpm 2021-10-28 22:44:15.000000000 +0200
++++ ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php 2022-03-16 09:53:25.480618076 +0100
@@ -125,7 +125,7 @@ class CaBundle
*/
public static function getBundledCaBundlePath()
@@ -141,3 +88,16 @@ diff -up ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php.rpm ./src/Com
// cURL does not understand 'phar://' paths
// see https://github.com/composer/ca-bundle/issues/10
+diff -up ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm ./tests/Composer/Test/Json/ComposerSchemaTest.php
+--- ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm 2022-03-16 09:47:01.000000000 +0100
++++ ./tests/Composer/Test/Json/ComposerSchemaTest.php 2022-03-16 09:53:25.480618076 +0100
+@@ -97,7 +97,8 @@ class ComposerSchemaTest extends TestCas
+ private function check(string $json)
+ {
+ $validator = new Validator();
+- $validator->check(json_decode($json), (object) array('$ref' => 'file://' . __DIR__ . '/../../../../res/composer-schema.json'));
++ $f = (getenv('BUILDROOT')?:'') . '/usr/share/composer/res/composer-schema.json';
++ $validator->check(json_decode($json), (object) array('$ref' => 'file://' . $f));
+
+ if (!$validator->isValid()) {
+ $errors = $validator->getErrors();
diff --git a/composer.json b/composer.json
index a5f2171..80b97d6 100644
--- a/composer.json
+++ b/composer.json
@@ -22,26 +22,32 @@
}
],
"require": {
- "php": "^5.3.2 || ^7.0 || ^8.0",
+ "php": "^7.2.5 || ^8.0",
"composer/ca-bundle": "^1.0",
"composer/metadata-minifier": "^1.0",
"composer/semver": "^3.0",
"composer/spdx-licenses": "^1.2",
- "composer/xdebug-handler": "^2.0 || ^3.0",
+ "composer/xdebug-handler": "^2.0.2 || ^3.0.3",
"justinrainbow/json-schema": "^5.2.11",
- "psr/log": "^1.0 || ^2.0",
+ "psr/log": "^1.0 || ^2.0 || ^3.0",
"seld/jsonlint": "^1.4",
- "seld/phar-utils": "^1.0",
- "symfony/console": "^2.8.52 || ^3.4.35 || ^4.4 || ^5.0",
- "symfony/filesystem": "^2.8.52 || ^3.4.35 || ^4.4 || ^5.0 || ^6.0",
- "symfony/finder": "^2.8.52 || ^3.4.35 || ^4.4 || ^5.0 || ^6.0",
- "symfony/process": "^2.8.52 || ^3.4.35 || ^4.4 || ^5.0 || ^6.0",
- "react/promise": "^1.2 || ^2.7",
- "composer/pcre": "^1.0"
+ "seld/phar-utils": "^1.2",
+ "symfony/console": "^5.4.1 || ^6.0",
+ "symfony/filesystem": "^5.4 || ^6.0",
+ "symfony/finder": "^5.4 || ^6.0",
+ "symfony/process": "^5.4 || ^6.0",
+ "react/promise": "^2.8",
+ "composer/pcre": "^2 || ^3",
+ "symfony/polyfill-php73": "^1.24",
+ "symfony/polyfill-php80": "^1.24"
},
"require-dev": {
- "symfony/phpunit-bridge": "^4.2 || ^5.0 || ^6.0",
- "phpspec/prophecy": "^1.10"
+ "symfony/phpunit-bridge": "^6.0",
+ "phpstan/phpstan": "^1.4.1",
+ "phpstan/phpstan-phpunit": "^1.0",
+ "phpstan/phpstan-deprecation-rules": "^1",
+ "phpstan/phpstan-strict-rules": "^1",
+ "phpstan/phpstan-symfony": "^1.1"
},
"suggest": {
"ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -50,13 +56,13 @@
},
"config": {
"platform": {
- "php": "5.3.9"
+ "php": "7.2.5"
},
"platform-check": false
},
"extra": {
"branch-alias": {
- "dev-main": "2.2-dev"
+ "dev-main": "2.3-dev"
}
},
"autoload": {
@@ -66,13 +72,8 @@
},
"autoload-dev": {
"psr-4": {
- "Composer\\Test\\": "tests/Composer/Test",
- "Composer\\PHPStanRules\\": "phpstan/Rules/src",
- "Composer\\PHPStanRulesTests\\": "phpstan/Rules/tests"
- },
- "classmap": [
- "phpstan/Rules/tests/data"
- ]
+ "Composer\\Test\\": "tests/Composer/Test"
+ }
},
"bin": [
"bin/composer"
@@ -80,19 +81,12 @@
"scripts": {
"compile": "@php -dphar.readonly=0 bin/compile",
"test": "@php simple-phpunit",
- "phpstan-setup": [
- "@composer config platform --unset",
- "@composer update",
- "@composer require --dev phpstan/phpstan:1.4.* phpstan/phpstan-phpunit:1.0.* phpstan/phpstan-deprecation-rules:1.0.* phpstan/phpstan-strict-rules:1.1.* phpunit/phpunit:^7.5.20 --with-all-dependencies",
- "git checkout composer.json composer.lock"
- ],
"phpstan": "@php vendor/bin/phpstan analyse --configuration=phpstan/config.neon"
},
"scripts-descriptions": {
"compile": "Compile composer.phar",
"test": "Run all tests",
- "phpstan-setup": "Prepare environment to run PHPStan locally (must be run with PHP7.4)",
- "phpstan": "Runs PHPStan (after phpstan-setup was executed, must be run with PHP7.4)"
+ "phpstan": "Runs PHPStan"
},
"support": {
"issues": "https://github.com/composer/composer/issues",
diff --git a/composer.spec b/composer.spec
index 78a5c67..c3ba1a7 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%if 0%{?fedora}
+%if 0
%bcond_without tests
%bcond_without syslib
%else
@@ -18,21 +18,21 @@
%bcond_with syslib
%endif
-%global gh_commit 07eccf080ad63d55d95a7c9133506db7d9029264
+%global gh_commit 36dc875e1c6d5ce9411c78aae22b33ac24c86e13
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
%global gh_project composer
-%global api_version 2.2.0
+%global api_version 2.3.0
%global run_version 2.2.2
-%global upstream_version 2.2.9
-#global upstream_prever RC1
-#global upstream_lower rc1
+%global upstream_version 2.3.0
+%global upstream_prever RC2
+%global upstream_lower rc2
-%global symfony_prefix php-symfony4
-%global symfony_path %{_datadir}/php/Symfony4
-%global symfony_min 4.4
+%global symfony_prefix php-symfony5
+%global symfony_path %{_datadir}/php/Symfony5
+%global symfony_min 5.4.1
%global _phpunit %{_bindir}/phpunit9
@@ -68,26 +68,26 @@ BuildRequires: (php-composer(composer/ca-bundle) >= 1.0 with php-com
BuildRequires: (php-composer(composer/metadata-minifier) >= 1.0 with php-composer(composer/metadata-minifier) < 2)
BuildRequires: (php-composer(composer/semver) >= 3.0 with php-composer(composer/semver) < 4)
BuildRequires: (php-composer(composer/spdx-licenses) >= 1.2 with php-composer(composer/spdx-licenses) < 2)
-BuildRequires: (php-composer(composer/xdebug-handler) >= 2.0 with php-composer(composer/xdebug-handler) < 4)
+BuildRequires: (php-composer(composer/xdebug-handler) >= 2.0.2 with php-composer(composer/xdebug-handler) < 4)
BuildRequires: (php-composer(seld/jsonlint) >= 1.4 with php-composer(seld/jsonlint) < 2)
-BuildRequires: (php-composer(seld/phar-utils) >= 1.1 with php-composer(seld/phar-utils) < 2)
-BuildRequires: (php-composer(psr/log) >= 1.1 with php-composer(psr/log) < 3)
+BuildRequires: (php-composer(seld/phar-utils) >= 1.2 with php-composer(seld/phar-utils) < 2)
+BuildRequires: (php-composer(psr/log) >= 1.1 with php-composer(psr/log) < 4)
BuildRequires: (php-composer(justinrainbow/json-schema) >= 5.2.11 with php-composer(justinrainbow/json-schema) < 6)
BuildRequires: (php-composer(react/promise) >= 2.7 with php-composer(react/promise) < 3)
-BuildRequires: (php-composer(composer/pcre) >= 1.0 with php-composer(composer/pcre) < 2)
+BuildRequires: (php-composer(composer/pcre) >= 2 with php-composer(composer/pcre) < 4)
# remirepo:13
%else
BuildRequires: php-composer-ca-bundle
BuildRequires: php-composer-metadata-minifier
BuildRequires: php-composer-semver3
BuildRequires: php-composer-spdx-licenses >= 1.2
-BuildRequires: php-composer-xdebug-handler2
+BuildRequires: php-composer-xdebug-handler2 >= 2.0.2
BuildRequires: php-jsonlint >= 1.4
-BuildRequires: php-seld-phar-utils >= 1.1
+BuildRequires: php-seld-phar-utils >= 1.2
BuildRequires: php-PsrLog >= 1.1
BuildRequires: php-justinrainbow-json-schema5 >= 5.2.11
BuildRequires: php-react-promise >= 2.7
-BuildRequires: php-composer-pcre
+BuildRequires: php-composer-pcre3
%endif
BuildRequires: %{symfony_prefix}-console >= %{symfony_min}
BuildRequires: %{symfony_prefix}-finder >= %{symfony_min}
@@ -103,22 +103,24 @@ BuildRequires: php-fedora-autoloader-devel
%endif
# From composer.json, "require": {
-# "php": "^5.3.2 || ^7.0",
+# "php": "^7.2.5 || ^8.0",
# "composer/ca-bundle": "^1.0",
# "composer/metadata-minifier": "^1.0",
# "composer/semver": "^3.0",
# "composer/spdx-licenses": "^1.2",
-# "composer/xdebug-handler": "^2.0 || ^3.0",
+# "composer/xdebug-handler": "^2.0.2 || ^3.0.3",
# "justinrainbow/json-schema": "^5.2.11",
-# "psr/log": "^1.0 || ^2.0"
+# "psr/log": "^1.0 || ^2.0 || ^3.0"
# "seld/jsonlint": "~1.4",
-# "seld/phar-utils": "^1.0",
-# "symfony/console": "^2.8.52 || ^3.4.35 || ^4.4 || ^5.0",
-# "symfony/filesystem": "^2.8.52 || ^3.4.35 || ^4.4 || ^5.0 || ^6.0",
-# "symfony/finder": "^2.8.52 || ^3.4.35 || ^4.4 || ^5.0 || ^6.0",
-# "symfony/process": "^^2.8.52 || ^3.4.35 || ^4.4 || ^5.0 || ^6.0",
-# "react/promise": "^1.2 || ^2.7",
-# "composer/pcre": "^1.0"
+# "seld/phar-utils": "^1.2",
+# "symfony/console": "^5.4.1 || ^6.0",
+# "symfony/filesystem": "^5.4 || ^6.0",
+# "symfony/finder": "^5.4 || ^6.0",
+# "symfony/process": "^5.4 || ^6.0",
+# "react/promise": "^2.8",
+# "composer/pcre": "^2 || ^3"
+# "symfony/polyfill-php73": "^1.24",
+# "symfony/polyfill-php80": "^1.24"
Requires: php(language) >= 7.2.5
Requires: php-cli
%if %{with syslib}
@@ -128,26 +130,26 @@ Requires: (php-composer(composer/ca-bundle) >= 1.0 with php-com
Requires: (php-composer(composer/metadata-minifier) >= 1.0 with php-composer(composer/metadata-minifier) < 2)
Requires: (php-composer(composer/semver) >= 3.0 with php-composer(composer/semver) < 4)
Requires: (php-composer(composer/spdx-licenses) >= 1.2 with php-composer(composer/spdx-licenses) < 2)
-Requires: (php-composer(composer/xdebug-handler) >= 2.0 with php-composer(composer/xdebug-handler) < 4)
+Requires: (php-composer(composer/xdebug-handler) >= 2.0.2 with php-composer(composer/xdebug-handler) < 4)
Requires: (php-composer(seld/jsonlint) >= 1.4 with php-composer(seld/jsonlint) < 2)
-Requires: (php-composer(seld/phar-utils) >= 1.1 with php-composer(seld/phar-utils) < 2)
-Requires: (php-composer(psr/log) >= 1.1 with php-composer(psr/log) < 3)
+Requires: (php-composer(seld/phar-utils) >= 1.2 with php-composer(seld/phar-utils) < 2)
+Requires: (php-composer(psr/log) >= 1.1 with php-composer(psr/log) < 4)
Requires: (php-composer(justinrainbow/json-schema) >= 5.2.11 with php-composer(justinrainbow/json-schema) < 6)
Requires: (php-composer(react/promise) >= 2.7 with php-composer(react/promise) < 3)
-Requires: (php-composer(composer/pcre) >= 1.0 with php-composer(composer/pcre) < 2)
+Requires: (php-composer(composer/pcre) >= 2 with php-composer(composer/pcre) < 4)
# remirepo:13
%else
Requires: php-composer-ca-bundle
Requires: php-composer-metadata-minifier
Requires: php-composer-semver3
Requires: php-composer-spdx-licenses >= 1.2
-Requires: php-composer-xdebug-handler2
+Requires: php-composer-xdebug-handler2 >= 2.0.2
Requires: php-jsonlint >= 1.4
-Requires: php-seld-phar-utils >= 1.1
+Requires: php-seld-phar-utils >= 1.2
Requires: php-PsrLog >= 1.1
Requires: php-justinrainbow-json-schema5 >= 5.2.11
Requires: php-react-promise >= 2.7
-Requires: php-composer-pcre
+Requires: php-composer-pcre3
%endif
Requires: %{symfony_prefix}-console >= %{symfony_min}
Requires: %{symfony_prefix}-finder >= %{symfony_min}
@@ -161,8 +163,8 @@ Requires: ca-certificates
# Bundled libraries
Provides: bundled(php-composer-ca-bundle) = 1.3.1
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
-Provides: bundled(php-composer-pcre) = 1.0.1
-Provides: bundled(php-composer-semver) = 3.3.0
+Provides: bundled(php-composer-pcre) = 2.0.0
+Provides: bundled(php-composer-semver) = 3.3.1
Provides: bundled(php-composer-spdx-licenses) = 1.5.6
Provides: bundled(php-composer-xdebug-handler) = 3.0.3
Provides: bundled(php-justinrainbow-json-schema) = 5.2.11
@@ -264,8 +266,11 @@ cat << 'EOF' | tee -a src/Composer/autoload.php
'%{_datadir}/php/Composer/Spdx/autoload.php',
'%{_datadir}/php/Composer/MetadataMinifier/autoload.php',
'%{_datadir}/php/Composer/Semver3/autoload.php',
- '%{_datadir}/php/Composer/Pcre/autoload.php',
[
+ '%{_datadir}/php/Composer/Pcre3/autoload.php',
+ '%{_datadir}/php/Composer/Pcre2/autoload.php',
+ ], [
+ '%{_datadir}/php/Psr/Log3/autoload.php',
'%{_datadir}/php/Psr/Log2/autoload.php',
'%{_datadir}/php/Psr/Log/autoload.php',
],
@@ -408,6 +413,14 @@ exit $ret
%changelog
+* Mon Mar 21 2022 Remi Collet <remi@remirepo.net> - 2.3.0~RC2-1
+- update to 2.3.0RC2
+
+* Wed Mar 16 2022 Remi Collet <remi@remirepo.net> - 2.3.0~RC1-1
+- update to 2.3.0RC1
+- always use bundled libraries
+ as symfony/* 5.4 and composer/pcre 2 are not available
+
* Wed Mar 16 2022 Remi Collet <remi@remirepo.net> - 2.2.9-1
- update to 2.2.9
diff --git a/installed.json b/installed.json
index b9fa2c7..07abc37 100644
--- a/installed.json
+++ b/installed.json
@@ -153,32 +153,32 @@
},
{
"name": "composer/pcre",
- "version": "1.0.1",
- "version_normalized": "1.0.1.0",
+ "version": "2.0.0",
+ "version_normalized": "2.0.0.0",
"source": {
"type": "git",
"url": "https://github.com/composer/pcre.git",
- "reference": "67a32d7d6f9f560b726ab25a061b38ff3a80c560"
+ "reference": "c8e9d27cfc5ed22643c19c160455b473ffd8aabe"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/pcre/zipball/67a32d7d6f9f560b726ab25a061b38ff3a80c560",
- "reference": "67a32d7d6f9f560b726ab25a061b38ff3a80c560",
+ "url": "https://api.github.com/repos/composer/pcre/zipball/c8e9d27cfc5ed22643c19c160455b473ffd8aabe",
+ "reference": "c8e9d27cfc5ed22643c19c160455b473ffd8aabe",
"shasum": ""
},
"require": {
- "php": "^5.3.2 || ^7.0 || ^8.0"
+ "php": "^7.2 || ^8.0"
},
"require-dev": {
"phpstan/phpstan": "^1.3",
"phpstan/phpstan-strict-rules": "^1.1",
- "symfony/phpunit-bridge": "^4.2 || ^5"
+ "symfony/phpunit-bridge": "^5"
},
- "time": "2022-01-21T20:24:37+00:00",
+ "time": "2022-02-25T20:05:29+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.x-dev"
+ "dev-main": "2.x-dev"
}
},
"installation-source": "dist",
@@ -207,7 +207,7 @@
],
"support": {
"issues": "https://github.com/composer/pcre/issues",
- "source": "https://github.com/composer/pcre/tree/1.0.1"
+ "source": "https://github.com/composer/pcre/tree/2.0.0"
},
"funding": [
{
@@ -227,17 +227,17 @@
},
{
"name": "composer/semver",
- "version": "3.3.0",
- "version_normalized": "3.3.0.0",
+ "version": "3.3.1",
+ "version_normalized": "3.3.1.0",
"source": {
"type": "git",
"url": "https://github.com/composer/semver.git",
- "reference": "f79c90ad4e9b41ac4dfc5d77bf398cf61fbd718b"
+ "reference": "5d8e574bb0e69188786b8ef77d43341222a41a71"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/semver/zipball/f79c90ad4e9b41ac4dfc5d77bf398cf61fbd718b",
- "reference": "f79c90ad4e9b41ac4dfc5d77bf398cf61fbd718b",
+ "url": "https://api.github.com/repos/composer/semver/zipball/5d8e574bb0e69188786b8ef77d43341222a41a71",
+ "reference": "5d8e574bb0e69188786b8ef77d43341222a41a71",
"shasum": ""
},
"require": {
@@ -247,7 +247,7 @@
"phpstan/phpstan": "^1.4",
"symfony/phpunit-bridge": "^4.2 || ^5"
},
- "time": "2022-03-15T08:35:57+00:00",
+ "time": "2022-03-16T11:22:07+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -291,7 +291,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/semver/issues",
- "source": "https://github.com/composer/semver/tree/3.3.0"
+ "source": "https://github.com/composer/semver/tree/3.3.1"
},
"funding": [
{