summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-05 08:26:36 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-05 08:26:36 +0200
commit1831f73d89bb7b39cbc4e77f10fcf63c96284663 (patch)
treed7ec4da119540c5d91fb8e40020fac769f481b3f
parentd9bf2ed8e3744dd093ba0a9375577cf35a5583af (diff)
php-bartlett-php-compatinfo-db: 1.10.0
-rw-r--r--composer.json7
-rw-r--r--composer.spec13
2 files changed, 11 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 10fc4f8..fc3d584 100644
--- a/composer.json
+++ b/composer.json
@@ -23,7 +23,7 @@
},
"require": {
"php": "^5.3.2 || ^7.0",
- "justinrainbow/json-schema": "^1.6",
+ "justinrainbow/json-schema": "^1.6 || ^2.0",
"composer/ca-bundle": "^1.0",
"composer/semver": "^1.0",
"composer/spdx-licenses": "^1.0",
@@ -38,9 +38,8 @@
},
"require-dev": {
"phpunit/phpunit": "^4.5 || ^5.0.5",
- "phpunit/phpunit-mock-objects": "2.3.0 || ^3.0"
+ "phpunit/phpunit-mock-objects": "^2.3 || ^3.0"
},
- "_": "phpunit/phpunit-mock-objects required in 2.3.0 due to https://github.com/sebastianbergmann/phpunit-mock-objects/issues/223 - needs hhvm 3.8+ on travis",
"config": {
"platform": {
"php": "5.3.9"
@@ -60,7 +59,7 @@
"bin": ["bin/composer"],
"extra": {
"branch-alias": {
- "dev-master": "1.1-dev"
+ "dev-master": "1.2-dev"
}
},
"scripts": {
diff --git a/composer.spec b/composer.spec
index 48c8f03..48c92ca 100644
--- a/composer.spec
+++ b/composer.spec
@@ -6,14 +6,14 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 30ab6f1c1753267d181839142fafe022313c3c9a
+%global gh_commit e3c36a766b0791abcbc8876b4a5cb4bde10a5f1b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 1.0-dev
%global gh_owner composer
%global gh_project composer
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
-%global api_version 1.1.0
-#global prever RC
+%global api_version 1.2.0
+%global prever RC
Name: composer
Version: 1.1.3
@@ -50,7 +50,7 @@ BuildRequires: php-composer(symfony/process) >= 2.1
BuildRequires: php-zip
# From composer.json, "require-dev": {
# "phpunit/phpunit": "^4.5 || ^5.0.5",
-# "phpunit/phpunit-mock-objects": "2.3.0 || ^3.0"
+# "phpunit/phpunit-mock-objects": "^2.3 || ^3.0"
BuildRequires: php-composer(phpunit/phpunit) >= 4.5
# For autoloader
BuildRequires: php-composer(symfony/class-loader)
@@ -61,7 +61,7 @@ BuildRequires: php-PsrLog >= 1.0.0-8
# From composer.json, "require": {
# "php": "^5.3.2 || ^7.0",
-# "justinrainbow/json-schema": "^1.6",
+# "justinrainbow/json-schema": "^1.6 || ^2.0",
# "composer/ca-bundle": "^1.0",
# "composer/semver": "^1.0",
# "composer/spdx-licenses": "^1.0",
@@ -241,6 +241,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jul 5 2016 Remi Collet <remi@fedoraproject.org> - 1.2.0-0.1.RC
+- update to 1.2.0-RC
+
* Sun Jun 26 2016 Remi Collet <remi@fedoraproject.org> - 1.1.3-1
- update to 1.1.3