summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-20 13:45:31 +0100
committerRemi Collet <remi@php.net>2022-12-20 13:45:31 +0100
commit09ade9d89a9f0e1c917683f8ed8590be46793470 (patch)
tree45c4c1fe822aa9bb5b19caa71c722f96475a31e3
parentab250273e212c69343f3a4199b3b8c44be40d24b (diff)
update to 2.5.0
-rw-r--r--composer-bash-completion9
-rw-r--r--composer.json7
-rw-r--r--composer.spec28
-rw-r--r--installed.json218
4 files changed, 175 insertions, 87 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index dba4a5c..64aa6bb 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -11,20 +11,21 @@ _sf_composer() {
local sf_cmd="${COMP_WORDS[0]}"
# for an alias, get the real script behind it
- if [[ $(type -t $sf_cmd) == "alias" ]]; then
+ sf_cmd_type=$(type -t $sf_cmd)
+ if [[ $sf_cmd_type == "alias" ]]; then
sf_cmd=$(alias $sf_cmd | sed -E "s/alias $sf_cmd='(.*)'/\1/")
- else
+ elif [[ $sf_cmd_type == "file" ]]; then
sf_cmd=$(type -p $sf_cmd)
fi
- if [ ! -x "$sf_cmd" ]; then
+ if [[ $sf_cmd_type != "function" && ! -x $sf_cmd ]]; then
return 1
fi
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.4.4")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.5.0")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.json b/composer.json
index 780f051..da53892 100644
--- a/composer.json
+++ b/composer.json
@@ -38,14 +38,15 @@
"symfony/finder": "^5.4 || ^6.0",
"symfony/process": "^5.4 || ^6.0",
"react/promise": "^2.8",
- "composer/pcre": "^2 || ^3",
+ "composer/pcre": "^2.1 || ^3.1",
"symfony/polyfill-php73": "^1.24",
"symfony/polyfill-php80": "^1.24",
+ "symfony/polyfill-php81": "^1.24",
"seld/signal-handler": "^2.0"
},
"require-dev": {
"symfony/phpunit-bridge": "^6.0",
- "phpstan/phpstan": "^1.4.1",
+ "phpstan/phpstan": "^1.9.3",
"phpstan/phpstan-phpunit": "^1.0",
"phpstan/phpstan-deprecation-rules": "^1",
"phpstan/phpstan-strict-rules": "^1",
@@ -64,7 +65,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "2.4-dev"
+ "dev-main": "2.5-dev"
},
"phpstan": {
"includes": [
diff --git a/composer.spec b/composer.spec
index 049e5a7..dce242c 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit e8d9087229bcdbc5867594d3098091412f1130cf
+%global gh_commit 09ef0e3acbb377f28927fa6a527c251da713ebac
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.3.0
%global run_version 2.2.2
-%global upstream_version 2.4.4
+%global upstream_version 2.5.0
#global upstream_prever RC1
#global upstream_lower rc1
@@ -32,7 +32,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
Release: 1%{?dist}
Summary: Dependency Manager for PHP
-# composer and all dependencies are MIT
+# SPDX: composer and all dependencies are MIT
License: MIT
URL: https://getcomposer.org/
Source0: %{gh_project}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tgz
@@ -83,7 +83,7 @@ Requires: ca-certificates
Provides: bundled(php-composer-ca-bundle) = 1.3.4
Provides: bundled(php-composer-class-map-generator) = 1.0.0
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
-Provides: bundled(php-composer-pcre) = 2.0.0
+Provides: bundled(php-composer-pcre) = 2.1.0
Provides: bundled(php-composer-semver) = 3.3.2
Provides: bundled(php-composer-spdx-licenses) = 1.5.7
Provides: bundled(php-composer-xdebug-handler) = 3.0.3
@@ -94,19 +94,20 @@ Provides: bundled(php-react-promise) = v2.9.0
Provides: bundled(php-seld-jsonlint) = 1.9.0
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.1
-Provides: bundled(php-symfony-console) = v5.4.14
+Provides: bundled(php-symfony-console) = v5.4.16
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
Provides: bundled(php-symfony-filesystem) = v5.4.13
Provides: bundled(php-symfony-finder) = v5.4.11
-Provides: bundled(php-symfony-polyfill-ctype) = v1.26.0
-Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.26.0
-Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.26.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.26.0
-Provides: bundled(php-symfony-polyfill-php73) = v1.26.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.26.0
+Provides: bundled(php-symfony-polyfill-ctype) = v1.27.0
+Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.27.0
+Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.27.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
Provides: bundled(php-symfony-process) = v5.4.11
Provides: bundled(php-symfony-service-contracts) = v2.5.2
-Provides: bundled(php-symfony-string) = v5.4.14
+Provides: bundled(php-symfony-string) = v5.4.15
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -248,6 +249,9 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Tue Dec 20 2022 Remi Collet <remi@remirepo.net> - 2.5.0-1
+- update to 2.5.0
+
* Fri Oct 28 2022 Remi Collet <remi@remirepo.net> - 2.4.4-1
- update to 2.4.4
diff --git a/installed.json b/installed.json
index 459b3d4..d1b46be 100644
--- a/installed.json
+++ b/installed.json
@@ -229,17 +229,17 @@
},
{
"name": "composer/pcre",
- "version": "2.0.0",
- "version_normalized": "2.0.0.0",
+ "version": "2.1.0",
+ "version_normalized": "2.1.0.0",
"source": {
"type": "git",
"url": "https://github.com/composer/pcre.git",
- "reference": "c8e9d27cfc5ed22643c19c160455b473ffd8aabe"
+ "reference": "3fdb2807b31a78a40ad89570e30ec77466c98717"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/pcre/zipball/c8e9d27cfc5ed22643c19c160455b473ffd8aabe",
- "reference": "c8e9d27cfc5ed22643c19c160455b473ffd8aabe",
+ "url": "https://api.github.com/repos/composer/pcre/zipball/3fdb2807b31a78a40ad89570e30ec77466c98717",
+ "reference": "3fdb2807b31a78a40ad89570e30ec77466c98717",
"shasum": ""
},
"require": {
@@ -250,7 +250,7 @@
"phpstan/phpstan-strict-rules": "^1.1",
"symfony/phpunit-bridge": "^5"
},
- "time": "2022-02-25T20:05:29+00:00",
+ "time": "2022-11-16T18:32:04+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -283,7 +283,7 @@
],
"support": {
"issues": "https://github.com/composer/pcre/issues",
- "source": "https://github.com/composer/pcre/tree/2.0.0"
+ "source": "https://github.com/composer/pcre/tree/2.1.0"
},
"funding": [
{
@@ -977,17 +977,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.14",
- "version_normalized": "5.4.14.0",
+ "version": "v5.4.16",
+ "version_normalized": "5.4.16.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "984ea2c0f45f42dfed01d2f3987b187467c4b16d"
+ "reference": "8e9b9c8dfb33af6057c94e1b44846bee700dc5ef"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/984ea2c0f45f42dfed01d2f3987b187467c4b16d",
- "reference": "984ea2c0f45f42dfed01d2f3987b187467c4b16d",
+ "url": "https://api.github.com/repos/symfony/console/zipball/8e9b9c8dfb33af6057c94e1b44846bee700dc5ef",
+ "reference": "8e9b9c8dfb33af6057c94e1b44846bee700dc5ef",
"shasum": ""
},
"require": {
@@ -1025,7 +1025,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2022-10-07T08:01:20+00:00",
+ "time": "2022-11-25T14:09:27+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1059,7 +1059,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.14"
+ "source": "https://github.com/symfony/console/tree/v5.4.16"
},
"funding": [
{
@@ -1282,17 +1282,17 @@
},
{
"name": "symfony/polyfill-ctype",
- "version": "v1.26.0",
- "version_normalized": "1.26.0.0",
+ "version": "v1.27.0",
+ "version_normalized": "1.27.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-ctype.git",
- "reference": "6fd1b9a79f6e3cf65f9e679b23af304cd9e010d4"
+ "reference": "5bbc823adecdae860bb64756d639ecfec17b050a"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/6fd1b9a79f6e3cf65f9e679b23af304cd9e010d4",
- "reference": "6fd1b9a79f6e3cf65f9e679b23af304cd9e010d4",
+ "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/5bbc823adecdae860bb64756d639ecfec17b050a",
+ "reference": "5bbc823adecdae860bb64756d639ecfec17b050a",
"shasum": ""
},
"require": {
@@ -1304,11 +1304,11 @@
"suggest": {
"ext-ctype": "For best performance"
},
- "time": "2022-05-24T11:49:31+00:00",
+ "time": "2022-11-03T14:55:06+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.26-dev"
+ "dev-main": "1.27-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1347,7 +1347,7 @@
"portable"
],
"support": {
- "source": "https://github.com/symfony/polyfill-ctype/tree/v1.26.0"
+ "source": "https://github.com/symfony/polyfill-ctype/tree/v1.27.0"
},
"funding": [
{
@@ -1367,17 +1367,17 @@
},
{
"name": "symfony/polyfill-intl-grapheme",
- "version": "v1.26.0",
- "version_normalized": "1.26.0.0",
+ "version": "v1.27.0",
+ "version_normalized": "1.27.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-grapheme.git",
- "reference": "433d05519ce6990bf3530fba6957499d327395c2"
+ "reference": "511a08c03c1960e08a883f4cffcacd219b758354"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/433d05519ce6990bf3530fba6957499d327395c2",
- "reference": "433d05519ce6990bf3530fba6957499d327395c2",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/511a08c03c1960e08a883f4cffcacd219b758354",
+ "reference": "511a08c03c1960e08a883f4cffcacd219b758354",
"shasum": ""
},
"require": {
@@ -1386,11 +1386,11 @@
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2022-05-24T11:49:31+00:00",
+ "time": "2022-11-03T14:55:06+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.26-dev"
+ "dev-main": "1.27-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1431,7 +1431,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.26.0"
+ "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.27.0"
},
"funding": [
{
@@ -1451,17 +1451,17 @@
},
{
"name": "symfony/polyfill-intl-normalizer",
- "version": "v1.26.0",
- "version_normalized": "1.26.0.0",
+ "version": "v1.27.0",
+ "version_normalized": "1.27.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-normalizer.git",
- "reference": "219aa369ceff116e673852dce47c3a41794c14bd"
+ "reference": "19bd1e4fcd5b91116f14d8533c57831ed00571b6"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/219aa369ceff116e673852dce47c3a41794c14bd",
- "reference": "219aa369ceff116e673852dce47c3a41794c14bd",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/19bd1e4fcd5b91116f14d8533c57831ed00571b6",
+ "reference": "19bd1e4fcd5b91116f14d8533c57831ed00571b6",
"shasum": ""
},
"require": {
@@ -1470,11 +1470,11 @@
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2022-05-24T11:49:31+00:00",
+ "time": "2022-11-03T14:55:06+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.26-dev"
+ "dev-main": "1.27-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1518,7 +1518,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.26.0"
+ "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.27.0"
},
"funding": [
{
@@ -1538,17 +1538,17 @@
},
{
"name": "symfony/polyfill-mbstring",
- "version": "v1.26.0",
- "version_normalized": "1.26.0.0",
+ "version": "v1.27.0",
+ "version_normalized": "1.27.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-mbstring.git",
- "reference": "9344f9cb97f3b19424af1a21a3b0e75b0a7d8d7e"
+ "reference": "8ad114f6b39e2c98a8b0e3bd907732c207c2b534"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/9344f9cb97f3b19424af1a21a3b0e75b0a7d8d7e",
- "reference": "9344f9cb97f3b19424af1a21a3b0e75b0a7d8d7e",
+ "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/8ad114f6b39e2c98a8b0e3bd907732c207c2b534",
+ "reference": "8ad114f6b39e2c98a8b0e3bd907732c207c2b534",
"shasum": ""
},
"require": {
@@ -1560,11 +1560,11 @@
"suggest": {
"ext-mbstring": "For best performance"
},
- "time": "2022-05-24T11:49:31+00:00",
+ "time": "2022-11-03T14:55:06+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.26-dev"
+ "dev-main": "1.27-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1604,7 +1604,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.26.0"
+ "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.27.0"
},
"funding": [
{
@@ -1624,27 +1624,27 @@
},
{
"name": "symfony/polyfill-php73",
- "version": "v1.26.0",
- "version_normalized": "1.26.0.0",
+ "version": "v1.27.0",
+ "version_normalized": "1.27.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php73.git",
- "reference": "e440d35fa0286f77fb45b79a03fedbeda9307e85"
+ "reference": "9e8ecb5f92152187c4799efd3c96b78ccab18ff9"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php73/zipball/e440d35fa0286f77fb45b79a03fedbeda9307e85",
- "reference": "e440d35fa0286f77fb45b79a03fedbeda9307e85",
+ "url": "https://api.github.com/repos/symfony/polyfill-php73/zipball/9e8ecb5f92152187c4799efd3c96b78ccab18ff9",
+ "reference": "9e8ecb5f92152187c4799efd3c96b78ccab18ff9",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2022-05-24T11:49:31+00:00",
+ "time": "2022-11-03T14:55:06+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.26-dev"
+ "dev-main": "1.27-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1686,7 +1686,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php73/tree/v1.26.0"
+ "source": "https://github.com/symfony/polyfill-php73/tree/v1.27.0"
},
"funding": [
{
@@ -1706,27 +1706,27 @@
},
{
"name": "symfony/polyfill-php80",
- "version": "v1.26.0",
- "version_normalized": "1.26.0.0",
+ "version": "v1.27.0",
+ "version_normalized": "1.27.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php80.git",
- "reference": "cfa0ae98841b9e461207c13ab093d76b0fa7bace"
+ "reference": "7a6ff3f1959bb01aefccb463a0f2cd3d3d2fd936"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/cfa0ae98841b9e461207c13ab093d76b0fa7bace",
- "reference": "cfa0ae98841b9e461207c13ab093d76b0fa7bace",
+ "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/7a6ff3f1959bb01aefccb463a0f2cd3d3d2fd936",
+ "reference": "7a6ff3f1959bb01aefccb463a0f2cd3d3d2fd936",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2022-05-10T07:21:04+00:00",
+ "time": "2022-11-03T14:55:06+00:00",
"type": "library",
"extra": {
"branch-alias": {
- "dev-main": "1.26-dev"
+ "dev-main": "1.27-dev"
},
"thanks": {
"name": "symfony/polyfill",
@@ -1772,7 +1772,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php80/tree/v1.26.0"
+ "source": "https://github.com/symfony/polyfill-php80/tree/v1.27.0"
},
"funding": [
{
@@ -1791,6 +1791,88 @@
"install-path": "../symfony/polyfill-php80"
},
{
+ "name": "symfony/polyfill-php81",
+ "version": "v1.27.0",
+ "version_normalized": "1.27.0.0",
+ "source": {
+ "type": "git",
+ "url": "https://github.com/symfony/polyfill-php81.git",
+ "reference": "707403074c8ea6e2edaf8794b0157a0bfa52157a"
+ },
+ "dist": {
+ "type": "zip",
+ "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/707403074c8ea6e2edaf8794b0157a0bfa52157a",
+ "reference": "707403074c8ea6e2edaf8794b0157a0bfa52157a",
+ "shasum": ""
+ },
+ "require": {
+ "php": ">=7.1"
+ },
+ "time": "2022-11-03T14:55:06+00:00",
+ "type": "library",
+ "extra": {
+ "branch-alias": {
+ "dev-main": "1.27-dev"
+ },
+ "thanks": {
+ "name": "symfony/polyfill",
+ "url": "https://github.com/symfony/polyfill"
+ }
+ },
+ "installation-source": "dist",
+ "autoload": {
+ "files": [
+ "bootstrap.php"
+ ],
+ "psr-4": {
+ "Symfony\\Polyfill\\Php81\\": ""
+ },
+ "classmap": [
+ "Resources/stubs"
+ ]
+ },
+ "notification-url": "https://packagist.org/downloads/",
+ "license": [
+ "MIT"
+ ],
+ "authors": [
+ {
+ "name": "Nicolas Grekas",
+ "email": "p@tchwork.com"
+ },
+ {
+ "name": "Symfony Community",
+ "homepage": "https://symfony.com/contributors"
+ }
+ ],
+ "description": "Symfony polyfill backporting some PHP 8.1+ features to lower PHP versions",
+ "homepage": "https://symfony.com",
+ "keywords": [
+ "compatibility",
+ "polyfill",
+ "portable",
+ "shim"
+ ],
+ "support": {
+ "source": "https://github.com/symfony/polyfill-php81/tree/v1.27.0"
+ },
+ "funding": [
+ {
+ "url": "https://symfony.com/sponsor",
+ "type": "custom"
+ },
+ {
+ "url": "https://github.com/fabpot",
+ "type": "github"
+ },
+ {
+ "url": "https://tidelift.com/funding/github/packagist/symfony/symfony",
+ "type": "tidelift"
+ }
+ ],
+ "install-path": "../symfony/polyfill-php81"
+ },
+ {
"name": "symfony/process",
"version": "v5.4.11",
"version_normalized": "5.4.11.0",
@@ -1943,17 +2025,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.14",
- "version_normalized": "5.4.14.0",
+ "version": "v5.4.15",
+ "version_normalized": "5.4.15.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "089e7237497fae7a9c404d0c3aeb8db3254733e4"
+ "reference": "571334ce9f687e3e6af72db4d3b2a9431e4fd9ed"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/089e7237497fae7a9c404d0c3aeb8db3254733e4",
- "reference": "089e7237497fae7a9c404d0c3aeb8db3254733e4",
+ "url": "https://api.github.com/repos/symfony/string/zipball/571334ce9f687e3e6af72db4d3b2a9431e4fd9ed",
+ "reference": "571334ce9f687e3e6af72db4d3b2a9431e4fd9ed",
"shasum": ""
},
"require": {
@@ -2012,7 +2094,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.14"
+ "source": "https://github.com/symfony/string/tree/v5.4.15"
},
"funding": [
{