summaryrefslogtreecommitdiffstats
path: root/xulrunner-2.0-system-cairo-tee.patch
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-01-31 20:54:42 +0100
committerRemi Collet <fedora@famillecollet.com>2011-01-31 20:54:42 +0100
commitf3ccf18c4f5e6b54aaf1ce4264e9287e70856ba3 (patch)
tree1c67d9217c28fecce1919735642969d90eb7cc75 /xulrunner-2.0-system-cairo-tee.patch
parent2e1287d80561ca9f73fa8c9217c4da1fb31064e8 (diff)
bluegriffon, clean spec, split sources, fix rawhide build
Diffstat (limited to 'xulrunner-2.0-system-cairo-tee.patch')
-rw-r--r--xulrunner-2.0-system-cairo-tee.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/xulrunner-2.0-system-cairo-tee.patch b/xulrunner-2.0-system-cairo-tee.patch
new file mode 100644
index 0000000..85c8447
--- /dev/null
+++ b/xulrunner-2.0-system-cairo-tee.patch
@@ -0,0 +1,29 @@
+https://bugzilla.mozilla.org/show_bug.cgi?id=623797
+
+# HG changeset patch
+# User Jory A. Pratt (anarchy@gentoo.org)
+# Parent b27366868c807e07a11741a7a2eb404ebc08e5e7
+Check to ensure system cairo has tee backend support, part 2 bug #623797
+
+diff --git a/configure.in b/configure.in
+--- a/configure.in
++++ b/configure.in
+@@ -8714,16 +8714,17 @@ if test "$MOZ_TREE_CAIRO"; then
+
+ CAIRO_FEATURES_H=gfx/cairo/cairo/src/cairo-features.h
+ mv -f $CAIRO_FEATURES_H "$CAIRO_FEATURES_H".orig 2> /dev/null
+
+ else
+ PKG_CHECK_MODULES(CAIRO, cairo >= $CAIRO_VERSION pixman-1 freetype2 fontconfig)
+ MOZ_CAIRO_CFLAGS=$CAIRO_CFLAGS
+ MOZ_CAIRO_LIBS=$CAIRO_LIBS
++ PKG_CHECK_MODULES(CAIRO_TEE, cairo-tee >= $CAIRO_VERSION)
+ if test "$MOZ_X11"; then
+ PKG_CHECK_MODULES(CAIRO_XRENDER, cairo-xlib-xrender >= $CAIRO_VERSION)
+ MOZ_CAIRO_LIBS="$MOZ_CAIRO_LIBS $XLDFLAGS $CAIRO_XRENDER_LIBS"
+ MOZ_CAIRO_CFLAGS="$MOZ_CAIRO_CFLAGS $CAIRO_XRENDER_CFLAGS"
+ fi
+ fi
+
+ AC_SUBST(MOZ_TREE_CAIRO)
+