summaryrefslogtreecommitdiffstats
path: root/atoum.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-10 12:02:37 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-10 12:02:37 +0100
commitcec817baf2d6eced464eca3e12a159f72ab3deda (patch)
treec527e59b31386a88cc4ac3f6946cb1a3500e07ce /atoum.spec
parenta2055fae466ff8e1d4142bed21e0e2212c98d79b (diff)
atoum: minor fix
Diffstat (limited to 'atoum.spec')
-rw-r--r--atoum.spec9
1 files changed, 6 insertions, 3 deletions
diff --git a/atoum.spec b/atoum.spec
index 7decc8a..afe9c56 100644
--- a/atoum.spec
+++ b/atoum.spec
@@ -121,7 +121,7 @@ sed -i bin/%{name} \
%install
-rm -rf $RPM_BUILD_ROOT
+rm -rf %{buildroot}
# create needed directories
mkdir -p %{buildroot}%{_datadir}/%{name}
mkdir -p %{buildroot}%{_bindir}
@@ -145,9 +145,12 @@ rm tests/units/classes/reports/asynchronous/xunit.php
cd tests/units
echo "date.timezone=UTC" >php.ini
export PHPRC=$(pwd)/php.ini
+
if which php70; then
- php56 runner.php --directories .
php70 runner.php --directories .
+fi
+if which php56; then
+ php56 runner.php --directories .
else
php runner.php --directories .
fi
@@ -157,7 +160,7 @@ fi
%clean
-rm -rf $RPM_BUILD_ROOT
+rm -rf %{buildroot}
%files