summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--mod_wsgi-3.3-httpd24.patch27
-rw-r--r--mod_wsgi.spec8
3 files changed, 27 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index 1e65467..91b0fd5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
-include ../common/Makefile
+include ../../common/Makefile
diff --git a/mod_wsgi-3.3-httpd24.patch b/mod_wsgi-3.3-httpd24.patch
index 1e9a8b4..f0f3a2f 100644
--- a/mod_wsgi-3.3-httpd24.patch
+++ b/mod_wsgi-3.3-httpd24.patch
@@ -84,7 +84,18 @@ diff -r 21f4dac5959a -r 8906fb52b6b2 mod_wsgi/mod_wsgi.c
{
int i;
apr_status_t rv;
-@@ -12739,8 +12756,13 @@ static int wsgi_hook_daemon_handler(conn
+@@ -11008,8 +11025,9 @@ static int wsgi_start_process(apr_pool_t
+ * shared memory segments or memory mapped files not
+ * available to code in daemon processes.
+ */
+-
++#if !AP_MODULE_MAGIC_AT_LEAST(20071023, 0)
+ ap_cleanup_scoreboard(0);
++#endif
+
+ /*
+ * Wipe out random value used in magic token so that not
+@@ -12739,8 +12757,13 @@ static int wsgi_hook_daemon_handler(conn
* file for the host.
*/
@@ -98,7 +109,7 @@ diff -r 21f4dac5959a -r 8906fb52b6b2 mod_wsgi/mod_wsgi.c
key = apr_psprintf(p, "%s|%s",
apr_table_get(r->subprocess_env,
-@@ -13259,6 +13281,18 @@ static PyObject *Auth_environ(AuthObject
+@@ -13259,6 +13282,18 @@ static PyObject *Auth_environ(AuthObject
Py_DECREF(object);
}
@@ -117,7 +128,7 @@ diff -r 21f4dac5959a -r 8906fb52b6b2 mod_wsgi/mod_wsgi.c
if (c->remote_ip) {
value = c->remote_ip;
#if PY_MAJOR_VERSION >= 3
-@@ -13269,6 +13303,7 @@ static PyObject *Auth_environ(AuthObject
+@@ -13269,6 +13304,7 @@ static PyObject *Auth_environ(AuthObject
PyDict_SetItemString(vars, "REMOTE_ADDR", object);
Py_DECREF(object);
}
@@ -125,7 +136,7 @@ diff -r 21f4dac5959a -r 8906fb52b6b2 mod_wsgi/mod_wsgi.c
#if PY_MAJOR_VERSION >= 3
value = ap_document_root(r);
-@@ -13292,6 +13327,17 @@ static PyObject *Auth_environ(AuthObject
+@@ -13292,6 +13328,17 @@ static PyObject *Auth_environ(AuthObject
Py_DECREF(object);
}
@@ -143,7 +154,7 @@ diff -r 21f4dac5959a -r 8906fb52b6b2 mod_wsgi/mod_wsgi.c
rport = c->remote_addr->port;
value = apr_itoa(r->pool, rport);
#if PY_MAJOR_VERSION >= 3
-@@ -13301,6 +13347,7 @@ static PyObject *Auth_environ(AuthObject
+@@ -13301,6 +13348,7 @@ static PyObject *Auth_environ(AuthObject
#endif
PyDict_SetItemString(vars, "REMOTE_PORT", object);
Py_DECREF(object);
@@ -151,7 +162,7 @@ diff -r 21f4dac5959a -r 8906fb52b6b2 mod_wsgi/mod_wsgi.c
value = r->protocol;
#if PY_MAJOR_VERSION >= 3
-@@ -14391,8 +14438,13 @@ static int wsgi_hook_access_checker(requ
+@@ -14391,8 +14439,13 @@ static int wsgi_hook_access_checker(requ
host = ap_get_remote_host(r->connection, r->per_dir_config,
REMOTE_HOST, NULL);
@@ -165,7 +176,7 @@ diff -r 21f4dac5959a -r 8906fb52b6b2 mod_wsgi/mod_wsgi.c
allow = wsgi_allow_access(r, config, host);
-@@ -14645,8 +14697,14 @@ static int wsgi_hook_check_user_id(reque
+@@ -14645,8 +14698,14 @@ static int wsgi_hook_check_user_id(reque
#if defined(MOD_WSGI_WITH_AUTHZ_PROVIDER)
@@ -180,7 +191,7 @@ diff -r 21f4dac5959a -r 8906fb52b6b2 mod_wsgi/mod_wsgi.c
{
WSGIRequestConfig *config;
-@@ -14695,6 +14753,9 @@ static authz_status wsgi_check_authoriza
+@@ -14695,6 +14754,9 @@ static authz_status wsgi_check_authoriza
static const authz_provider wsgi_authz_provider =
{
&wsgi_check_authorization,
diff --git a/mod_wsgi.spec b/mod_wsgi.spec
index 7aa8229..6c217df 100644
--- a/mod_wsgi.spec
+++ b/mod_wsgi.spec
@@ -6,7 +6,7 @@
Name: mod_wsgi
Version: 3.3
-Release: 5%{?dist}.1
+Release: 6%{?dist}
Summary: A WSGI interface for Python web applications in Apache
Group: System Environment/Libraries
@@ -62,6 +62,12 @@ rm -rf $RPM_BUILD_ROOT
%changelog
+* Wed Jun 13 2012 Remi Collet <RPMS@FamilleCollet.com> - 3.3-6
+- sync with rawhide, rebuild for remi repo
+
+* Wed Jun 13 2012 Joe Orton <jorton@redhat.com> - 3.3-6
+- add possible fix for daemon mode crash (#831701)
+
* Thu Apr 19 2012 Remi Collet <RPMS@FamilleCollet.com> - 3.3-5.1
- sync with rawhide, rebuild for remi repo