summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--mod_bw-httpd24.patch49
-rw-r--r--mod_bw.spec8
3 files changed, 27 insertions, 32 deletions
diff --git a/Makefile b/Makefile
index 1e65467..91b0fd5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
-include ../common/Makefile
+include ../../common/Makefile
diff --git a/mod_bw-httpd24.patch b/mod_bw-httpd24.patch
index d49d310..0d9e8c3 100644
--- a/mod_bw-httpd24.patch
+++ b/mod_bw-httpd24.patch
@@ -1,42 +1,31 @@
-diff -up mod_bw/mod_bw.c.httpd24 mod_bw/mod_bw.c
---- mod_bw/mod_bw.c.httpd24 2012-04-10 11:57:06.092958430 +0200
-+++ mod_bw/mod_bw.c 2012-04-10 11:59:51.832838191 +0200
-@@ -519,10 +519,8 @@ static long get_bw_rate(request_rec * r,
+diff --git a/mod_bw.c b/mod_bw.c
+index a49caf8..8b75973 100644
+--- a/mod_bw.c
++++ b/mod_bw.c
+@@ -519,7 +519,7 @@ static long get_bw_rate(request_rec * r, apr_array_header_t * a)
return e[i].rate;
case T_IP:
- if (apr_ipsubnet_test(e[i].x.ip, r->connection->remote_addr)) {
-- return e[i].rate;
-- }
-- break;
-+ return e[i].rate;
-+
- case T_HOST:
- if (!gothost) {
- int remotehost_is_ip;
-@@ -608,10 +606,8 @@ static int get_maxconn(request_rec * r,
++ if (apr_ipsubnet_test(e[i].x.ip, r->useragent_addr)) {
+ return e[i].rate;
+ }
+ break;
+@@ -608,7 +608,7 @@ static int get_maxconn(request_rec * r, apr_array_header_t * a)
return e[i].max;
case T_IP:
- if (apr_ipsubnet_test(e[i].x.ip, r->connection->remote_addr)) {
-- return e[i].max;
-- }
-- break;
-+ return e[i].max;
-+
- case T_HOST:
- if (!gothost) {
- int remotehost_is_ip;
-@@ -659,10 +655,8 @@ static int get_sid(request_rec * r, apr_
++ if (apr_ipsubnet_test(e[i].x.ip, r->useragent_addr)) {
+ return e[i].max;
+ }
+ break;
+@@ -659,7 +659,7 @@ static int get_sid(request_rec * r, apr_array_header_t * a)
return e[i].sid;
case T_IP:
- if (apr_ipsubnet_test(e[i].x.ip, r->connection->remote_addr)) {
-- return e[i].sid;
-- }
-- break;
-+ return e[i].sid;
-+
- case T_HOST:
- if (!gothost) {
- int remotehost_is_ip;
++ if (apr_ipsubnet_test(e[i].x.ip, r->useragent_addr)) {
+ return e[i].sid;
+ }
+ break;
diff --git a/mod_bw.spec b/mod_bw.spec
index fb9cb1d..d8faa3f 100644
--- a/mod_bw.spec
+++ b/mod_bw.spec
@@ -3,7 +3,7 @@
Name: mod_bw
Version: 0.92
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: Bandwidth Limiter For Apache
Group: System Environment/Daemons
@@ -56,6 +56,12 @@ rm -rf $RPM_BUILD_ROOT
%changelog
+* Thu Aug 23 2012 Remi Collet <RPMS@FamilleCollet.com> - 0.92-3
+- sync patch with rawhide (but keep version 0.92)
+
+* Mon Jul 23 2012 Jan Kaluza <jkaluza@redhat.com> - 0.8-10
+- Use proper httpd-2.4 patch
+
* Wed Apr 18 2012 Remi Collet <RPMS@FamilleCollet.com> - 0.92-2
- sync patch with rawhide (but keep version 0.92)