summaryrefslogtreecommitdiffstats
path: root/httpd-2.4.4-export.patch
diff options
context:
space:
mode:
Diffstat (limited to 'httpd-2.4.4-export.patch')
-rw-r--r--httpd-2.4.4-export.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/httpd-2.4.4-export.patch b/httpd-2.4.4-export.patch
new file mode 100644
index 0000000..eb670c6
--- /dev/null
+++ b/httpd-2.4.4-export.patch
@@ -0,0 +1,20 @@
+
+There is no need to "suck in" the apr/apr-util symbols when using
+a shared libapr{,util}, it just bloats the symbol table; so don't.
+
+Upstream-HEAD: needed
+Upstream-2.0: omit
+Upstream-Status: EXPORT_DIRS change is conditional on using shared apr
+
+--- httpd-2.4.4/server/Makefile.in.export
++++ httpd-2.4.4/server/Makefile.in
+@@ -57,9 +57,6 @@ export_files:
+ ( for dir in $(EXPORT_DIRS); do \
+ ls $$dir/*.h ; \
+ done; \
+- for dir in $(EXPORT_DIRS_APR); do \
+- ls $$dir/ap[ru].h $$dir/ap[ru]_*.h 2>/dev/null; \
+- done; \
+ ) | sed -e s,//,/,g | sort -u > $@
+
+ exports.c: export_files