summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-04-20 17:32:27 +0200
committerRemi Collet <fedora@famillecollet.com>2012-04-20 17:32:27 +0200
commit14184dc422b158575b35881d4f46121aa1fb7681 (patch)
treeb6cbafcdcbab0d682588b50700728fd4f197e32f
parentb4c6f6bd66de282d73b9f360d73b6125473ab586 (diff)
httpd-2.4.2-3: sync with rawhide
-rw-r--r--httpd-2.4.2-restart.patch29
-rw-r--r--httpd.service3
-rw-r--r--httpd.spec17
-rw-r--r--ssl.conf3
4 files changed, 47 insertions, 5 deletions
diff --git a/httpd-2.4.2-restart.patch b/httpd-2.4.2-restart.patch
new file mode 100644
index 0000000..07ff452
--- /dev/null
+++ b/httpd-2.4.2-restart.patch
@@ -0,0 +1,29 @@
+
+https://bugzilla.redhat.com/show_bug.cgi?id=814645
+
+--- httpd-2.4.2/server/main.c.restart
++++ httpd-2.4.2/server/main.c
+@@ -671,6 +671,11 @@ int main(int argc, const char * const ar
+ }
+ }
+
++ /* If our config failed, deal with that here. */
++ if (rv != OK) {
++ destroy_and_exit_process(process, 1);
++ }
++
+ signal_server = APR_RETRIEVE_OPTIONAL_FN(ap_signal_server);
+ if (signal_server) {
+ int exit_status;
+@@ -680,11 +685,6 @@ int main(int argc, const char * const ar
+ }
+ }
+
+- /* If our config failed, deal with that here. */
+- if (rv != OK) {
+- destroy_and_exit_process(process, 1);
+- }
+-
+ apr_pool_clear(plog);
+
+ if ( ap_run_open_logs(pconf, plog, ptemp, ap_server_conf) != OK) {
diff --git a/httpd.service b/httpd.service
index fda59d2..c1172b4 100644
--- a/httpd.service
+++ b/httpd.service
@@ -7,8 +7,7 @@ Type=forking
PIDFile=/var/run/httpd/httpd.pid
EnvironmentFile=/etc/sysconfig/httpd
ExecStart=/usr/sbin/httpd $OPTIONS
-ExecReload=/usr/sbin/httpd $OPTIONS -t
-ExecReload=/usr/sbin/httpd -HUP $MAINPID
+ExecReload=/usr/sbin/httpd $OPTIONS -k graceful
ExecStop=/usr/sbin/httpd $OPTIONS -k graceful-stop
PrivateTmp=true
diff --git a/httpd.spec b/httpd.spec
index 38bce5e..c951af2 100644
--- a/httpd.spec
+++ b/httpd.spec
@@ -8,7 +8,7 @@
Summary: Apache HTTP Server
Name: httpd
Version: 2.4.2
-Release: 1%{?dist}
+Release: 3%{?dist}
URL: http://httpd.apache.org/
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
Source1: index.html
@@ -45,6 +45,8 @@ Patch23: httpd-2.4.1-export.patch
Patch24: httpd-2.4.1-corelimit.patch
Patch25: httpd-2.4.1-selinux.patch
Patch26: httpd-2.4.1-suenable.patch
+# Bug fixes
+Patch40: httpd-2.4.2-restart.patch
License: ASL 2.0
Group: System Environment/Daemons
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
@@ -152,6 +154,8 @@ authentication to the Apache HTTP Server.
%patch25 -p1 -b .selinux
%patch26 -p1 -b .suenable
+%patch40 -p1 -b .restart
+
# Patch in vendor/release string
sed "s/@RELEASE@/%{vstring}/" < %{PATCH20} | patch -p1
@@ -554,6 +558,17 @@ rm -rf $RPM_BUILD_ROOT
%{_sysconfdir}/rpm/macros.httpd
%changelog
+* Fri Apr 20 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.4.2-3
+- sync with rawhide, rebuild for remi repo
+
+* Fri Apr 20 2012 Joe Orton <jorton@redhat.com> - 2.4.2-3
+- really fix restart
+
+* Fri Apr 20 2012 Joe Orton <jorton@redhat.com> - 2.4.2-2
+- tweak default ssl.conf
+- fix restart handling (#814645)
+- use graceful restart by default
+
* Wed Apr 18 2012 Remi Collet <RPMS@FamilleCollet.com> - 2.4.2-1
- update to 2.4.2, rebuild for remi repo
diff --git a/ssl.conf b/ssl.conf
index 5791eaf..c6b89e3 100644
--- a/ssl.conf
+++ b/ssl.conf
@@ -20,8 +20,7 @@ SSLPassPhraseDialog exec:/usr/libexec/httpd-ssl-pass-dialog
# Inter-Process Session Cache:
# Configure the SSL Session Cache: First the mechanism
# to use and second the expiring timeout (in seconds).
-#SSLSessionCache dc:UNIX:/var/cache/mod_ssl/distcache
-SSLSessionCache shmcb:/var/cache/mod_ssl/scache(512000)
+SSLSessionCache shmcb:/var/run/httpd/sslcache(512000)
SSLSessionCacheTimeout 300
# Pseudo Random Number Generator (PRNG):