summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-25 18:09:37 +0200
committerRemi Collet <remi@remirepo.net>2021-06-25 18:09:37 +0200
commite75775399a9c32e29140e4696a447ac23cfec68a (patch)
tree87d996c00973da06e6c13d4e874212217a447031
parentdaa82694c679001032d494aa962b1b5e6d54e664 (diff)
update to version 7.1.0 patch level 2
drop patch merged upstream
-rw-r--r--3858.patch31
-rw-r--r--ImageMagick7.spec11
2 files changed, 6 insertions, 36 deletions
diff --git a/3858.patch b/3858.patch
deleted file mode 100644
index 228c6d8..0000000
--- a/3858.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From f9ca2521de918c342618ee4dc0a01b70c92c024e Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 23 Jun 2021 16:42:15 +0200
-Subject: [PATCH] fix memory corruption in ConcatenateStringInfo
-
----
- MagickCore/string.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/MagickCore/string.c b/MagickCore/string.c
-index dccef76a27..691d55034d 100644
---- a/MagickCore/string.c
-+++ b/MagickCore/string.c
-@@ -530,7 +530,6 @@ MagickExport void ConcatenateStringInfo(StringInfo *string_info,
- length+=source->length;
- if (~length < MagickPathExtent)
- ThrowFatalException(ResourceLimitFatalError,"MemoryAllocationFailed");
-- string_info->length=length;
- if (string_info->datum == (unsigned char *) NULL)
- string_info->datum=(unsigned char *) AcquireQuantumMemory(length+
- MagickPathExtent,sizeof(*string_info->datum));
-@@ -540,7 +539,8 @@ MagickExport void ConcatenateStringInfo(StringInfo *string_info,
- sizeof(*string_info->datum));
- if (string_info->datum == (unsigned char *) NULL)
- ThrowFatalException(ResourceLimitFatalError,"MemoryAllocationFailed");
-- (void) memcpy(string_info->datum+length,source->datum,source->length);
-+ (void) memcpy(string_info->datum+string_info->length,source->datum,source->length);
-+ string_info->length=length;
- }
-
- /*
diff --git a/ImageMagick7.spec b/ImageMagick7.spec
index 96abfa8..f9b2d3b 100644
--- a/ImageMagick7.spec
+++ b/ImageMagick7.spec
@@ -9,7 +9,7 @@
# Please preserve changelog entries
#
%global VER 7.1.0
-%global Patchlevel 1
+%global Patchlevel 2
%global incsuffixe -7
%global libsuffixe -7.Q16HDRI
%bcond_without tests
@@ -43,7 +43,7 @@ Name: %{libname}
Name: %{libname}7
%endif
Version: %{VER}.%{Patchlevel}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: An X application for displaying and manipulating images
License: ImageMagick
Url: http://www.imagemagick.org/
@@ -51,8 +51,6 @@ Url: http://www.imagemagick.org/
#Source0: ftp://ftp.imagemagick.org/pub/ImageMagick/releases/ImageMagick-%%{VER}-%%{Patchlevel}.tar.xz
Source0: https://www.imagemagick.org/download/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
-Patch0: 3858.patch
-
BuildRequires: gcc
BuildRequires: gcc-c++
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -350,7 +348,6 @@ however.
%prep
%setup -q -n %{libname}-%{VER}-%{Patchlevel}
-%patch0 -p1
# for %%doc
mkdir Magick++/examples
@@ -601,6 +598,10 @@ fi
%changelog
+* Fri Jun 25 2021 Remi Collet <remi@remirepo.net> - 7.1.0-2-1
+- update to version 7.1.0 patch level 2
+- drop patch merged upstream
+
* Wed Jun 23 2021 Remi Collet <remi@remirepo.net> - 7.1.0-1-2
- fix memory corruption using fix from
https://github.com/ImageMagick/ImageMagick/pull/3858