summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-04 09:39:55 +0100
committerRemi Collet <remi@remirepo.net>2017-12-04 09:39:55 +0100
commitacef2801c076bed06fa3cf8ba07ff896b54f5717 (patch)
tree1e0247fc2e56f4398267bc89f719cc1a88167b9f
parent1e4573bb8f728b09c4072c9be25d167d60dbf392 (diff)
update to version 7.0.7 patch level 13
-rw-r--r--1db0ae830c0e71218fb3b1916941901802b8c813.patch43
-rw-r--r--8558aa4d14275251e0154e837977c16b7895e124.patch49
-rw-r--r--ImageMagick7.spec12
3 files changed, 5 insertions, 99 deletions
diff --git a/1db0ae830c0e71218fb3b1916941901802b8c813.patch b/1db0ae830c0e71218fb3b1916941901802b8c813.patch
deleted file mode 100644
index 48b5c6c..0000000
--- a/1db0ae830c0e71218fb3b1916941901802b8c813.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 1db0ae830c0e71218fb3b1916941901802b8c813 Mon Sep 17 00:00:00 2001
-From: Cristy <urban-warrior@imagemagick.org>
-Date: Thu, 30 Nov 2017 09:02:22 -0500
-Subject: [PATCH] https://github.com/ImageMagick/ImageMagick/issues/888
-
----
- coders/dng.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/coders/dng.c b/coders/dng.c
-index 98bba92ea7..2ee9658962 100644
---- a/coders/dng.c
-+++ b/coders/dng.c
-@@ -169,11 +169,11 @@ static void SetDNGProperties(Image *image,const libraw_data_t *raw_info,
- (void) SetImageProperty(image,"dng:make",raw_info->idata.make,exception);
- (void) SetImageProperty(image,"dng:camera.model.name",raw_info->idata.model,
- exception);
-- (void) SetImageProperty(image,"dng:software",raw_info->idata.software,
-- exception);
- (void) FormatMagickTime(raw_info->other.timestamp,MagickPathExtent,timestamp);
- (void) SetImageProperty(image,"dng:create.date",timestamp,exception);
- #if LIBRAW_COMPILE_CHECK_VERSION_NOTLESS(0,18)
-+ (void) SetImageProperty(image,"dng:software",raw_info->idata.software,
-+ exception);
- if (*raw_info->shootinginfo.BodySerial != '\0')
- (void) SetImageProperty(image,"dng:serial.number",
- raw_info->shootinginfo.BodySerial,exception);
-@@ -181,7 +181,6 @@ static void SetDNGProperties(Image *image,const libraw_data_t *raw_info,
- raw_info->other.FlashEC);
- (void) SetImageProperty(image,"dng:flash.exposure.compensation",property,
- exception);
--#endif
- (void) FormatLocaleString(property,MagickPathExtent,"1/%0.1f",
- 1.0/raw_info->other.shutter);
- (void) SetImageProperty(image,"dng:exposure.time",property,exception);
-@@ -230,6 +229,7 @@ static void SetDNGProperties(Image *image,const libraw_data_t *raw_info,
- raw_info->lens.FocalLengthIn35mmFormat);
- (void) SetImageProperty(image,"dng:focal.length.in.35mm.format",property,
- exception);
-+#endif
- }
- #endif
-
diff --git a/8558aa4d14275251e0154e837977c16b7895e124.patch b/8558aa4d14275251e0154e837977c16b7895e124.patch
deleted file mode 100644
index 9774582..0000000
--- a/8558aa4d14275251e0154e837977c16b7895e124.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 8558aa4d14275251e0154e837977c16b7895e124 Mon Sep 17 00:00:00 2001
-From: Cristy <urban-warrior@imagemagick.org>
-Date: Thu, 30 Nov 2017 09:21:15 -0500
-Subject: [PATCH] https://github.com/ImageMagick/ImageMagick/issues/888
-
----
- coders/dng.c | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/coders/dng.c b/coders/dng.c
-index 2ee9658962..b0d4ffe79b 100644
---- a/coders/dng.c
-+++ b/coders/dng.c
-@@ -171,6 +171,9 @@ static void SetDNGProperties(Image *image,const libraw_data_t *raw_info,
- exception);
- (void) FormatMagickTime(raw_info->other.timestamp,MagickPathExtent,timestamp);
- (void) SetImageProperty(image,"dng:create.date",timestamp,exception);
-+ (void) FormatLocaleString(property,MagickPathExtent,"%0.1f",
-+ raw_info->other.iso_speed);
-+ (void) SetImageProperty(image,"dng:iso.setting",property,exception);
- #if LIBRAW_COMPILE_CHECK_VERSION_NOTLESS(0,18)
- (void) SetImageProperty(image,"dng:software",raw_info->idata.software,
- exception);
-@@ -187,9 +190,6 @@ static void SetDNGProperties(Image *image,const libraw_data_t *raw_info,
- (void) FormatLocaleString(property,MagickPathExtent,"%0.1f",
- raw_info->other.aperture);
- (void) SetImageProperty(image,"dng:f.number",property,exception);
-- (void) FormatLocaleString(property,MagickPathExtent,"%0.1f",
-- raw_info->other.iso_speed);
-- (void) SetImageProperty(image,"dng:iso.setting",property,exception);
- (void) FormatLocaleString(property,MagickPathExtent,"%0.1f",
- raw_info->lens.EXIF_MaxAp);
- (void) SetImageProperty(image,"dng:max.aperture.value",property,exception);
-@@ -400,6 +400,7 @@ static Image *ReadDNGImage(const ImageInfo *image_info,ExceptionInfo *exception)
- profile=DestroyStringInfo(profile);
- }
- }
-+#if LIBRAW_COMPILE_CHECK_VERSION_NOTLESS(0,18)
- if (raw_info->idata.xmpdata)
- {
- profile=BlobToStringInfo(raw_info->idata.xmpdata,
-@@ -410,6 +411,7 @@ static Image *ReadDNGImage(const ImageInfo *image_info,ExceptionInfo *exception)
- profile=DestroyStringInfo(profile);
- }
- }
-+#endif
- SetDNGProperties(image,raw_info,exception);
- libraw_close(raw_info);
- return(image);
diff --git a/ImageMagick7.spec b/ImageMagick7.spec
index 014ca02..0d0b05b 100644
--- a/ImageMagick7.spec
+++ b/ImageMagick7.spec
@@ -9,7 +9,7 @@
# Please preserve changelog entries
#
%global VER 7.0.7
-%global Patchlevel 12
+%global Patchlevel 13
%global incsuffixe -7
%global libsuffixe -7.Q16HDRI
%global with_tests 0%{!?_without_tests:1}
@@ -61,16 +61,13 @@ Name: %{libname}
Name: %{libname}7
%endif
Version: %{VER}.%{Patchlevel}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: An X application for displaying and manipulating images
Group: Applications/Multimedia
License: ImageMagick
Url: http://www.imagemagick.org/
Source0: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
-Patch0: https://github.com/ImageMagick/ImageMagick/commit/1db0ae830c0e71218fb3b1916941901802b8c813.patch
-Patch1: https://github.com/ImageMagick/ImageMagick/commit/8558aa4d14275251e0154e837977c16b7895e124.patch
-
BuildRequires: bzip2-devel, freetype-devel, libjpeg-devel, libpng-devel
BuildRequires: libtiff-devel, giflib-devel, zlib-devel
%if 0%{?fedora} >= 7 || 0%{?rhel} >= 6
@@ -312,8 +309,6 @@ however.
%prep
%setup -q -n %{libname}-%{VER}-%{Patchlevel}
-%patch0 -p1 -b.upstream
-%patch1 -p1 -b.upstream
# for %%doc
mkdir Magick++/examples
@@ -547,6 +542,9 @@ fi
%changelog
+* Mon Dec 4 2017 Remi Collet <remi@remirepo.net> - 7.0.7.13-1
+- update to version 7.0.7 patch level 13
+
* Thu Nov 30 2017 Remi Collet <remi@remirepo.net> - 7.0.7.12-2
- add upstream patch for #888