summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-31 08:03:50 +0100
committerRemi Collet <remi@php.net>2022-01-31 08:03:50 +0100
commit6b4d8314919fabe70c33f30b80f14e6b6af394cd (patch)
tree294daceaff64b6bcbb3162e75176722c152f88e5
parentb8a0f403cb3e7c38c7192317a5c954dcce8be570 (diff)
update to version 7.1.0 patch level 22
-rw-r--r--ImageMagick7.spec13
-rw-r--r--heic-el7.patch43
2 files changed, 7 insertions, 49 deletions
diff --git a/ImageMagick7.spec b/ImageMagick7.spec
index 99a7161..9999623 100644
--- a/ImageMagick7.spec
+++ b/ImageMagick7.spec
@@ -9,11 +9,14 @@
# Please preserve changelog entries
#
%global VER 7.1.0
-%global Patchlevel 20
+%global Patchlevel 22
%global incsuffixe -7
%global libsuffixe -7.Q16HDRI
%bcond_without tests
+# Disable automatic .la file removal
+%global __brp_remove_la_files %nil
+
%global with_djvu 1
%global with_webp 1
%global with_jp2 1
@@ -51,8 +54,6 @@ Url: http://www.imagemagick.org/
#Source0: ftp://ftp.imagemagick.org/pub/ImageMagick/releases/ImageMagick-%%{VER}-%%{Patchlevel}.tar.xz
Source0: https://www.imagemagick.org/download/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
-Patch0: heic-el7.patch
-
BuildRequires: gcc
BuildRequires: gcc-c++
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -360,9 +361,6 @@ however.
%prep
%setup -q -n %{libname}-%{VER}-%{Patchlevel}
-%if 0%{?rhel} == 7
-%patch0 -p1 -R
-%endif
# for %%doc
mkdir Magick++/examples
@@ -613,6 +611,9 @@ fi
%changelog
+* Mon Jan 31 2022 Remi Collet <remi@remirepo.net> - 7.1.0.22-1
+- update to version 7.1.0 patch level 22
+
* Mon Jan 24 2022 Remi Collet <remi@remirepo.net> - 7.1.0.20-1
- update to version 7.1.0 patch level 20
- add weak dependencies on default fonts
diff --git a/heic-el7.patch b/heic-el7.patch
deleted file mode 100644
index 730bf81..0000000
--- a/heic-el7.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 1b89b2b729238758a98c596c256a1d5753fa5670 Mon Sep 17 00:00:00 2001
-From: Cristy <urban-warrior@imagemagick.org>
-Date: Wed, 19 Jan 2022 18:40:35 -0500
-Subject: [PATCH] AVIF is supported by the HEIC coder
-
----
- coders/heic.c | 18 +++++++-----------
- coders/miff.c | 4 ++--
- coders/mpc.c | 7 +++----
- 3 files changed, 12 insertions(+), 17 deletions(-)
-
-diff --git a/coders/heic.c b/coders/heic.c
-index c17ec7848c..29c5fbc0a9 100644
---- a/coders/heic.c
-+++ b/coders/heic.c
-@@ -586,20 +586,16 @@ static Image *ReadHEICImage(const ImageInfo *image_info,
- */
- static MagickBooleanType IsHEIC(const unsigned char *magick,const size_t length)
- {
-+#if defined(MAGICKCORE_HEIC_DELEGATE)
-+ enum heif_filetype_result
-+ heif_filetype;
-+
- if (length < 12)
- return(MagickFalse);
-- if (LocaleNCompare((const char *) magick+4,"ftyp",4) != 0)
-- return(MagickFalse);
-- if (LocaleNCompare((const char *) magick+8,"avif",4) == 0)
-- return(MagickTrue);
-- if (LocaleNCompare((const char *) magick+8,"heic",4) == 0)
-- return(MagickTrue);
-- if (LocaleNCompare((const char *) magick+8,"heix",4) == 0)
-- return(MagickTrue);
-- if (LocaleNCompare((const char *) magick+8,"mif1",4) == 0)
-- return(MagickTrue);
-- if (LocaleNCompare((const char *) magick+8,"msf1",4) == 0)
-+ heif_filetype=heif_check_filetype(magick,(int) length);
-+ if (heif_filetype == heif_filetype_yes_supported)
- return(MagickTrue);
-+#endif
- return(MagickFalse);
- }
-