summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-28 11:45:24 +0200
committerRemi Collet <remi@php.net>2022-03-28 11:45:24 +0200
commit3b3da29d698acc57690dd4859e4aa6f018698339 (patch)
treea1885cc5d796e70bb406ce1a4c86e3fbcd4a858d
parent8144cb1df90b1319f68de8879e476fd6189f6b86 (diff)
update to version 7.1.0 patch level 29
-rw-r--r--ImageMagick7.spec10
-rw-r--r--heif.patch64
2 files changed, 5 insertions, 69 deletions
diff --git a/ImageMagick7.spec b/ImageMagick7.spec
index 517e0ad..c7f30b2 100644
--- a/ImageMagick7.spec
+++ b/ImageMagick7.spec
@@ -9,7 +9,7 @@
# Please preserve changelog entries
#
%global VER 7.1.0
-%global Patchlevel 28
+%global Patchlevel 29
%global incsuffixe -7
%global libsuffixe -7.Q16HDRI
%bcond_without tests
@@ -46,7 +46,7 @@ Name: %{libname}
Name: %{libname}7
%endif
Version: %{VER}.%{Patchlevel}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: An X application for displaying and manipulating images
License: ImageMagick
Url: http://www.imagemagick.org/
@@ -54,8 +54,6 @@ Url: http://www.imagemagick.org/
#Source0: ftp://ftp.imagemagick.org/pub/ImageMagick/releases/ImageMagick-%%{VER}-%%{Patchlevel}.tar.xz
Source0: https://www.imagemagick.org/download/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
-Patch0: heif.patch
-
BuildRequires: gcc
BuildRequires: gcc-c++
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -363,7 +361,6 @@ however.
%prep
%setup -q -n %{libname}-%{VER}-%{Patchlevel}
-%patch0 -p1
# for %%doc
mkdir Magick++/examples
@@ -614,6 +611,9 @@ fi
%changelog
+* Mon Mar 28 2022 Remi Collet <remi@remirepo.net> - 7.1.0.29-1
+- update to version 7.1.0 patch level 29
+
* Tue Mar 22 2022 Remi Collet <remi@remirepo.net> - 7.1.0.28-2
- build using upstream patch
diff --git a/heif.patch b/heif.patch
deleted file mode 100644
index 086f28c..0000000
--- a/heif.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From ffc2aaae543dcd60c6cc7e5a426f66dbc51df560 Mon Sep 17 00:00:00 2001
-From: Cristy <urban-warrior@imagemagick.org>
-Date: Mon, 21 Mar 2022 21:53:40 -0400
-Subject: [PATCH] https://github.com/ImageMagick/ImageMagick/issues/4972
-
----
- coders/heic.c | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
-diff --git a/coders/heic.c b/coders/heic.c
-index 96b4e218fc..846f5c7575 100644
---- a/coders/heic.c
-+++ b/coders/heic.c
-@@ -318,13 +318,17 @@ static MagickBooleanType ReadHEICImageHandle(const ImageInfo *image_info,
- if (preserve_orientation == MagickTrue)
- decode_options->ignore_transformations=1;
- chroma=heif_chroma_interleaved_RGB;
-+#if LIBHEIF_NUMERIC_VERSION > 0x01040000
- if (image->depth > 8)
- chroma=heif_chroma_interleaved_RRGGBB_LE;
-+#endif
- if (image->alpha_trait != UndefinedPixelTrait)
- {
- chroma=heif_chroma_interleaved_RGBA;
-+#if LIBHEIF_NUMERIC_VERSION > 0x01040000
- if (image->depth > 8)
- chroma=heif_chroma_interleaved_RRGGBBAA_LE;
-+#endif
- }
- error=heif_decode_image(image_handle,&heif_image,heif_colorspace_RGB,chroma,
- decode_options);
-@@ -1225,16 +1229,20 @@ static MagickBooleanType WriteHEICImage(const ImageInfo *image_info,
- status=TransformImageColorspace(image,sRGBColorspace,exception);
- colorspace=heif_colorspace_RGB;
- chroma=heif_chroma_interleaved_RGBA;
-+#if LIBHEIF_NUMERIC_VERSION > 0x01040000
- if (image->depth > 8)
- chroma=heif_chroma_interleaved_RRGGBBAA_LE;
-+#endif
- }
- else
- if (IssRGBCompatibleColorspace(image->colorspace) != MagickFalse)
- {
- colorspace=heif_colorspace_RGB;
- chroma=heif_chroma_interleaved_RGB;
-+#if LIBHEIF_NUMERIC_VERSION > 0x01040000
- if (image->depth > 8)
- chroma=heif_chroma_interleaved_RRGGBB_LE;
-+#endif
- if (GetPixelChannels(image) == 1)
- {
- colorspace=heif_colorspace_monochrome;
-@@ -1265,9 +1273,11 @@ static MagickBooleanType WriteHEICImage(const ImageInfo *image_info,
- if (colorspace == heif_colorspace_YCbCr)
- status=WriteHEICImageYCbCr(image,heif_image,exception);
- else
-+#if LIBHEIF_NUMERIC_VERSION > 0x01040000
- if (image->depth > 8)
- status=WriteHEICImageRRGGBBAA(image,heif_image,exception);
- else
-+#endif
- status=WriteHEICImageRGBA(image,heif_image,exception);
- if (status == MagickFalse)
- break;