From 57ef8b9c95af7540d2104595a4c5662aaa4950ea Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Thu, 20 Aug 2020 13:24:59 +0200
Subject: Core:   Fix #79877 getimagesize function silently truncates after a
 null byte Phar:   Fix #79797 use of freed hash key in the phar_parse_zipfile
 function   CVE-2020-7068

---
 php.spec | 26 ++++++++++++++++++++++++--
 1 file changed, 24 insertions(+), 2 deletions(-)

(limited to 'php.spec')

diff --git a/php.spec b/php.spec
index 53ad131..6e3c4d4 100644
--- a/php.spec
+++ b/php.spec
@@ -62,8 +62,13 @@
 %global oraclever 18.3
 %endif
 %global oraclelib 18.1
+
+%else
+%ifarch x86_64
+%global oraclever 19.8
 %else
 %global oraclever 19.6
+%endif
 %global oraclelib 19.1
 %endif
 
@@ -141,7 +146,7 @@
 Summary: PHP scripting language for creating dynamic web sites
 Name: %{?scl_prefix}php
 Version: %{upver}%{?rcver:~%{rcver}}
-Release: 21%{?dist}
+Release: 22%{?dist}
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
 # TSRM is licensed under BSD
@@ -249,6 +254,8 @@ Patch240: php-bug79330.patch
 Patch241: php-bug79465.patch
 Patch242: php-bug78875.patch
 Patch243: php-bug78876.patch
+Patch244: php-bug79797.patch
+Patch245: php-bug79877.patch
 
 # Fixes for tests (300+)
 # Factory is droped from system tzdata
@@ -967,7 +974,7 @@ support for JavaScript Object Notation (JSON) to PHP.
 %if 0%{?rhel}
 %patch9 -p1 -b .curltls
 %endif
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 29 || 0%{?rhel} >= 7
 %patch10 -p1 -b .icu62
 %endif
 
@@ -1035,6 +1042,8 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
 %patch241 -p1 -b .bug79465
 %patch242 -p1 -b .bug78875
 %patch243 -p1 -b .bug78876
+%patch244 -p1 -b .bug79797
+%patch245 -p1 -b .bug79877
 : ---------------------------
 #exit 1
 
@@ -1186,6 +1195,12 @@ exit 1
 
 
 %build
+# This package fails to build with LTO due to undefined symbols.  LTO
+# was disabled in OpenSuSE as well, but with no real explanation why
+# beyond the undefined symbols.  It really shold be investigated further.
+# Disable LTO
+%define _lto_cflags %{nil}
+
 # aclocal workaround - to be improved
 cat $(aclocal --print-ac-dir)/{libtool,ltoptions,ltsugar,ltversion,lt~obsolete}.m4 >>aclocal.m4
 
@@ -1987,6 +2002,13 @@ EOF
 
 
 %changelog
+* Tue Aug  4 2020 Remi Collet <remi@remirepo.net> - 7.0.33-22
+- Core:
+  Fix #79877 getimagesize function silently truncates after a null byte
+- Phar:
+  Fix #79797 use of freed hash key in the phar_parse_zipfile function
+  CVE-2020-7068
+
 * Tue May 12 2020 Remi Collet <remi@remirepo.net> - 7.0.33-21
 - Core:
   Fix #78875 Long filenames cause OOM and temp files are not cleaned
-- 
cgit