summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-bash-completion2
-rw-r--r--composer.spec7
-rw-r--r--installed.json77
3 files changed, 45 insertions, 41 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index f31bc3a..4ca8915 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.8.8")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.8.9")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.spec b/composer.spec
index 44e65e1..e30f0a4 100644
--- a/composer.spec
+++ b/composer.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 85ff84d6c5260ba21740a7c5c9a111890805d6e7
+%global gh_commit b4e6bff2db7ce756ddb77ecee958a0f41f42bd9d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -19,7 +19,7 @@
%global api_version 2.6.0
%global run_version 2.2.2
-%global upstream_version 2.8.8
+%global upstream_version 2.8.9
#global upstream_prever RC1
#global upstream_lower rc1
@@ -208,6 +208,9 @@ php -r '
%changelog
+* Tue May 13 2025 Remi Collet <remi@remirepo.net> - 2.8.9-1
+- update to 2.8.9
+
* Sat Apr 5 2025 Remi Collet <remi@remirepo.net> - 2.8.8-1
- update to 2.8.8
diff --git a/installed.json b/installed.json
index 57a9dad..c59dbd1 100644
--- a/installed.json
+++ b/installed.json
@@ -395,27 +395,27 @@
},
{
"name": "composer/spdx-licenses",
- "version": "1.5.8",
- "version_normalized": "1.5.8.0",
+ "version": "1.5.9",
+ "version_normalized": "1.5.9.0",
"source": {
"type": "git",
"url": "https://github.com/composer/spdx-licenses.git",
- "reference": "560bdcf8deb88ae5d611c80a2de8ea9d0358cc0a"
+ "reference": "edf364cefe8c43501e21e88110aac10b284c3c9f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/spdx-licenses/zipball/560bdcf8deb88ae5d611c80a2de8ea9d0358cc0a",
- "reference": "560bdcf8deb88ae5d611c80a2de8ea9d0358cc0a",
+ "url": "https://api.github.com/repos/composer/spdx-licenses/zipball/edf364cefe8c43501e21e88110aac10b284c3c9f",
+ "reference": "edf364cefe8c43501e21e88110aac10b284c3c9f",
"shasum": ""
},
"require": {
"php": "^5.3.2 || ^7.0 || ^8.0"
},
"require-dev": {
- "phpstan/phpstan": "^0.12.55",
- "symfony/phpunit-bridge": "^4.2 || ^5"
+ "phpstan/phpstan": "^1.11",
+ "symfony/phpunit-bridge": "^3 || ^7"
},
- "time": "2023-11-20T07:44:33+00:00",
+ "time": "2025-05-12T21:07:07+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -458,7 +458,7 @@
"support": {
"irc": "ircs://irc.libera.chat:6697/composer",
"issues": "https://github.com/composer/spdx-licenses/issues",
- "source": "https://github.com/composer/spdx-licenses/tree/1.5.8"
+ "source": "https://github.com/composer/spdx-licenses/tree/1.5.9"
},
"funding": [
{
@@ -1371,8 +1371,8 @@
},
{
"name": "symfony/polyfill-ctype",
- "version": "v1.31.0",
- "version_normalized": "1.31.0.0",
+ "version": "v1.32.0",
+ "version_normalized": "1.32.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-ctype.git",
@@ -1433,7 +1433,7 @@
"portable"
],
"support": {
- "source": "https://github.com/symfony/polyfill-ctype/tree/v1.31.0"
+ "source": "https://github.com/symfony/polyfill-ctype/tree/v1.32.0"
},
"funding": [
{
@@ -1453,8 +1453,8 @@
},
{
"name": "symfony/polyfill-intl-grapheme",
- "version": "v1.31.0",
- "version_normalized": "1.31.0.0",
+ "version": "v1.32.0",
+ "version_normalized": "1.32.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-grapheme.git",
@@ -1514,7 +1514,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.31.0"
+ "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.32.0"
},
"funding": [
{
@@ -1534,8 +1534,8 @@
},
{
"name": "symfony/polyfill-intl-normalizer",
- "version": "v1.31.0",
- "version_normalized": "1.31.0.0",
+ "version": "v1.32.0",
+ "version_normalized": "1.32.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-normalizer.git",
@@ -1598,7 +1598,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.31.0"
+ "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.32.0"
},
"funding": [
{
@@ -1618,20 +1618,21 @@
},
{
"name": "symfony/polyfill-mbstring",
- "version": "v1.31.0",
- "version_normalized": "1.31.0.0",
+ "version": "v1.32.0",
+ "version_normalized": "1.32.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-mbstring.git",
- "reference": "85181ba99b2345b0ef10ce42ecac37612d9fd341"
+ "reference": "6d857f4d76bd4b343eac26d6b539585d2bc56493"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/85181ba99b2345b0ef10ce42ecac37612d9fd341",
- "reference": "85181ba99b2345b0ef10ce42ecac37612d9fd341",
+ "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/6d857f4d76bd4b343eac26d6b539585d2bc56493",
+ "reference": "6d857f4d76bd4b343eac26d6b539585d2bc56493",
"shasum": ""
},
"require": {
+ "ext-iconv": "*",
"php": ">=7.2"
},
"provide": {
@@ -1640,7 +1641,7 @@
"suggest": {
"ext-mbstring": "For best performance"
},
- "time": "2024-09-09T11:45:10+00:00",
+ "time": "2024-12-23T08:48:59+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1681,7 +1682,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.31.0"
+ "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.32.0"
},
"funding": [
{
@@ -1701,8 +1702,8 @@
},
{
"name": "symfony/polyfill-php73",
- "version": "v1.31.0",
- "version_normalized": "1.31.0.0",
+ "version": "v1.32.0",
+ "version_normalized": "1.32.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php73.git",
@@ -1760,7 +1761,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php73/tree/v1.31.0"
+ "source": "https://github.com/symfony/polyfill-php73/tree/v1.32.0"
},
"funding": [
{
@@ -1780,23 +1781,23 @@
},
{
"name": "symfony/polyfill-php80",
- "version": "v1.31.0",
- "version_normalized": "1.31.0.0",
+ "version": "v1.32.0",
+ "version_normalized": "1.32.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php80.git",
- "reference": "60328e362d4c2c802a54fcbf04f9d3fb892b4cf8"
+ "reference": "0cc9dd0f17f61d8131e7df6b84bd344899fe2608"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/60328e362d4c2c802a54fcbf04f9d3fb892b4cf8",
- "reference": "60328e362d4c2c802a54fcbf04f9d3fb892b4cf8",
+ "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/0cc9dd0f17f61d8131e7df6b84bd344899fe2608",
+ "reference": "0cc9dd0f17f61d8131e7df6b84bd344899fe2608",
"shasum": ""
},
"require": {
"php": ">=7.2"
},
- "time": "2024-09-09T11:45:10+00:00",
+ "time": "2025-01-02T08:10:11+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1843,7 +1844,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php80/tree/v1.31.0"
+ "source": "https://github.com/symfony/polyfill-php80/tree/v1.32.0"
},
"funding": [
{
@@ -1863,8 +1864,8 @@
},
{
"name": "symfony/polyfill-php81",
- "version": "v1.31.0",
- "version_normalized": "1.31.0.0",
+ "version": "v1.32.0",
+ "version_normalized": "1.32.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php81.git",
@@ -1922,7 +1923,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php81/tree/v1.31.0"
+ "source": "https://github.com/symfony/polyfill-php81/tree/v1.32.0"
},
"funding": [
{