summaryrefslogtreecommitdiffstats
path: root/zephir.spec
diff options
context:
space:
mode:
Diffstat (limited to 'zephir.spec')
-rw-r--r--zephir.spec21
1 files changed, 13 insertions, 8 deletions
diff --git a/zephir.spec b/zephir.spec
index 6fdabb4..27b4e73 100644
--- a/zephir.spec
+++ b/zephir.spec
@@ -21,7 +21,7 @@
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit d1b4cc68d9d6eee6dbf2c6f13f03e8708e7c70a5
+%global gh_commit 664381ee570887b7c7a8585e16da92078bce197f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -30,13 +30,13 @@
%global parser_ver 1.1.1
Name: %{?scl_prefix}%{gh_project}
-Version: 0.10.10
+Version: 0.10.12
Release: 1%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
Summary: Zephir language for creation of extensions for PHP.
Group: Development/Languages
License: MIT
-URL: https://getcomposer.org/
+URL: https://zephir-lang.com/
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
# Adapt path used in RPM
@@ -54,7 +54,7 @@ BuildRequires: %{?scl_prefix}php-ctype
# "ext-pdo": "*",
# "ext-pdo_sqlite": "*",
# "squizlabs/php_codesniffer": "^3.2",
-# "phpunit/phpunit": "^4.8"
+# "phpunit/phpunit": "^4.8 || ^5.7"
BuildRequires: %{?scl_prefix}php-gmp
BuildRequires: %{?scl_prefix}php-pdo
BuildRequires: %{?scl_prefix}php-pdo_sqlite
@@ -65,15 +65,17 @@ Requires: %{?scl_prefix}php-cli
Requires: %{?scl_prefix}php-zephir-parser >= %{parser_ver}
# From composer.json, "require"
# "php": ">=5.5",
-# "ext-json": "*",
-# "ext-hash": "*",
# "ext-ctype": "*",
+# "ext-hash": "*",
+# "ext-json": "*",
# "ext-xml": "*"
+# "ext-mbstring": "*"
Requires: %{?scl_prefix}php(language) >= 5.5
-Requires: %{?scl_prefix}php-json
-Requires: %{?scl_prefix}php-hash
Requires: %{?scl_prefix}php-ctype
+Requires: %{?scl_prefix}php-hash
+Requires: %{?scl_prefix}php-json
Requires: %{?scl_prefix}php-xml
+Requires: %{?scl_prefix}php-mbstring
# From phpcompatinfo
Requires: %{?scl_prefix}php-reflection
Requires: %{?scl_prefix}php-date
@@ -159,6 +161,9 @@ sh ./bin/%{gh_project}.test version | grep %{version}
%changelog
+* Sat Oct 20 2018 Remi Collet <remi@remirepo.net> - 0.10.12-1
+- update to 0.10.12
+
* Fri May 25 2018 Remi Collet <remi@remirepo.net> - 0.10.10-1
- update to 0.10.10