summaryrefslogtreecommitdiffstats
path: root/zephir-parser.spec
diff options
context:
space:
mode:
Diffstat (limited to 'zephir-parser.spec')
-rw-r--r--zephir-parser.spec27
1 files changed, 15 insertions, 12 deletions
diff --git a/zephir-parser.spec b/zephir-parser.spec
index 4d7d773..0a2ad1d 100644
--- a/zephir-parser.spec
+++ b/zephir-parser.spec
@@ -11,16 +11,17 @@
%global with_tests 0
%scl_package zephyr-parser
%else
-%if "%{php_version}" > "5.6"
+%if 0%{?fedora}
%global with_tests 0%{!?_without_tests:1}
%else
+# Disable in EL as 5.4 and 5.5 can't use phpunit
%global with_tests 0%{?_with_tests:1}
%endif
%endif
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit 1fae5e50acea21511a092ffc443b54b865542665
+%global gh_commit 63a35e13c5150e19b3d6abe00fdd65e2471a84f4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -28,7 +29,7 @@
%global ext_name zephir_parser
Name: %{?scl_prefix}%{gh_project}-parser
-Version: 0.9.7
+Version: 0.9.8
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Zephir parser extension
@@ -47,15 +48,15 @@ BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-hash
BuildRequires: %{?scl_prefix}php-ctype
# From composer.json, "require-dev"
-# "squizlabs/php_codesniffer": "~2.6",
-# "phpunit/phpunit": "3.7.*",
# "ext-gmp": "*",
# "ext-pdo": "*",
-# "ext-pdo_sqlite": "*"
+# "ext-pdo_sqlite": "*",
+# "squizlabs/php_codesniffer": "^2.8",
+# "phpunit/phpunit": "^4.8"
BuildRequires: %{?scl_prefix}php-gmp
BuildRequires: %{?scl_prefix}php-pdo
BuildRequires: %{?scl_prefix}php-pdo_sqlite
-BuildRequires: %{?scl_prefix}php-composer(phpunit/phpunit) >= 3.7
+BuildRequires: %{?scl_prefix}php-composer(phpunit/phpunit) >= 4.8
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -79,7 +80,7 @@ Requires: %{name} = %{version}-%{release}
# "ext-hash": "*",
# "ext-ctype": "*",
# "ext-xml": "*"
-Requires: %{?scl_prefix}php(language) >= 5.4
+Requires: %{?scl_prefix}php(language) >= 5.4
Requires: %{?scl_prefix}php-json
Requires: %{?scl_prefix}php-hash
Requires: %{?scl_prefix}php-ctype
@@ -167,10 +168,9 @@ sh ./bin/%{gh_project}.test version | grep %{version}
%if %{with_tests}
: Run test suite
-if %{_bindir}/phpunit --atleast-version 5; then
- %{_bindir}/phpunit unit-tests/Zephir --verbose
-fi
-
+%{_bindir}/phpunit \
+ --bootstrap %{buildroot}%{_datadir}/%{gh_project}/bootstrap.php \
+ --verbose unit-tests/Zephir
%else
: Test suite disabled
%endif
@@ -189,6 +189,9 @@ fi
%changelog
+* Mon May 22 2017 Remi Collet <remi@remirepo.net> - 0.9.8-1
+- version 0.9.8
+
* Wed Apr 5 2017 Remi Collet <remi@fedoraproject.org> - 0.9.7-1
- version 0.9.7