summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--zephir-rpm.patch8
-rw-r--r--zephir.spec (renamed from zephir-parser.spec)64
2 files changed, 24 insertions, 48 deletions
diff --git a/zephir-rpm.patch b/zephir-rpm.patch
index 30b5ea7..43e36a5 100644
--- a/zephir-rpm.patch
+++ b/zephir-rpm.patch
@@ -1,6 +1,6 @@
diff -up bin/zephir.rpm bin/zephir
---- bin/zephir.rpm 2016-10-10 10:45:24.937478208 +0200
-+++ bin/zephir 2016-10-10 10:47:47.437248408 +0200
+--- bin/zephir.rpm 2017-10-11 16:28:17.271148783 +0200
++++ bin/zephir 2017-10-11 17:37:30.075485109 +0200
@@ -1,26 +1,8 @@
#!/bin/sh
-if [ -z "$ZEPHIRDIR" ]; then
@@ -25,9 +25,9 @@ diff -up bin/zephir.rpm bin/zephir
+export ZEPHIRDIR="@DATADIR@/zephir"
if [ ! -z $1 ] && [ ! -z $2 ] && [ ! -z $3 ] && [ "$1" = "-c" ]; then
-- php -d safe_mode=Off -d enable_dl=On -c $2 $ZEPHIRDIR/compiler.php ${*:3}
+- php -c $2 $ZEPHIRDIR/compiler.php ${*:3}
+ @BINDIR@/php -d memory_limit=1G -d extension=zephir_parser.so -c $2 $ZEPHIRDIR/compiler.php ${*:3}
else
-- php -d safe_mode=Off -d enable_dl=On $ZEPHIRDIR/compiler.php $*
+- php $ZEPHIRDIR/compiler.php $*
+ @BINDIR@/php -d memory_limit=1G -d extension=zephir_parser.so $ZEPHIRDIR/compiler.php $*
fi
diff --git a/zephir-parser.spec b/zephir.spec
index 4b940da..359783a 100644
--- a/zephir-parser.spec
+++ b/zephir.spec
@@ -1,4 +1,4 @@
-# remirepo/fedora spec file for zephir and zephir-parser
+# remirepo/fedora spec file for zephir
#
# Copyright (c) 2016-2017 Remi Collet
# License: CC-BY-SA
@@ -21,19 +21,20 @@
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit 534bd284df93e1c36c9893d8bd2ef270b207a55b
+%global gh_commit fb706a75805db24f2c7e70aad2465771c365d5a8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
%global gh_project zephir
%global ext_name zephir_parser
+%global parser_ver 1.0.3
-Name: %{?scl_prefix}%{gh_project}-parser
-Version: 0.9.11
-Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Summary: Zephir parser extension
+Name: %{?scl_prefix}%{gh_project}
+Version: 0.10.2
+Release: 1%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
+Summary: Zephir language for creation of extensions for PHP.
-Group: Development/Libraries
+Group: Development/Languages
License: MIT
URL: https://getcomposer.org/
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
@@ -41,8 +42,9 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Adapt path used in RPM
Patch0: %{gh_project}-rpm.patch
-BuildRequires: %{?scl_prefix}php-devel > 5.4
-BuildRequires: re2c
+BuildArch: noarch
+BuildRequires: %{?scl_prefix}php-devel > 5.5
+BuildRequires: %{?scl_prefix}php-zephir-parser >= %{parser_ver}
%if %{with_tests}
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-hash
@@ -59,28 +61,15 @@ BuildRequires: %{?scl_prefix}php-pdo_sqlite
BuildRequires: %{?scl_prefix}php-composer(phpunit/phpunit) >= 4.8
%endif
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-%description
-Parser extension used by %{gh_project}
-
-
-%package -n %{?scl_prefix}%{gh_project}
-Summary: Zephir language for creation of extensions for PHP.
-Group: Development/Languages
-BuildArch: noarch
-
Requires: %{?scl_prefix}php-cli
-Requires: %{name} = %{version}-%{release}
+Requires: %{?scl_prefix}php-zephir-parser >= %{parser_ver}
# From composer.json, "require"
# "php": ">=5.4",
# "ext-json": "*",
# "ext-hash": "*",
# "ext-ctype": "*",
# "ext-xml": "*"
-Requires: %{?scl_prefix}php(language) >= 5.4
+Requires: %{?scl_prefix}php(language) >= 5.5
Requires: %{?scl_prefix}php-json
Requires: %{?scl_prefix}php-hash
Requires: %{?scl_prefix}php-ctype
@@ -95,7 +84,7 @@ Requires: %{?scl_prefix}php-spl
Provides: %{?scl_prefix}php-composer(%{gh_owner}/%{gh_project}) = %{version}
-%description -n %{?scl_prefix}%{gh_project}
+%description
Zephir - Ze(nd Engine) Ph(p) I(nt)r(mediate) - is a high level language
that eases the creation and maintainability of extensions for PHP.
Zephir extensions are exported to C code that can be compiled and
@@ -127,20 +116,10 @@ find . -name \*.php -exec chmod -x {} \;
%build
-%{?dtsenable}
-
-cd parser/parser
-./build_linux.sh
-cd ..
-%{_bindir}/phpize
-%configure \
- --with-php-config=%{_bindir}/php-config
-make
-
+# nothing
%install
-%{?dtsenable}
: Library and resources
mkdir -p %{buildroot}%{_datadir}/%{gh_project}
@@ -152,8 +131,6 @@ done
: Command
install -Dpm 755 bin/%{gh_project} %{buildroot}%{_bindir}/%{gh_project}
-: Extension
-make install -C parser INSTALL_ROOT=%{buildroot}
%check
@@ -163,9 +140,6 @@ sed -e 's:%ZEPHIRDIR%:%{buildroot}%{_datadir}/%{gh_project}:g' \
sh ./bin/%{gh_project}.test version
sh ./bin/%{gh_project}.test version | grep %{version}
-: Check extension
-%{_bindir}/php -n -d extension=parser/modules/%{ext_name}.so -m | grep %{ext_name}
-
%if %{with_tests}
: Run test suite
%{_bindir}/phpunit \
@@ -179,9 +153,6 @@ sh ./bin/%{gh_project}.test version | grep %{version}
%files
%{!?_licensedir:%global license %%doc}
%license LICENSE
-%{php_extdir}/%{ext_name}.so
-
-%files -n %{?scl_prefix}%{gh_project}
%doc *.md
%doc composer.json
%{_bindir}/%{gh_project}
@@ -189,6 +160,11 @@ sh ./bin/%{gh_project}.test version | grep %{version}
%changelog
+* Wed Oct 11 2017 Remi Collet <remi@remirepo.net> - 0.10.2-1
+- version 0.10.2
+- drop zephir-parser sub-package
+- add dependency on php-zephir-parser
+
* Fri Aug 4 2017 Remi Collet <remi@remirepo.net> - 0.9.11-1
- version 0.9.11