summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--zephir-rpm.patch18
-rw-r--r--zephir.spec9
2 files changed, 15 insertions, 12 deletions
diff --git a/zephir-rpm.patch b/zephir-rpm.patch
index 52039be..9598e20 100644
--- a/zephir-rpm.patch
+++ b/zephir-rpm.patch
@@ -1,9 +1,9 @@
-diff -up bin/zephir.rpm bin/zephir
---- bin/zephir.rpm 2017-10-11 16:28:17.271148783 +0200
-+++ bin/zephir 2017-10-11 17:37:30.075485109 +0200
-@@ -1,26 +1,8 @@
+diff -up ./bin/zephir.rpm ./bin/zephir
+--- ./bin/zephir.rpm 2017-10-23 07:02:31.781050845 +0200
++++ ./bin/zephir 2017-10-23 07:04:04.955553874 +0200
+@@ -1,26 +1,10 @@
#!/bin/sh
--if [ -z "$ZEPHIRDIR" ]; then
+ if [ -z "$ZEPHIRDIR" ]; then
- ZEPHIRDIR="%ZEPHIRDIR%"
- if [ "$ZEPHIRDIR" = "%""ZEPHIRDIR""%" ]; then
- if [ -h $0 ]; then
@@ -21,13 +21,13 @@ diff -up bin/zephir.rpm bin/zephir
- exit 1
- fi
- fi
--fi
-+export ZEPHIRDIR="@DATADIR@/zephir"
++ export ZEPHIRDIR="@DATADIR@/zephir"
+ fi
if [ ! -z $1 ] && [ ! -z $2 ] && [ ! -z $3 ] && [ "$1" = "-c" ]; then
-- php -c $2 $ZEPHIRDIR/compiler.php ${*:3}
+- php -d timecop.func_override=0 -c $2 $ZEPHIRDIR/compiler.php ${*:3}
+ @BINDIR@/php -d timecop.func_override=0 -d memory_limit=1G -d extension=zephir_parser.so -c $2 $ZEPHIRDIR/compiler.php ${*:3}
else
-- php $ZEPHIRDIR/compiler.php $*
+- php -d timecop.func_override=0 $ZEPHIRDIR/compiler.php $*
+ @BINDIR@/php -d timecop.func_override=0 -d memory_limit=1G -d extension=zephir_parser.so $ZEPHIRDIR/compiler.php $*
fi
diff --git a/zephir.spec b/zephir.spec
index 8249ecd..2fc8a06 100644
--- a/zephir.spec
+++ b/zephir.spec
@@ -21,7 +21,7 @@
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit 7f475126c7380bea312afa2783f681e7f6689ca5
+%global gh_commit 11e39849b02f8bebe780f2c8a52487e8566609ef
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -30,8 +30,8 @@
%global parser_ver 1.1.0
Name: %{?scl_prefix}%{gh_project}
-Version: 0.10.3
-Release: 2%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
+Version: 0.10.4
+Release: 1%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
Summary: Zephir language for creation of extensions for PHP.
Group: Development/Languages
@@ -160,6 +160,9 @@ sh ./bin/%{gh_project}.test version | grep %{version}
%changelog
+* Mon Oct 23 2017 Remi Collet <remi@remirepo.net> - 0.10.4-1
+- version 0.10.4
+
* Fri Oct 13 2017 Remi Collet <remi@remirepo.net> - 0.10.3-2
- disable timecop which breaks zephir
see https://github.com/phalcon/zephir/pull/1588