summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--zephir-rpm.patch22
-rw-r--r--zephir.spec9
2 files changed, 17 insertions, 14 deletions
diff --git a/zephir-rpm.patch b/zephir-rpm.patch
index 3239650..1f6b125 100644
--- a/zephir-rpm.patch
+++ b/zephir-rpm.patch
@@ -1,7 +1,7 @@
diff -up ./Library/autoload.php.rpm ./Library/autoload.php
---- ./Library/autoload.php.rpm 2018-11-28 15:59:50.923865048 +0100
-+++ ./Library/autoload.php 2018-11-28 16:16:41.880180099 +0100
-@@ -39,20 +39,5 @@ if (PHP_SAPI !== 'cli' && PHP_SAPI !== '
+--- ./Library/autoload.php.rpm 2019-01-16 13:34:46.975062156 +0100
++++ ./Library/autoload.php 2019-01-16 13:35:28.477322927 +0100
+@@ -39,20 +39,4 @@ if (PHP_SAPI !== 'cli' && PHP_SAPI !== '
exit(1);
}
@@ -9,25 +9,25 @@ diff -up ./Library/autoload.php.rpm ./Library/autoload.php
- __DIR__.'/../vendor/autoload.php', // Is installed locally
- __DIR__.'/../../../autoload.php', // Is installed via Composer
-];
-+require_once dirname(__DIR__) . '/autoload.php';
-
+-
-foreach ($autoloaders as $file) {
-- if (\file_exists($file)) {
+- if (file_exists($file)) {
- include_once $file;
- break;
- }
-}
-
--if (false == \class_exists('Composer\Autoload\ClassLoader', false)) {
-- \fwrite(STDERR, 'Unable to find the Composer autoloader.'.PHP_EOL);
+-if (false == class_exists('Composer\Autoload\ClassLoader', false)) {
+- fwrite(STDERR, 'Unable to find the Composer autoloader.'.PHP_EOL);
-
- exit(1);
-}
++require_once dirname(__DIR__) . '/autoload.php';
diff -up ./zephir.rpm ./zephir
---- ./zephir.rpm 2018-11-27 22:28:25.000000000 +0100
-+++ ./zephir 2018-11-28 15:57:43.690197659 +0100
+--- ./zephir.rpm 2019-01-16 13:34:46.975062156 +0100
++++ ./zephir 2019-01-16 13:36:53.264855644 +0100
@@ -1,4 +1,3 @@
-#!/usr/bin/env php
<?php
- /**
+ /*
diff --git a/zephir.spec b/zephir.spec
index f22687c..28ab443 100644
--- a/zephir.spec
+++ b/zephir.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for zephir
#
-# Copyright (c) 2016-2018 Remi Collet
+# Copyright (c) 2016-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -16,7 +16,7 @@
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit 4495e75ab246aa3120bffc0fb8e70b38dfa25969
+%global gh_commit 209fe3fde9731b9e1d8a20f71ce7970f3be2d21b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -25,7 +25,7 @@
%global parser_ver 1.1.1
Name: %{?scl_prefix}%{gh_project}
-Version: 0.11.8
+Version: 0.11.9
Release: 1%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
Summary: Zephir language for creation of extensions for PHP.
@@ -321,6 +321,9 @@ esac
%changelog
+* Wed Jan 16 2019 Remi Collet <remi@remirepo.net> - 0.11.9-1
+- update to 0.11.9
+
* Mon Dec 3 2018 Remi Collet <remi@remirepo.net> - 0.11.8-1
- update to 0.11.8