summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json42
-rw-r--r--zephir.spec23
2 files changed, 42 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index d586cf4..cb4f925 100644
--- a/composer.json
+++ b/composer.json
@@ -7,43 +7,57 @@
"phalcon",
"internals"
],
- "homepage": "https://zephir-lang.com/",
+ "homepage": "https://zephir-lang.com",
"license": "MIT",
"authors": [
{
"name": "Zephir Team",
"email": "team@zephir-lang.com",
- "homepage": "https://zephir-lang.com/"
+ "homepage": "https://zephir-lang.com"
},
{
"name": "Contributors",
"homepage": "https://github.com/phalcon/zephir/graphs/contributors"
}
],
- "support": {
- "issues": "https://github.com/phalcon/zephir/issues?state=open",
- "source": "https://github.com/phalcon/zephir",
- "forum": "https://forum.zephir-lang.com/",
- "docs": "https://docs.zephir-lang.com/"
- },
"require": {
"php": ">=5.5",
- "ext-json": "*",
- "ext-hash": "*",
"ext-ctype": "*",
- "ext-xml": "*"
+ "ext-hash": "*",
+ "ext-json": "*",
+ "ext-xml": "*",
+ "ext-mbstring": "*"
},
"require-dev": {
"ext-gmp": "*",
"ext-pdo": "*",
"ext-pdo_sqlite": "*",
- "squizlabs/php_codesniffer": "^3.2",
- "phpunit/phpunit": "^4.8"
+ "phpunit/phpunit": "^4.8 || ^5.7",
+ "squizlabs/php_codesniffer": "^3.2"
},
"autoload": {
"psr-4": {
"Zephir\\": "Library"
}
},
- "bin": ["bin/zephir"]
+ "autoload-dev": {
+ "psr-4": {
+ "Zephir\\Stubs\\": "unit-tests/Zephir/Stubs/",
+ "Zephir\\Test\\": "unit-tests/Zephir/Test/",
+ "Zephir\\Support\\": "unit-tests/Zephir/Support/",
+ "Extension\\": "unit-tests/Extension/"
+ },
+ "classmap": [
+ "unit-tests/Data/"
+ ]
+ },
+ "bin": [
+ "bin/zephir"
+ ],
+ "support": {
+ "issues": "https://github.com/phalcon/zephir/issues?state=open",
+ "forum": "https://forum.zephir-lang.com",
+ "source": "https://github.com/phalcon/zephir",
+ "docs": "https://docs.zephir-lang.com"
+ }
}
diff --git a/zephir.spec b/zephir.spec
index a8be84e..3b7c8fe 100644
--- a/zephir.spec
+++ b/zephir.spec
@@ -21,7 +21,7 @@
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit f5a5a148371f10c886e5b8a095a76c360ea1966a
+%global gh_commit ab3551da612b837cbeb2dc228052a6d35bec5778
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -30,13 +30,13 @@
%global parser_ver 1.1.1
Name: %{?scl_prefix}%{gh_project}
-Version: 0.11.0
+Version: 0.11.1
Release: 1%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
Summary: Zephir language for creation of extensions for PHP.
Group: Development/Languages
License: MIT
-URL: https://getcomposer.org/
+URL: https://zephir-lang.com/
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
# Adapt path used in RPM
@@ -53,8 +53,8 @@ BuildRequires: %{?scl_prefix}php-ctype
# "ext-gmp": "*",
# "ext-pdo": "*",
# "ext-pdo_sqlite": "*",
-# "squizlabs/php_codesniffer": "^3.2",
-# "phpunit/phpunit": "^4.8"
+# "phpunit/phpunit": "^4.8 || ^5.7,
+# "squizlabs/php_codesniffer": "^3.2"
BuildRequires: %{?scl_prefix}php-gmp
BuildRequires: %{?scl_prefix}php-pdo
BuildRequires: %{?scl_prefix}php-pdo_sqlite
@@ -65,15 +65,17 @@ Requires: %{?scl_prefix}php-cli
Requires: %{?scl_prefix}php-zephir-parser >= %{parser_ver}
# From composer.json, "require"
# "php": ">=5.5",
-# "ext-json": "*",
-# "ext-hash": "*",
# "ext-ctype": "*",
+# "ext-hash": "*",
+# "ext-json": "*",
# "ext-xml": "*"
+# "ext-mbstring": "*"
Requires: %{?scl_prefix}php(language) >= 5.5
-Requires: %{?scl_prefix}php-json
-Requires: %{?scl_prefix}php-hash
Requires: %{?scl_prefix}php-ctype
+Requires: %{?scl_prefix}php-hash
+Requires: %{?scl_prefix}php-json
Requires: %{?scl_prefix}php-xml
+Requires: %{?scl_prefix}php-mbstring
# From phpcompatinfo
Requires: %{?scl_prefix}php-reflection
Requires: %{?scl_prefix}php-date
@@ -160,6 +162,9 @@ sh ./bin/%{gh_project}.test version | grep %{version}
%changelog
+* Sat Oct 20 2018 Remi Collet <remi@remirepo.net> - 0.11.1-1
+- update to 0.11.1
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 0.11.0-1
- update to 0.11.0