summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-11-04 18:11:32 +0100
committerRemi Collet <remi@remirepo.net>2019-11-04 18:11:32 +0100
commit017c9cfcb77e0a557e4f88b144e7885a089ceae5 (patch)
treef37729a0af8e54c01a23d68ada1226c48e608efd
parent3cffdb0e79b85144c64885245b454bc8a74ad4e9 (diff)
- update to 0.12.11HEADmaster
- add dependency on ocramius/proxy-manager - add dependency on symfony/proxy-manager-bridge
-rw-r--r--composer.json3
-rw-r--r--zephir.spec27
2 files changed, 28 insertions, 2 deletions
diff --git a/composer.json b/composer.json
index 482c110..749b27f 100644
--- a/composer.json
+++ b/composer.json
@@ -29,6 +29,8 @@
"ext-mbstring": "*",
"ext-pcre": "*",
"ext-xml": "*",
+ "ext-zlib": "*",
+ "ocramius/proxy-manager": "2.0.4",
"oneup/flysystem-bundle": "^1.14 || ^3.0",
"symfony/cache": "3.4.*",
"symfony/config": "3.4.*",
@@ -41,6 +43,7 @@
"symfony/http-kernel": "3.4.*",
"symfony/monolog-bridge": "3.4.*",
"symfony/monolog-bundle": "3.3.*",
+ "symfony/proxy-manager-bridge": "3.4.*",
"symfony/routing": "3.4.*",
"symfony/yaml": "3.4.*"
},
diff --git a/zephir.spec b/zephir.spec
index d49edc7..d8ad24c 100644
--- a/zephir.spec
+++ b/zephir.spec
@@ -7,6 +7,10 @@
# Please, preserve the changelog entries
#
+#####
+##### TODO: review autoloadere for SCL
+#####
+
%if 0%{?scl:1}
%global with_tests 0
%scl_package zephyr
@@ -16,7 +20,7 @@
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit fedc314d7146cf9e35265fb4f8a20094017b3bf3
+%global gh_commit 8b9430c33bdec75aa9577b19d221908370536078
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -25,7 +29,7 @@
%global parser_ver 1.1.1
Name: %{?scl_prefix}%{gh_project}
-Version: 0.12.10
+Version: 0.12.11
Release: 1%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
Summary: Zephir language for creation of extensions for PHP.
@@ -46,6 +50,7 @@ BuildRequires: %{?scl_prefix}php-ctype
BuildRequires: %{?scl_prefix}php-psr
BuildRequires: %{_bindir}/phpab
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(ocramius/proxy-manager) >= 2.0.4 with php-composer(ocramius/proxy-manager) < 3)
BuildRequires: (php-composer(oneup/flysystem-bundle) >= 1.14 with php-composer(oneup/flysystem-bundle) < 4)
BuildRequires: (php-composer(symfony/cache) >= 3.4 with php-composer(symfony/cache) < 4)
BuildRequires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 4)
@@ -58,9 +63,11 @@ BuildRequires: (php-composer(symfony/framework-bundle) >= 3.4 with php-c
BuildRequires: (php-composer(symfony/http-kernel) >= 3.4 with php-composer(symfony/http-kernel) < 4)
BuildRequires: (php-composer(symfony/monolog-bridge) >= 3.4 with php-composer(symfony/monolog-bridge) < 4)
BuildRequires: (php-composer(symfony/monolog-bundle) >= 3.3 with php-composer(symfony/monolog-bundle) < 4)
+BuildRequires: (php-composer(symfony/proxy-manager-bridge) >= 3.4 with php-composer(symfony/proxy-manager-bridge) < 4)
BuildRequires: (php-composer(symfony/routing) >= 3.4 with php-composer(symfony/routing) < 4)
BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 4)
%else
+BuildRequires: php-ocramius-proxy-manager
BuildRequires: php-oneup-flysystem-bundle
BuildRequires: php-symfony3-cache
BuildRequires: php-symfony3-config
@@ -73,6 +80,7 @@ BuildRequires: php-symfony3-framework-bundle
BuildRequires: php-symfony3-http-kernel
BuildRequires: php-symfony3-monolog-bridge
BuildRequires: php-symfony-monolog-bundle
+BuildRequires: php-symfony3-proxy-manager-bridge
BuildRequires: php-symfony3-routing
BuildRequires: php-symfony3-yaml
%endif
@@ -113,6 +121,8 @@ Requires: %{?scl_prefix}php-zephir-parser >= %{parser_ver}
# "ext-mbstring": "*",
# "ext-pcre": "*",
# "ext-xml": "*"
+# "ext-zlib": "*",
+# "ocramius/proxy-manager": "2.0.4",
# "oneup/flysystem-bundle": "^1.14 || ^3.0",
# "symfony/cache": "3.4.*",
# "symfony/config": "3.4.*",
@@ -125,6 +135,7 @@ Requires: %{?scl_prefix}php-zephir-parser >= %{parser_ver}
# "symfony/http-kernel": "3.4.*",
# "symfony/monolog-bridge": "3.4.*",
# "symfony/monolog-bundle": "3.3.*",
+# "symfony/proxy-manager-bridge": "3.4.*",
# "symfony/routing": "3.4.*",
# "symfony/yaml": "3.4.*"
Requires: %{?scl_prefix}php(language) >= 7.0
@@ -135,7 +146,9 @@ Requires: %{?scl_prefix}php-json
Requires: %{?scl_prefix}php-mbstring
Requires: %{?scl_prefix}php-pcre
Requires: %{?scl_prefix}php-xml
+Requires: %{?scl_prefix}php-zlib
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(ocramius/proxy-manager) >= 2.0.4 with php-composer(ocramius/proxy-manager) < 3)
Requires: (php-composer(oneup/flysystem-bundle) >= 1.14 with php-composer(oneup/flysystem-bundle) < 4)
Requires: (php-composer(symfony/cache) >= 3.4 with php-composer(symfony/cache) < 4)
Requires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 4)
@@ -148,9 +161,11 @@ Requires: (php-composer(symfony/framework-bundle) >= 3.4 with php-c
Requires: (php-composer(symfony/http-kernel) >= 3.4 with php-composer(symfony/http-kernel) < 4)
Requires: (php-composer(symfony/monolog-bridge) >= 3.4 with php-composer(symfony/monolog-bridge) < 4)
Requires: (php-composer(symfony/monolog-bundle) >= 3.3 with php-composer(symfony/monolog-bundle) < 4)
+Requires: (php-composer(symfony/proxy-manager-bridge) >= 3.4 with php-composer(symfony/proxy-manager-bridge) < 4)
Requires: (php-composer(symfony/routing) >= 3.4 with php-composer(symfony/routing) < 4)
Requires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 4)
%else
+Requires: php-ocramius-proxy-manager
Requires: php-oneup-flysystem-bundle
Requires: php-symfony3-cache
Requires: php-symfony3-config
@@ -163,6 +178,7 @@ Requires: php-symfony3-framework-bundle
Requires: php-symfony3-http-kernel
Requires: php-symfony3-monolog-bridge
Requires: php-symfony-monolog-bundle
+Requires: php-symfony3-proxy-manager-bridge
Requires: php-symfony3-routing
Requires: php-symfony3-yaml
%endif
@@ -215,6 +231,7 @@ require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Zephir\\', __DIR__ . '/Library');
\Fedora\Autoloader\Dependencies::required([
__DIR__ . '/Library/functions.php',
+ '%{_datadir}/php/ProxyManager/autoload.php',
'%{_datadir}/php/Oneup/FlysystemBundle/autoload.php',
'%{_datadir}/php/Symfony3/Component/Cache/autoload.php',
'%{_datadir}/php/Symfony3/Component/Config/autoload.php',
@@ -229,6 +246,7 @@ require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
'%{_datadir}/php/Symfony3/Component/Routing/autoload.php',
'%{_datadir}/php/Symfony3/Component/Yaml/autoload.php',
'%{_datadir}/php/Symfony/Bundle/MonologBundle/autoload.php',
+ '%{_datadir}/php/Symfony3/Bridge/ProxyManager/autoload.php',
]);
EOF
@@ -339,6 +357,11 @@ esac
%changelog
+* Mon Nov 4 2019 Remi Collet <remi@remirepo.net> - 0.12.11-1
+- update to 0.12.11
+- add dependency on ocramius/proxy-manager
+- add dependency on symfony/proxy-manager-bridge
+
* Mon Oct 21 2019 Remi Collet <remi@remirepo.net> - 0.12.10-1
- update to 0.12.10