summaryrefslogtreecommitdiffstats
path: root/unit.spec
diff options
context:
space:
mode:
Diffstat (limited to 'unit.spec')
-rw-r--r--unit.spec11
1 files changed, 10 insertions, 1 deletions
diff --git a/unit.spec b/unit.spec
index 2eb8f84..4dc7c51 100644
--- a/unit.spec
+++ b/unit.spec
@@ -19,7 +19,7 @@
Name: unit
Summary: NGINX Unit application server
Version: 1.7
-Release: 1%{?dist}
+Release: 2%{?dist}
License: ASL 2.0
URL: https://unit.nginx.org/
@@ -27,6 +27,7 @@ Source0: https://github.com/%{gh_owner}/%{project}/archive/%{gh_commit
Source1: unit.service
Source2: unit.init
Source3: unit.sysconf
+Source4: unit.logrotate
# Use system crypto policy
Patch0: https://github.com/nginx/unit/pull/215.patch
@@ -44,6 +45,8 @@ Requires(preun): chkconfig
Requires(preun): initscripts
Requires(postun): initscripts
%endif
+Requires: logrotate
+
Provides: nginx-unit = %{version}-%{release}
@@ -116,6 +119,8 @@ mkdir -p %{buildroot}%{_sharedstatedir}/%{name}
mkdir -p %{buildroot}%{_localstatedir}/log/%{name}
mkdir -p %{buildroot}%{_localstatedir}/run/%{name}
+install -p -D -m 0644 %{SOURCE4} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
+
# init scripts
%if %{use_systemd}
install -p -D -m 0644 %{SOURCE1} %{buildroot}%{_unitdir}/%{name}.service
@@ -173,6 +178,7 @@ fi
%dir %{_libdir}/unit/debug-modules
%dir %{_sharedstatedir}/unit
%dir %attr(0700,root,root) %{_localstatedir}/log/unit
+%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
%if %{use_systemd}
%dir %{_sysconfdir}/systemd/system/%{name}.service.d
@@ -193,6 +199,9 @@ fi
%changelog
+* Thu Jan 17 2019 Remi Collet <remi@remirepo.net> - 1.7-2
+- provide logrotate configuration
+
* Tue Jan 15 2019 Remi Collet <remi@remirepo.net> - 1.7-1
- initial package
- open https://github.com/nginx/unit/pull/215 system crypto policy