summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--unit-build.patch25
-rw-r--r--unit.spec8
2 files changed, 32 insertions, 1 deletions
diff --git a/unit-build.patch b/unit-build.patch
new file mode 100644
index 0000000..c2b0ef4
--- /dev/null
+++ b/unit-build.patch
@@ -0,0 +1,25 @@
+From 0125873b1dfbe6e671e3c9874ec2653f1b7832fa Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 3 Sep 2021 18:03:38 +0200
+Subject: [PATCH] fix build with recent glibc
+
+---
+ src/nxt_thread.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/nxt_thread.h b/src/nxt_thread.h
+index d7800cc..36e74cd 100644
+--- a/src/nxt_thread.h
++++ b/src/nxt_thread.h
+@@ -142,7 +142,7 @@ nxt_thread_yield() \
+ #endif
+
+
+-#if (PTHREAD_STACK_MIN)
++#if defined(PTHREAD_STACK_MIN)
+ #define NXT_THREAD_STACK_MIN PTHREAD_STACK_MIN
+
+ #else
+--
+2.31.1
+
diff --git a/unit.spec b/unit.spec
index 0f70879..e2019c9 100644
--- a/unit.spec
+++ b/unit.spec
@@ -17,7 +17,7 @@
Name: unit
Summary: NGINX Unit application server
Version: 1.25.0
-Release: 1%{?dist}
+Release: 2%{?dist}
License: ASL 2.0
URL: https://unit.nginx.org/
@@ -30,6 +30,7 @@ Source4: unit.logrotate
# Use system crypto policy
# https://github.com/nginx/unit/pull/215
Patch0: %{project}-syspol.patch
+Patch1: %{project}-build.patch
BuildRequires: make
BuildRequires: gcc
@@ -64,6 +65,7 @@ Library and include files required for NGINX Unit modules development.
%prep
%setup -qn %{project}-%{gh_commit}
%patch0 -p1 -b .syspol
+%patch1 -p1 -b .build
cp pkg/rpm/rpmbuild/SOURCES/unit.example.config example.config
@@ -187,6 +189,10 @@ BANNER
%changelog
+* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 1.25.0-2
+- fix build with recent glibc using patch from
+ https://github.com/nginx/unit/pull/576
+
* Tue Aug 24 2021 Remi Collet <remi@remirepo.net> - 1.25.0-1
- update to 1.25.0