summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--unit-syspol.patch12
-rw-r--r--unit.spec7
2 files changed, 11 insertions, 8 deletions
diff --git a/unit-syspol.patch b/unit-syspol.patch
index c79025c..1ab0ddf 100644
--- a/unit-syspol.patch
+++ b/unit-syspol.patch
@@ -1,16 +1,16 @@
diff -up ./src/nxt_openssl.c.syspol ./src/nxt_openssl.c
---- ./src/nxt_openssl.c.syspol 2021-05-28 07:49:58.267866774 +0200
-+++ ./src/nxt_openssl.c 2021-05-28 07:52:44.119844098 +0200
-@@ -269,7 +269,7 @@ nxt_openssl_server_init(nxt_task_t *task
- nxt_mp_t *mp, nxt_conf_value_t *conf_cmds, nxt_bool_t last)
+--- ./src/nxt_openssl.c.syspol 2021-08-19 16:52:54.000000000 +0200
++++ ./src/nxt_openssl.c 2021-08-24 07:43:45.844605992 +0200
+@@ -278,7 +278,7 @@ nxt_openssl_server_init(nxt_task_t *task
+ nxt_tls_init_t *tls_init, nxt_bool_t last)
{
SSL_CTX *ctx;
- const char *ciphers, *ca_certificate;
+ const char *ca_certificate;
+ nxt_tls_conf_t *conf;
STACK_OF(X509_NAME) *list;
nxt_tls_bundle_conf_t *bundle;
-
-@@ -327,13 +327,13 @@ nxt_openssl_server_init(nxt_task_t *task
+@@ -339,13 +339,13 @@ nxt_openssl_server_init(nxt_task_t *task
}
*/
diff --git a/unit.spec b/unit.spec
index 1425c52..0f70879 100644
--- a/unit.spec
+++ b/unit.spec
@@ -11,12 +11,12 @@
%global gh_owner nginx
%global project unit
-%global gh_commit 25d8e102b0b3ca6cfa15b752397566fdbe2f7eaa
+%global gh_commit 66e986fc19dd12c731be5f52d0aa4cea32931b7d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
Name: unit
Summary: NGINX Unit application server
-Version: 1.24.0
+Version: 1.25.0
Release: 1%{?dist}
License: ASL 2.0
URL: https://unit.nginx.org/
@@ -187,6 +187,9 @@ BANNER
%changelog
+* Tue Aug 24 2021 Remi Collet <remi@remirepo.net> - 1.25.0-1
+- update to 1.25.0
+
* Fri May 28 2021 Remi Collet <remi@remirepo.net> - 1.24.0-1
- update to 1.24.0