summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 2e8d44e..0406eaf 100644
--- a/Makefile
+++ b/Makefile
@@ -95,7 +95,11 @@ php7src:
spectool -g -S $(NAME)-php7.spec
php7build:
- time rpmbuild $(RPMDEFINES) --define "scl php70" --without zts -bb $(NAME)-php7.spec
+ @if test -f $(NAME)-php7.spec ; then \
+ time rpmbuild $(RPMDEFINES) --define "scl php70" --without zts -bb $(NAME)-php7.spec ; \
+ else \
+ time rpmbuild $(RPMDEFINES) --define "scl php70" --without zts -bb $(NAME).spec ; \
+ fi
php7srpm:
rpmbuild $(RPMDEFINES) $(SRCDEFINES) -bs $(NAME)-php7.spec