summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec269
1 files changed, 18 insertions, 251 deletions
diff --git a/php.spec b/php.spec
index a68180b..c9adba4 100644
--- a/php.spec
+++ b/php.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for php83-php
+# remirepo spec file for php84-php
# with SCL and backport stuff, adapted from
#
# Fedora spec file for php
@@ -23,17 +23,15 @@
%endif
# API/ABI check
-%global apiver 20230831
-%global zendver 20230831
-%global pdover 20170320
-# Extension version
-%global oci8ver 3.3.0
+%global apiver 20230901
+%global zendver 20230901
+%global pdover 20240423
# Adds -z now to the linker flags
%global _hardened_build 1
# version used for php embedded library soname
-%global embed_version 8.3
+%global embed_version 8.4
# Ugly hack. Harcoded values to avoid relocation.
%global _httpd_mmn %(cat %{_root_includedir}/httpd/.mmn 2>/dev/null || echo 0)
@@ -49,16 +47,6 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%ifarch aarch64
-%global oraclever 19.22
-%global oraclelib 19.1
-%global oracledir 19.22
-%else
-%global oraclever 21.13
-%global oraclelib 21.1
-%global oracledir 21
-%endif
-
# Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests
%bcond_without lsws
@@ -71,66 +59,30 @@
%global mysql_config %{_root_libdir}/mysql/mysql_config
# Optional extensions; to enable: pass "--with xxx" etc to rpmbuild/mock.
-%bcond_with oci8
%bcond_with zip
# Optional extensions; to disable: pass "--without xxx" etc to rpmbuild/mock.
-%bcond_without imap
%bcond_without firebird
%bcond_without freetds
%bcond_without tidy
%bcond_without sqlite3
%bcond_without enchant
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-# switch to bundled library using --without libpcre
%bcond_without libpcre
-%else
-# switch to system library using --with libpcre
-%bcond_with libpcre
-%endif
-
-# Using qdbm from "remi" for now, see https://bugzilla.redhat.com/2017308
-%if 0%{?fedora} >= 33 || 0%{?rhel} >= 8
%bcond_without qdbm
-%else
-%bcond_with qdbm
-%endif
-
-%if 0%{?fedora} >= 33 || 0%{?rhel} >= 8
-# switch to bundled library using --without libxcrypt
%bcond_without libxcrypt
-%else
-# switch to system library using --with libxcrypt
-%bcond_with libxcrypt
-%endif
-
%bcond_without dtrace
-
# build with system libgd (gd-last in remi repo)
%bcond_without libgd
-
# build with system tzdata (2021 required)
-%if 0%{?fedora} >= 33 || 0%{?rhel} >= 7
%bcond_without tzdata
-%else
-%bcond_with tzdata
-%endif
-
-
-# httpd 2.4.10 with httpd-filesystem and sethandler support
-%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
-%global with_httpd2410 1
-%else
-%global with_httpd2410 0
-%endif
%global gh_commit 9ce6980b4d93d539341807087abef9217cb81351
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20230605
%global gh_owner php
%global gh_project php-src
-%global upver 8.3.9
-#global rcver RC1
+%global upver 8.4.0
+%global rcver alpha1
# TODO set PHP_EXTRA_VERSION for EOL version
Summary: PHP scripting language for creating dynamic web sites
@@ -169,25 +121,22 @@ Source12: php-fpm.wants
# Configuration files for some extensions
Source50: 10-opcache.ini
Source51: opcache-default.blacklist
-Source52: 20-oci8.ini
Source53: 20-ffi.ini
# Build fixes
-Patch1: php-7.4.0-httpd.patch
+Patch1: php-8.4.0-httpd.patch
Patch5: php-7.2.0-includedir.patch
-Patch6: php-8.0.0-embed.patch
+Patch6: php-8.4.0-embed.patch
Patch8: php-8.1.0-libdb.patch
-# RHEL backports
-Patch10: php-8.2.0-curl.patch
# Functional changes
# Use system nikic/php-parser
Patch41: php-8.3.3-parser.patch
# use system tzdata
-Patch43: php-8.3.0-systzdata-v24.patch
+Patch43: php-8.4.0-systzdata-v24.patch
# See http://bugs.php.net/53436
# + display PHP version backported from 8.4
-Patch44: php-7.4.0-phpize.patch
+Patch44: php-8.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
Patch45: php-7.4.0-ldap_r.patch
# Ignore unsupported "threads" option on password_hash
@@ -200,7 +149,6 @@ Patch47: php-8.1.0-phpinfo.patch
Patch48: php-8.3.0-openssl-ec-param.patch
# RC Patch
-Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
@@ -218,10 +166,8 @@ BuildRequires: pkgconfig(libcurl) >= 7.29.0
BuildRequires: libdb-devel
BuildRequires: httpd-devel >= 2.0.46-1
BuildRequires: pam-devel
-%if %{with_httpd2410}
# to ensure we are using httpd with filesystem feature (see #1081453)
BuildRequires: httpd-filesystem
-%endif
BuildRequires: %{?dtsprefix}libstdc++-devel
# no pkgconfig to avoid compat-openssl10
BuildRequires: openssl-devel >= 1.0.2
@@ -263,13 +209,8 @@ Requires: httpd-mmn = %{_httpd_mmn}
Provides: %{?scl_prefix}mod_php = %{version}-%{release}
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
# To ensure correct /var/lib/php/session ownership:
-%if %{with_httpd2410}
Requires(pre): httpd-filesystem
-%else
-Requires(pre): httpd
-%endif
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# For backwards-compatibility, pull the "php" command
Recommends: %{?scl_prefix}php-cli%{?_isa} = %{version}-%{release}
# httpd have threaded MPM by default
@@ -280,13 +221,6 @@ Recommends: %{?scl_prefix}php-opcache%{?_isa} = %{version}-%{release}
Recommends: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Recommends: %{?scl_prefix}php-sodium%{?_isa} = %{version}-%{release}
Recommends: %{?scl_prefix}php-xml%{?_isa} = %{version}-%{release}
-%else
-# For backwards-compatibility, require php-cli for the time being:
-Requires: %{?scl_prefix}php-cli%{?_isa} = %{version}-%{release}
-# For ARGON2 password
-Requires: %{?scl_prefix}php-sodium%{?_isa} = %{version}-%{release}
-%endif
-
# Don't provides extensions, or shared libraries (embedded)
%{?filter_from_requires: %filter_from_requires /libphp.*so/d}
@@ -339,15 +273,11 @@ Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
# is not valid. We can use %%post because this particular %%triggerun script
# should fire just after this package is installed.
Requires(post): systemd-sysv
-%if %{with_httpd2410}
# To ensure correct /var/lib/php/session ownership:
Requires(pre): httpd-filesystem
# For php.conf in /etc/httpd/conf.d
# and version 2.4.10 for proxy support in SetHandler
Requires: httpd-filesystem >= 2.4.10
-%else
-Requires(pre): %{_root_sbindir}/useradd
-%endif
%description fpm
PHP-FPM (FastCGI Process Manager) is an alternative PHP FastCGI
@@ -452,9 +382,7 @@ Requires: openssl-devel%{?_isa} >= 1.0.2
Requires: pcre2-devel%{?_isa} >= 10.30
%endif
Requires: zlib-devel%{?_isa}
-%if 0%{?fedora} || 0%{?rhel} >= 8
Recommends: php-nikic-php-parser5 >= 5.0.0
-%endif
%description devel
The %{?scl_prefix}php-devel package contains the files needed for building PHP
@@ -478,23 +406,6 @@ bytecode in the shared memory. This eliminates the stages of reading code from
the disk and compiling it on future access. In addition, it applies a few
bytecode optimization patterns that make code execution faster.
-%if %{with imap}
-%package imap
-Summary: A module for PHP applications that use IMAP
-# All files licensed under PHP version 3.01
-License: PHP-3.01
-Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(krb5)
-BuildRequires: pkgconfig(krb5-gssapi)
-BuildRequires: openssl-devel >= 1.0.2
-BuildRequires: libc-client-devel
-
-%description imap
-The %{?scl_prefix}php-imap module will add IMAP (Internet Message Access Protocol)
-support to PHP. IMAP is a protocol for retrieving and uploading e-mail
-messages on mail servers. PHP is an HTML-embedded scripting language.
-%endif
-
%package ldap
Summary: A module for PHP applications that use LDAP
# All files licensed under PHP version 3.01
@@ -639,43 +550,6 @@ Inprise Corp (now known as Borland Software Corp) under the InterBase Public
License.
%endif
-%if %{with oci8}
-%package oci8
-Summary: A module for PHP applications that use OCI8 databases
-# All files licensed under PHP version 3.01
-License: PHP-3.01
-%ifarch aarch64
-BuildRequires: oracle-instantclient%{oraclever}-devel
-# Should requires libclntsh.so.19.1()(aarch-64), but it's not provided by Oracle RPM.
-Requires: libclntsh.so.%{oraclelib}
-AutoReq: 0
-%else
-BuildRequires: oracle-instantclient-devel >= %{oraclever}
-%endif
-Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
-Provides: %{?scl_prefix}php_database
-Provides: %{?scl_prefix}php-pdo_oci
-Provides: %{?scl_prefix}php-pdo_oci%{?_isa}
-Obsoletes: %{?scl_prefix}php-pecl-oci8 <= %{oci8ver}
-Conflicts: %{?scl_prefix}php-pecl-oci8 > %{oci8ver}
-Provides: %{?scl_prefix}php-pecl(oci8) = %{oci8ver}
-Provides: %{?scl_prefix}php-pecl(oci8)%{?_isa} = %{oci8ver}
-
-%description oci8
-The %{?scl_prefix}php-oci8 packages provides the OCI8 extension version %{oci8ver}
-and the PDO driver to access Oracle Database.
-
-The extension is linked with Oracle client libraries %{oraclever}
-(Oracle Instant Client). For details, see Oracle's note
-"Oracle Client / Server Interoperability Support" (ID 207303.1).
-
-You must install libclntsh.so.%{oraclelib} to use this package,
-provided by Oracle Instant Client RPM available from Oracle on:
-https://www.oracle.com/database/technologies/instant-client/downloads.html
-
-Documentation is at http://php.net/oci8 and http://php.net/pdo_oci
-%endif
-
%package snmp
Summary: A module for PHP applications that query SNMP-managed devices
# All files licensed under PHP version 3.01
@@ -824,17 +698,6 @@ that implements the PHP Data Objects (PDO) interface to enable access from
PHP to Microsoft SQL Server and Sybase databases through the FreeTDS library.
%endif
-%package pspell
-Summary: A module for PHP applications for using pspell interfaces
-# All files licensed under PHP version 3.01
-License: PHP-3.01
-Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: aspell-devel >= 0.50.0
-
-%description pspell
-The %{?scl_prefix}php-pspell package contains a dynamic shared object that will add
-support for using the pspell library to PHP.
-
%package intl
Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
@@ -914,15 +777,9 @@ in pure PHP.
%if %{with lsws}
: With Litespeed SAPI
%endif
-%if %{with oci8}
-: With Oracle extensions
-%endif
%if %{with enchant}
: With Enchant extensions
%endif
-%if %{with imap}
-: With Imap extensions
-%endif
%if %{with firebird}
: With pdo_firebird extension
%endif
@@ -971,9 +828,6 @@ in pure PHP.
%patch -P5 -p1 -b .includedir
%patch -P6 -p1 -b .embed
%patch -P8 -p1 -b .libdb
-%if 0%{?rhel} == 7
-%patch -P10 -p1 -b .curltls
-%endif
%patch -P41 -p1 -b .syslib
%if %{with tzdata}
@@ -986,8 +840,6 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch -P47 -p1 -b .phpinfo
%patch -P48 -p1 -b .ec-param
-%patch -P91 -p1 -b .remi-oci8
-
# upstream patches
# security patches
@@ -1071,14 +923,6 @@ if test "x${vpdo}" != "x%{pdover}"; then
exit 1
fi
-# Check for some extension version
-ver=$(sed -n '/#define PHP_OCI8_VERSION /{s/.* "//;s/".*$//;p}' ext/oci8/php_oci8.h)
-if test "$ver" != "%{oci8ver}"; then
- : Error: Upstream OCI8 version is now ${ver}, expecting %{oci8ver}.
- : Update the oci8ver macro and rebuild.
- exit 1
-fi
-
# https://bugs.php.net/63362 - Not needed but installed headers.
# Drop some Windows specific headers to avoid installation,
# before build to ensure they are really not needed.
@@ -1103,14 +947,12 @@ sed -e "s/@PHP_APIVER@/%{apiver}-%{__isa_bits}/" \
-e "s:@ETCDIR@:%{_sysconfdir}:" \
-e "s:@INCDIR@:%{_includedir}:" \
-e "s:@BINDIR@:%{_bindir}:" \
+ -e "s:@STATEDIR@:%{_localstatedir}:" \
-e "s:@SCL@:%{?scl:%{scl}_}:" \
%{SOURCE3} | tee macros.php
-%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
-echo '%%%{?scl:%{scl}_}pecl_xmldir %{_localstatedir}/lib/php/peclxml' | tee -a macros.php
-%endif
# Some extensions have their own configuration file
-cp %{SOURCE50} %{SOURCE51} %{SOURCE52} %{SOURCE53} .
+cp %{SOURCE50} %{SOURCE51} %{SOURCE53} .
sed -e 's:%{_root_sysconfdir}:%{_sysconfdir}:' \
-i 10-opcache.ini
@@ -1205,7 +1047,6 @@ ln -sf ../configure
%endif
--with-zlib \
--with-layout=GNU \
- --with-kerberos \
--with-libxml \
%if %{with tzdata}
--with-system-tzdata \
@@ -1235,9 +1076,6 @@ build --libdir=%{_libdir}/php \
--enable-opcache-file \
--with-capstone \
--enable-phpdbg \
-%if %{with imap}
- --with-imap=shared --with-imap-ssl \
-%endif
--enable-mbstring=shared \
--enable-mbregex \
--enable-gd=shared \
@@ -1269,10 +1107,6 @@ build --libdir=%{_libdir}/php \
--enable-mysqlnd=shared \
--with-mysqli=shared,mysqlnd \
--with-mysql-sock=%{mysql_sock} \
-%if %{with oci8}
- --with-oci8=shared,instantclient,%{_root_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
- --with-pdo-oci=shared,instantclient,%{_root_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
-%endif
%if %{with firebird}
--with-pdo-firebird=shared \
%endif
@@ -1300,7 +1134,6 @@ build --libdir=%{_libdir}/php \
%endif
--without-readline \
--with-libedit \
- --with-pspell=shared \
--enable-phar=shared \
%if %{with tidy}
--with-tidy=shared,%{_root_prefix} \
@@ -1329,7 +1162,6 @@ without_shared="--disable-gd \
--disable-xmlreader --disable-xmlwriter \
--without-sodium \
--without-sqlite3 --disable-phar --disable-fileinfo \
- --without-pspell \
--without-curl --disable-posix --disable-xml \
--disable-simplexml --disable-exif --without-gettext \
--without-iconv --disable-ftp --without-bz2 --disable-ctype \
@@ -1439,9 +1271,7 @@ cp %{SOURCE9} modconf
# Dual config file with httpd >= 2.4 (RHEL >= 7)
install -D -m 644 modconf $RPM_BUILD_ROOT%{_httpd_modconfdir}/20-%{name}.conf
install -D -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
-%if %{with_httpd2410}
cat %{SOURCE10} >>$RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
-%endif
sed -e 's:/var/lib:%{_localstatedir}/lib:' \
-i $RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
@@ -1451,11 +1281,9 @@ install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/session
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/wsdlcache
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/opcache
-%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/peclxml
install -m 755 -d $RPM_BUILD_ROOT%{_docdir}/pecl
install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/tests/pecl
-%endif
%if %{with lsws}
install -m 755 build-apache/sapi/litespeed/php $RPM_BUILD_ROOT%{_bindir}/lsphp
@@ -1483,11 +1311,9 @@ mv $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.d/www.conf.default .
# install -m 644 php-fpm.tmpfiles $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d/php-fpm.conf
# install systemd unit files and scripts for handling server startup
install -Dm 644 %{SOURCE6} $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/httpd.service.d/%{?scl_prefix}php-fpm.conf
install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/nginx.service.d/%{?scl_prefix}php-fpm.conf
sed -e 's/php-fpm/%{?scl_prefix}php-fpm/' -i $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/*.service.d/%{?scl_prefix}php-fpm.conf
-%endif
sed -e 's:/run:%{_localstatedir}/run:' \
-e 's:/etc/sysconfig:%{_sysconfdir}/sysconfig:' \
-e 's:php-fpm.service:%{?scl_prefix}php-fpm.service:' \
@@ -1496,7 +1322,6 @@ sed -e 's:/run:%{_localstatedir}/run:' \
# this folder requires systemd >= 204
install -m 755 -d $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/%{?scl_prefix}php-fpm.service.d
-%if %{with_httpd2410}
# Switch to UDS
# FPM
sed -e 's@127.0.0.1:9000@%{_localstatedir}/run/php-fpm/www.sock@' \
@@ -1505,7 +1330,6 @@ sed -e 's@127.0.0.1:9000@%{_localstatedir}/run/php-fpm/www.sock@' \
# Apache
sed -e 's@proxy:fcgi://127.0.0.1:9000@proxy:unix:%{_localstatedir}/run/php-fpm/www.sock|fcgi://localhost@' \
-i $RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
-%endif
# LogRotate
install -m 755 -d $RPM_BUILD_ROOT%{_root_sysconfdir}/logrotate.d
@@ -1514,16 +1338,6 @@ sed -e 's:/run:%{_localstatedir}/run:' \
-e 's:/var/log:%{_localstatedir}/log:' \
-i $RPM_BUILD_ROOT%{_root_sysconfdir}/logrotate.d/%{?scl_prefix}php-fpm
-# Environment file
-%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
-sed -e '/EnvironmentFile/d' -i $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
-%else
-install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
-install -m 644 %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/php-fpm
-sed -e 's:php-fpm.service:%{?scl_prefix}php-fpm.service:' \
- -i $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/php-fpm
-%endif
-
# make the cli commands available in standard root for SCL build
%if 0%{?scl:1}
install -m 755 -d $RPM_BUILD_ROOT%{_root_bindir}
@@ -1548,9 +1362,6 @@ TESTCMD="$TESTCMD --define extension_dir=$RPM_BUILD_ROOT%{_libdir}/php/modules"
# Generate files lists and stub .ini files for each subpackage
for mod in pgsql odbc ldap snmp \
mysqlnd mysqli \
-%if %{with imap}
- imap \
-%endif
mbstring gd dom xsl soap bcmath dba \
simplexml bz2 calendar ctype exif ftp gettext gmp iconv \
tokenizer opcache \
@@ -1570,12 +1381,9 @@ for mod in pgsql odbc ldap snmp \
zip \
%endif
sodium \
- pspell curl xml \
+ curl xml \
posix shmop sysvshm sysvsem sysvmsg \
pdo_mysql pdo_pgsql pdo_odbc pdo_sqlite \
-%if %{with oci8}
- oci8 pdo_oci \
-%endif
%if %{with firebird}
pdo_firebird \
%endif
@@ -1629,9 +1437,6 @@ cat files.mysqli \
# Split out the PDO modules
cat files.pdo_pgsql >> files.pgsql
cat files.pdo_odbc >> files.odbc
-%if %{with oci8}
-cat files.pdo_oci >> files.oci8
-%endif
# sysv* and posix in packaged in php-process
cat files.shmop files.sysv* files.posix > files.process
@@ -1667,33 +1472,15 @@ rm -rf $RPM_BUILD_ROOT%{_libdir}/php/modules/*.a \
rm -f README.{Zeus,QNX,CVS-RULES}
-%if ! %{with_httpd2410}
-%pre fpm
-# Add the "apache" user (to avoid pulling httpd in our dep)
-getent group apache >/dev/null || \
- groupadd -g 48 -r apache
-getent passwd apache >/dev/null || \
- useradd -r -u 48 -g apache -s /sbin/nologin \
- -d %{_httpd_contentdir} -c "Apache" apache
-exit 0
-%endif
-
%post fpm
%systemd_post %{?scl:%{scl}-}php-fpm.service
%preun fpm
%systemd_preun %{?scl:%{scl}-}php-fpm.service
-%if 0%{?fedora} < 27 && 0%{?rhel} < 8
-%postun fpm
-%systemd_postun_with_restart %{?scl:%{scl}-}php-fpm.service
-%endif
-
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# Raised by new pool installation or new extension installation
%transfiletriggerin fpm -- %{_sysconfdir}/php-fpm.d %{_sysconfdir}/php.d
systemctl try-restart %{?scl:%{scl}-}php-fpm.service >/dev/null 2>&1 || :
-%endif
# Handle upgrading from SysV initscript to native systemd unit.
# We can tell if a SysV version of php-fpm was previously installed by
@@ -1711,14 +1498,6 @@ if [ -f /etc/rc.d/init.d/%{?scl_prefix}php-fpm ]; then
fi
-%if 0%{?fedora} < 28 && 0%{?rhel} < 8
-%post embedded -p /sbin/ldconfig
-%postun embedded -p /sbin/ldconfig
-%endif
-
-
-%{!?_licensedir:%global license %%doc}
-
%files
%{_httpd_moddir}/libphp.so
%if 0%{?scl:1}
@@ -1744,12 +1523,10 @@ fi
%dir %{_libdir}/php/modules
%dir %{_localstatedir}/lib/php
%dir %{_datadir}/php
-%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
%dir %{_localstatedir}/lib/php/peclxml
%dir %{_docdir}/pecl
%dir %{_datadir}/tests
%dir %{_datadir}/tests/pecl
-%endif
%files cli
%{_bindir}/php
@@ -1783,22 +1560,15 @@ fi
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/session
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/wsdlcache
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/opcache
-%if %{with_httpd2410}
%config(noreplace) %{_httpd_confdir}/%{name}.conf
-%endif
%config(noreplace) %{_sysconfdir}/php-fpm.conf
%config(noreplace) %{_sysconfdir}/php-fpm.d/www.conf
%config(noreplace) %{_root_sysconfdir}/logrotate.d/%{?scl_prefix}php-fpm
-%if 0%{?fedora} < 26 && 0%{?rhel} < 8
-%config(noreplace) %{_sysconfdir}/sysconfig/php-fpm
-%endif
# {_prefix}/lib/tmpfiles.d/php-fpm.conf
%{_unitdir}/%{?scl_prefix}php-fpm.service
%dir %{_root_sysconfdir}/systemd/system/%{?scl_prefix}php-fpm.service.d
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
%config(noreplace) %{_root_sysconfdir}/systemd/system/httpd.service.d/%{?scl_prefix}php-fpm.conf
%config(noreplace) %{_root_sysconfdir}/systemd/system/nginx.service.d/%{?scl_prefix}php-fpm.conf
-%endif
%{_sbindir}/php-fpm
%dir %{_sysconfdir}/php-fpm.d
# log owned by apache for log
@@ -1829,9 +1599,6 @@ fi
%files pgsql -f files.pgsql
%files odbc -f files.odbc
-%if %{with imap}
-%files imap -f files.imap
-%endif
%files ldap -f files.ldap
%files snmp -f files.snmp
%files xml -f files.xml
@@ -1850,7 +1617,6 @@ fi
%if %{with freetds}
%files pdo-dblib -f files.pdo_dblib
%endif
-%files pspell -f files.pspell
%files intl -f files.intl
%files process -f files.process
%if %{with firebird}
@@ -1862,9 +1628,6 @@ fi
%files mysqlnd -f files.mysqlnd
%files opcache -f files.opcache
%config(noreplace) %{_sysconfdir}/php.d/opcache-default.blacklist
-%if %{with oci8}
-%files oci8 -f files.oci8
-%endif
%if %{with zip}
%files zip -f files.zip
%endif
@@ -1874,6 +1637,10 @@ fi
%changelog
+* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 8.4.0~alpha1-1
+- Update to 8.4.0alpha1
+- drop imap, pspell, oci8 and pdo_oci extensions
+
* Wed Jul 3 2024 Remi Collet <remi@remirepo.net> - 8.3.9-1
- Update to 8.3.9 - http://www.php.net/releases/8_3_9.php