summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README14
-rw-r--r--macros-build4
-rw-r--r--php82.spec13
3 files changed, 23 insertions, 8 deletions
diff --git a/README b/README
index 98cb9ef..b903c7e 100644
--- a/README
+++ b/README
@@ -23,12 +23,13 @@ which adds support for the PHP language to Apache HTTP server.
The %{?scl_prefix}php-fpm package provides the FastCGI process manager
which adds support for the PHP language to FastCGI compatible servers.
-FastCGI process manager (php-fpm) listens on local network soket
-(by default port 9000).
+FastCGI process manager (php-fpm) listens on local network soket.
When working with %{scl_name} collection, use the "scl" utility (see
scl(1) for usage) to enable the scl environment properly.
+You can alternatively use the "module" utility (see module(1) for usage).
+
Configuration for the %{scl_name} software collection is located under %{_sysconfdir}.
Examples:
@@ -46,9 +47,16 @@ scl enable %{scl_name} 'man php'
Show man pages for php command, which is part of the %{scl_name} software
collection.
+module load %{scl_name}
+ Enable %{scl_name} software collection in current interactive shell.
+
+module unload %{scl_name}
+ Disable %{scl_name} software collection in current interactive shell.
+
+
%if 0%{?rhel} >= 7
systemctl start %{?scl_prefix}php-fpm
%else
service %{?scl_prefix}php-fpm start
%endif
- Starts the php-fpm server from %{scl_name} software collection. \ No newline at end of file
+ Starts the php-fpm server from %{scl_name} software collection.
diff --git a/macros-build b/macros-build
index 03ff02d..ba4632d 100644
--- a/macros-build
+++ b/macros-build
@@ -1,4 +1,6 @@
-%_sclreq (%{scl_vendor})
+%scl_vendor @VENDOR@
+%_scl_prefix @PREFIX@
+%_sclreq (@VENDOR@)
%scl_package_override() %{expand:
%{?@SCL@___pear:%global __pear %@SCL@___pear}
diff --git a/php82.spec b/php82.spec
index 4489335..f2ae82e 100644
--- a/php82.spec
+++ b/php82.spec
@@ -26,7 +26,7 @@
Summary: Package that installs PHP 8.2
Name: %scl_name
Version: 8.2
-Release: 2%{?dist}
+Release: 3%{?dist}
License: GPLv2+
Source0: macros-build
@@ -174,7 +174,7 @@ help2man -N --section 7 ./h2m_helper -o %{scl_name}.7
install -D -m 644 enable %{buildroot}%{_scl_scripts}/enable
install -D -m 644 envmod %{buildroot}%{_root_datadir}/Modules/modulefiles/%{scl_name}
install -D -m 644 scldev %{buildroot}%{macrosdir}/macros.%{scl_name_base}-scldevel
-install -D -m 644 %{scl_name}.7 %{buildroot}%{_mandir}/man7/%{scl_name}.7
+install -D -m 644 %{scl_name}.7 %{buildroot}%{_root_mandir}/man7/%{scl_name}.7
install -d -m 755 %{buildroot}%{_datadir}/licenses
install -d -m 755 %{buildroot}%{_datadir}/doc/pecl
@@ -186,7 +186,7 @@ install -d -m 755 %{buildroot}%{_localstatedir}/lib/pear/pkgxml
cat %{buildroot}%{_root_sysconfdir}/rpm/macros.%{scl}-config
# Add the scl_package_override macro
-sed -e 's/@SCL@/%{scl}/g' %{SOURCE0} \
+sed -e 's/@SCL@/%{scl}/g;s:@PREFIX@:/opt/%{scl_vendor}:;s/@VENDOR@/%{scl_vendor}/' %{SOURCE0} \
| tee -a %{buildroot}%{_root_sysconfdir}/rpm/macros.%{scl}-config
# Move in correct location, if needed
@@ -233,7 +233,7 @@ restorecon -R %{_localstatedir} &>/dev/null || :
%license LICENSE
%doc README
%scl_files
-%{_mandir}/man7/%{scl_name}.*
+%{_root_mandir}/man7/%{scl_name}.*
%{?_licensedir:%{_datadir}/licenses}
%{_datadir}/tests
%{_root_datadir}/Modules/modulefiles/%{scl_name}
@@ -259,6 +259,11 @@ restorecon -R %{_localstatedir} &>/dev/null || :
%changelog
+* Thu Mar 9 2023 Remi Collet <remi@remirepo.net> 8.2-3
+- define %%scl_vendor and %%_scl_prefix in macros.php81-config
+- move man page out of scl tree
+- improve the man page
+
* Wed Jun 22 2022 Remi Collet <remi@remirepo.net> 8.2-2
- php82-syspaths conflicts with php81-syspaths