summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec254
1 files changed, 136 insertions, 118 deletions
diff --git a/php.spec b/php.spec
index ea067a9..c52f459 100644
--- a/php.spec
+++ b/php.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for php80-php
+# remirepo spec file for php82-php
# with SCL and backport stuff, adapted from
#
# Fedora spec file for php
@@ -23,17 +23,17 @@
%endif
# API/ABI check
-%global apiver 20200930
-%global zendver 20200930
+%global apiver 20210903
+%global zendver 20210903
%global pdover 20170320
# Extension version
-%global oci8ver 3.0.1
+%global oci8ver 3.2.1
# Adds -z now to the linker flags
%global _hardened_build 1
# version used for php embedded library soname
-%global embed_version 8.0
+%global embed_version 8.2
# Ugly hack. Harcoded values to avoid relocation.
%global _httpd_mmn %(cat %{_root_includedir}/httpd/.mmn 2>/dev/null || echo 0)
@@ -102,6 +102,14 @@
# build with system libgd (gd-last in remi repo)
%bcond_without libgd
+# build with system tzdata (2021 required)
+%if 0%{?fedora} >= 33 || 0%{?rhel} >= 7
+%bcond_without tzdata
+%else
+%bcond_with tzdata
+%endif
+
+
# httpd 2.4.10 with httpd-filesystem and sethandler support
%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
%global with_httpd2410 1
@@ -109,17 +117,18 @@
%global with_httpd2410 0
%endif
-%global gh_commit 18f2ef094af2b1ad961408fbaf222b9448df2750
+%global gh_commit f080a90a884197c30688c7c61920dd881b531f66
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_date 20200615
+%global gh_date 20220511
%global gh_owner php
%global gh_project php-src
-%global upver 8.0.19
-#global rcver RC1
+%global upver 8.2.0
+%global rcver -dev
+%global lower DEV
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
+Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -127,7 +136,8 @@ Release: 1%{?dist}
# main/snprintf.c, main/spprintf.c and main/rfc1867.c are ASL 1.0
# ext/date/lib is MIT
# Zend/zend_sort is NCSA
-License: PHP and Zend and BSD and MIT and ASL 1.0 and NCSA
+# Zend/asm is Boost
+License: PHP and Zend and BSD and MIT and ASL 1.0 and NCSA and Boost
URL: http://www.php.net/
%if 0%{?gh_date}
@@ -159,35 +169,24 @@ Source53: 20-ffi.ini
Patch1: php-7.4.0-httpd.patch
Patch5: php-7.2.0-includedir.patch
Patch6: php-8.0.0-embed.patch
-Patch8: php-7.4.0-libdb.patch
-# get rid of deprecated functions from 8.1
-Patch9: php-8.0.6-deprecated.patch
+Patch8: php-8.1.0-libdb.patch
# RHEL backports
Patch10: php-7.0.7-curl.patch
# Functional changes
# Use system nikic/php-parser
-Patch41: php-8.0.19-parser.patch
+Patch41: php-8.2.0-parser.patch
# use system tzdata
-Patch42: php-8.0.10-systzdata-v21.patch
+Patch43: php-8.1.0-systzdata-v22.patch
# See http://bugs.php.net/53436
-Patch43: php-7.4.0-phpize.patch
+Patch44: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
Patch45: php-7.4.0-ldap_r.patch
# Ignore unsupported "threads" option on password_hash
Patch46: php-8.0.7-argon2.patch
# drop "Configure command" from phpinfo output
# and only use gcc (instead of full version)
-Patch47: php-8.0.0-phpinfo.patch
-# add sha256 / sha512 security protocol, from 8.1
-Patch48: php-8.0.10-snmp-sha.patch
-# switch phar to use sha256 signature by default, from 8.1
-# implement openssl_256 and openssl_512 for phar signatures, from 8.1
-Patch49: php-8.0.10-phar-sha.patch
-# compatibility with OpenSSL 3.0, from 8.1
-Patch50: php-8.0.10-openssl3.patch
-# use system libxcrypt, from 8.1
-Patch51: php-8.0.13-crypt.patch
+Patch47: php-8.1.0-phpinfo.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
@@ -214,7 +213,7 @@ BuildRequires: httpd-filesystem
%endif
BuildRequires: %{?dtsprefix}libstdc++-devel
# no pkgconfig to avoid compat-openssl10
-BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: openssl-devel >= 1.0.2
BuildRequires: pkgconfig(sqlite3) >= 3.7.4
BuildRequires: pkgconfig(zlib) >= 1.2.0.4
BuildRequires: smtpdaemon
@@ -245,6 +244,9 @@ BuildRequires: re2c
%endif
# used for tests
BuildRequires: /bin/ps
+%if %{with tzdata}
+BuildRequires: tzdata
+%endif
Requires: httpd-mmn = %{_httpd_mmn}
Provides: %{?scl_prefix}mod_php = %{version}-%{release}
@@ -296,7 +298,7 @@ which adds support for the PHP language to system Apache HTTP Server.
%package cli
Summary: Command-line interface for PHP
# sapi/cli/ps_title.c is PostgreSQL
-License: PHP and Zend and BSD and MIT and ASL 1.0 and NCSA and PostgreSQL
+License: PHP and Zend and BSD and MIT and ASL 1.0 and NCSA and Boost and PostgreSQL
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php-cgi = %{version}-%{release}, %{?scl_prefix}php-cgi%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php-pcntl, %{?scl_prefix}php-pcntl%{?_isa}
@@ -319,6 +321,7 @@ The %{?scl_prefix}php-dbg package contains the interactive PHP debugger.
Summary: PHP FastCGI Process Manager
BuildRequires: libacl-devel
BuildRequires: pkgconfig(libsystemd) >= 209
+BuildRequires: pkgconfig(libselinux)
Requires(pre): %{_root_sbindir}/useradd
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
%{?systemd_requires}
@@ -422,13 +425,13 @@ Requires: libtool
# see "php-config --libs"
Requires: krb5-devel%{?_isa}
Requires: libxml2-devel%{?_isa}
-Requires: openssl-devel%{?_isa} >= 1.0.1
+Requires: openssl-devel%{?_isa} >= 1.0.2
%if %{with libpcre}
Requires: pcre2-devel%{?_isa} >= 10.30
%endif
Requires: zlib-devel%{?_isa}
%if 0%{?fedora} || 0%{?rhel} >= 8
-Recommends: php-nikic-php-parser4 >= 4.13.0
+Recommends: php-nikic-php-parser4 >= 4.13.1
%endif
%description devel
@@ -460,7 +463,7 @@ License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
BuildRequires: pkgconfig(krb5)
BuildRequires: pkgconfig(krb5-gssapi)
-BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: openssl-devel >= 1.0.2
BuildRequires: libc-client-devel
%description imap
@@ -476,7 +479,7 @@ License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
BuildRequires: pkgconfig(libsasl2)
BuildRequires: openldap-devel
-BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: openssl-devel >= 1.0.2
%description ldap
The %{?scl_prefix}php-ldap package adds Lightweight Directory Access Protocol (LDAP)
@@ -530,7 +533,7 @@ Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
Provides: %{?scl_prefix}php-pdo_pgsql, %{?scl_prefix}php-pdo_pgsql%{?_isa}
BuildRequires: krb5-devel
-BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: openssl-devel >= 1.0.2
BuildRequires: postgresql-devel
%description pgsql
@@ -721,6 +724,7 @@ BuildRequires: pkgconfig(libpng)
BuildRequires: pkgconfig(freetype2)
BuildRequires: pkgconfig(xpm)
BuildRequires: pkgconfig(libwebp)
+BuildRequires: pkgconfig(libavif)
Provides: bundled(gd) = 2.0.35
%endif
@@ -761,6 +765,7 @@ BuildRequires: lmdb-devel
%if %{with qdbm}
BuildRequires: qdbm-devel
%endif
+
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
%description dba
@@ -942,29 +947,21 @@ in pure PHP.
%patch5 -p1 -b .includedir
%patch6 -p1 -b .embed
%patch8 -p1 -b .libdb
-%patch9 -p1 -b .deprecated
%if 0%{?rhel}
%patch10 -p1 -b .curltls
%endif
%patch41 -p1 -b .syslib
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 6
-%patch42 -p1 -b .systzdata
+%if %{with tzdata}
+%patch43 -p1 -b .systzdata
%endif
-%patch43 -p1 -b .headers
+%patch44 -p1 -b .headers
sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
%patch45 -p1 -b .ldap_r
%endif
%patch46 -p1 -b .argon2
%patch47 -p1 -b .phpinfo
-%patch48 -p1 -b .sha
-%patch49 -p1 -b .pharsha
-%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9
-%patch50 -p1 -b .openssl3
-rm ext/openssl/tests/p12_with_extra_certs.p12
-%endif
-%patch51 -p1 -b .libxcrypt
%patch91 -p1 -b .remi-oci8
@@ -979,6 +976,7 @@ rm ext/openssl/tests/p12_with_extra_certs.p12
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE ZEND_LICENSE
+cp Zend/asm/LICENSE BOOST_LICENSE
cp TSRM/LICENSE TSRM_LICENSE
cp sapi/fpm/LICENSE fpm_LICENSE
cp ext/mbstring/libmbfl/LICENSE libmbfl_LICENSE
@@ -995,12 +993,9 @@ mkdir \
# ----- Manage known as failed test -------
# affected by systzdata patch
+%if %{with tzdata}
rm ext/date/tests/timezone_location_get.phpt
-%if 0%{?fedora} < 28
-# need tzdata 2018i
-rm ext/date/tests/bug33414-1.phpt
-rm ext/date/tests/bug33415-2.phpt
-rm ext/date/tests/date_modify-1.phpt
+rm ext/date/tests/bug80963.phpt
%endif
# too fast builder
rm ext/date/tests/bug73837.phpt
@@ -1181,7 +1176,7 @@ ln -sf ../configure
--with-layout=GNU \
--with-kerberos \
--with-libxml \
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 6
+%if %{with tzdata}
--with-system-tzdata \
%endif
--with-mhash \
@@ -1325,6 +1320,7 @@ popd
pushd build-fpm
build --enable-fpm \
--with-fpm-systemd \
+ --with-fpm-selinux \
--with-fpm-acl \
--libdir=%{_libdir}/php \
--without-mysqli \
@@ -1706,7 +1702,7 @@ fi
%files common -f files.common
%doc EXTENSIONS NEWS UPGRADING* README.REDIST.BINS *md docs
-%license LICENSE TSRM_LICENSE ZEND_LICENSE
+%license LICENSE TSRM_LICENSE ZEND_LICENSE BOOST_LICENSE
%license libmagic_LICENSE
%license timelib_LICENSE
%doc php.ini-*
@@ -1846,107 +1842,129 @@ fi
%changelog
-* Tue May 10 2022 Remi Collet <remi@remirepo.net> - 8.0.19-1
-- Update to 8.0.19 - http://www.php.net/releases/8_0_19.php
+* Wed May 11 2022 Remi Collet <remi@remirepo.net> - 8.2.0~DEV.20220511-1
+- update to 8.2.0-dev
+- add dependency on libselinux
+
+* Wed May 11 2022 Remi Collet <remi@remirepo.net> - 8.1.6-1
+- Update to 8.1.6 - http://www.php.net/releases/8_1_6.php
- use oracle client library version 21.6
-* Tue Apr 26 2022 Remi Collet <remi@remirepo.net> - 8.0.19~RC1-1
-- update to 8.0.19RC1
+* Wed Apr 27 2022 Remi Collet <remi@remirepo.net> - 8.1.6~RC1-1
+- update to 8.1.6RC1
-* Wed Apr 13 2022 Remi Collet <remi@remirepo.net> - 8.0.18-1
-- Update to 8.0.18 - http://www.php.net/releases/8_0_18.php
+* Wed Apr 13 2022 Remi Collet <remi@remirepo.net> - 8.1.5-1
+- Update to 8.1.5 - http://www.php.net/releases/8_1_5.php
-* Thu Mar 31 2022 Remi Collet <remi@remirepo.net> - 8.0.18~RC1-1
-- update to 8.0.18RC1
+* Fri Apr 1 2022 Remi Collet <remi@remirepo.net> - 8.1.5~RC1-1
+- update to 8.1.5RC1
-* Tue Mar 15 2022 Remi Collet <remi@remirepo.net> - 8.0.17-1
-- Update to 8.0.17 - http://www.php.net/releases/8_0_17.php
+* Wed Mar 16 2022 Remi Collet <remi@remirepo.net> - 8.1.4-1
+- Update to 8.1.4 - http://www.php.net/releases/8_1_4.php
-* Wed Mar 2 2022 Remi Collet <remi@remirepo.net> - 8.0.17~RC1-1
-- update to 8.0.17RC1
+* Thu Mar 3 2022 Remi Collet <remi@remirepo.net> - 8.1.4~RC1-1
+- update to 8.1.4RC1
-* Tue Feb 22 2022 Remi Collet <remi@remirepo.net> - 8.0.16-2
+* Tue Feb 22 2022 Remi Collet <remi@remirepo.net> - 8.1.3-2
- retrieve tzdata version
- use oracle client library version 21.5
-* Wed Feb 16 2022 Remi Collet <remi@remirepo.net> - 8.0.16-1
-- Update to 8.0.16 - http://www.php.net/releases/8_0_16.php
+* Wed Feb 16 2022 Remi Collet <remi@remirepo.net> - 8.1.3-1
+- Update to 8.1.3 - http://www.php.net/releases/8_1_3.php
-* Thu Feb 3 2022 Remi Collet <remi@remirepo.net> - 8.0.16~RC1-1
-- update to 8.0.16RC1
+* Tue Feb 8 2022 Remi Collet <remi@remirepo.net> - 8.1.3~RC1-2
+- fix GH-8059 arginfo not regenerated for extension
-* Tue Jan 18 2022 Remi Collet <remi@remirepo.net> - 8.0.15-1
-- Update to 8.0.15 - http://www.php.net/releases/8_0_15.php
+* Thu Feb 3 2022 Remi Collet <remi@remirepo.net> - 8.1.3~RC1-1
+- update to 8.1.3RC1
-* Wed Jan 5 2022 Remi Collet <remi@remirepo.net> - 8.0.15~RC1-1
-- update to 8.0.15RC1
+* Wed Jan 19 2022 Remi Collet <remi@remirepo.net> - 8.1.2-1
+- Update to 8.1.2 - http://www.php.net/releases/8_1_2.php
+- Fix GH-7899 Regression in unpack for negative int value
+- Fix GH-7883 Segfault when INI file is not readable
-* Thu Dec 16 2021 Remi Collet <remi@remirepo.net> - 8.0.14-1
-- Update to 8.0.14 - http://www.php.net/releases/8_0_14.php
+* Wed Jan 5 2022 Remi Collet <remi@remirepo.net> - 8.1.2~RC1-1
+- update to 8.1.2RC1
-* Thu Dec 2 2021 Remi Collet <remi@remirepo.net> - 8.0.14~RC1-2
-- ensure we use libgd >= 2.3
+* Wed Dec 15 2021 Remi Collet <remi@remirepo.net> - 8.1.1-1
+- Update to 8.1.1 - http://www.php.net/releases/8_1_1.php
-* Thu Dec 2 2021 Remi Collet <remi@remirepo.net> - 8.0.14~RC1-1
-- update to 8.0.14RC1
+* Thu Dec 2 2021 Remi Collet <remi@remirepo.net> - 8.1.1~RC1-1
+- update to 8.1.1RC1
- use oracle client library version 21.4
+- ensure libgd 2.3 is used
-* Wed Nov 17 2021 Remi Collet <remi@remirepo.net> - 8.0.13-1
-- Update to 8.0.13 - http://www.php.net/releases/8_0_13.php
+* Wed Nov 24 2021 Remi Collet <remi@remirepo.net> - 8.1.0-1
+- update to 8.1.0 GA
-* Wed Nov 3 2021 Remi Collet <remi@remirepo.net> - 8.0.13~RC1-1
-- update to 8.0.13RC1
+* Wed Nov 10 2021 Remi Collet <remi@remirepo.net> - 8.1.0~rc6-1
+- update to 8.1.0RC6
-* Tue Oct 26 2021 Remi Collet <remi@remirepo.net> - 8.0.12-3
+* Tue Oct 26 2021 Remi Collet <remi@remirepo.net> - 8.1.0~rc5-1
+- update to 8.1.0RC5
+- build using system libxcrypt (Fedora only)
+
+* Tue Oct 26 2021 Remi Collet <remi@remirepo.net> - 8.1.0~rc4-2
- dba: enable qdbm backend
-* Tue Oct 26 2021 Remi Collet <remi@remirepo.net> - 8.0.12-2
-- add patch for OpenSSL 3.0 on F36 and EL9
+* Wed Oct 13 2021 Remi Collet <remi@remirepo.net> - 8.1.0~rc4-1
+- update to 8.1.0RC4
+
+* Fri Oct 1 2021 Remi Collet <remi@remirepo.net> - 8.1.0~rc3-3
+- rebuild using ICU 69
-* Tue Oct 19 2021 Remi Collet <remi@remirepo.net> - 8.0.12-1
-- Update to 8.0.12 - http://www.php.net/releases/8_0_12.php
+* Wed Sep 29 2021 Remi Collet <remi@remirepo.net> - 8.1.0~rc3-1
+- update to 8.1.0RC3
-* Mon Oct 18 2021 Remi Collet <remi@remirepo.net> - 8.0.12~RC1-2
-- build using system libxcrypt (Fedora)
+* Sat Sep 18 2021 Remi Collet <remi@remirepo.net> - 8.1.0~rc2-1
+- update to 8.1.0RC2
+- use oracle client library version 21.3
-* Wed Oct 6 2021 Remi Collet <remi@remirepo.net> - 8.0.12~RC1-1
-- update to 8.0.12RC1
-- use libicu version 69
+* Wed Sep 1 2021 Remi Collet <remi@remirepo.net> - 8.1.0~rc1-2
+- rebuild with new sources
-* Wed Sep 22 2021 Remi Collet <remi@remirepo.net> - 8.0.11-1
-- Update to 8.0.11 - http://www.php.net/releases/8_0_11.php
+* Wed Sep 1 2021 Remi Collet <remi@remirepo.net> - 8.1.0~rc1-1
+- update to 8.1.0RC1
+- bump API version
-* Tue Sep 7 2021 Remi Collet <remi@remirepo.net> - 8.0.11~RC1-1
-- update to 8.0.11RC1
-- use oracle client library version 21.3
+* Mon Aug 23 2021 Remi Collet <remi@remirepo.net> - 8.1.0~beta3-1
+- update to 8.1.0beta3
+
+* Mon Aug 9 2021 Remi Collet <remi@remirepo.net> - 8.1.0~DEV.20210809-1
+- test build
+
+* Tue Aug 3 2021 Remi Collet <remi@remirepo.net> - 8.1.0~beta2-1
+- update to 8.1.0beta2
+- oci8 version is now 3.1.0
-* Tue Aug 24 2021 Remi Collet <remi@remirepo.net> - 8.0.10-1
-- Update to 8.0.10 - http://www.php.net/releases/8_0_10.php
+* Wed Jul 21 2021 Remi Collet <remi@remirepo.net> - 8.1.0~beta1-1
+- update to 8.1.0beta1
-* Wed Aug 11 2021 Remi Collet <remi@remirepo.net> - 8.0.10~RC1-2
-- phar: switch to sha256 signature by default, backported from 8.1
-- phar: implement openssl_256 and openssl_512 for signatures, backported from 8.1
-- snmp: add sha256 / sha512 security protocol, backported from 8.1
+* Tue Jul 6 2021 Remi Collet <remi@remirepo.net> - 8.1.0~alpha3-1
+- update to 8.1.0alpha3
-* Tue Aug 10 2021 Remi Collet <remi@remirepo.net> - 8.0.10~RC1-1
-- update to 8.0.10RC1
-- adapt systzdata patch for timelib 2020.03 (v20)
+* Tue Jun 22 2021 Remi Collet <remi@remirepo.net> - 8.1.0~alpha2-1
+- update to 8.1.0alpha2
-* Tue Aug 3 2021 Remi Collet <remi@remirepo.net> - 8.0.9-2
-- add upstream patch for https://bugs.php.net/81325 segfault in simplexml
+* Tue Jun 22 2021 Remi Collet <remi@remirepo.net> - 8.1.0~alpha2-0
+- test build for upcoming 8.1.0alpha2
+- fix build for missing public API using patch from
+ https://github.com/php/php-src/pull/7185
-* Thu Jul 29 2021 Remi Collet <remi@remirepo.net> - 8.0.9-1
-- Update to 8.0.9 - http://www.php.net/releases/8_0_9.php
+* Wed Jun 9 2021 Remi Collet <remi@remirepo.net> - 8.1.0~alpha1-1
+- update to 8.1.0alpha1
-* Tue Jul 13 2021 Remi Collet <remi@remirepo.net> - 8.0.9~RC1-1
-- update to 8.0.9RC1
+* Tue Jun 8 2021 Remi Collet <remi@remirepo.net> - 8.1.0~DEV.20210608-2
+- apply timelib fix for empty POSIX string in older TZif2 files
+- switch back to system tzdata on EL-7
-* Tue Jun 29 2021 Remi Collet <remi@remirepo.net> - 8.0.8-1
-- Update to 8.0.8 - http://www.php.net/releases/8_0_8.php
+* Tue Jun 8 2021 Remi Collet <remi@remirepo.net> - 8.1.0~DEV.20210608-1
+- new build
+- ignore unsupported "threads" options in password_hash
+- temporarily use bundled tzdata on EL-7
-* Tue Jun 15 2021 Remi Collet <remi@remirepo.net> - 8.0.8~RC1-1
-- update to 8.0.8RC1
-- ignore unsupported "threads" option on password_hash
+* Fri Jun 4 2021 Remi Collet <remi@remirepo.net> - 8.1.0~DEV.20210604-1
+- update to 8.1.0-dev
* Wed Jun 2 2021 Remi Collet <remi@remirepo.net> - 8.0.7-1
- Update to 8.0.7 - http://www.php.net/releases/8_0_7.php