summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec28
1 files changed, 12 insertions, 16 deletions
diff --git a/php.spec b/php.spec
index b9d6702..693c992 100644
--- a/php.spec
+++ b/php.spec
@@ -49,17 +49,10 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%ifarch aarch64
-%global oraclever 19.25
-%global oraclemax 20
-%global oraclelib 19.1
-%global oracledir 19.25
-%else
-%global oraclever 23.6
+%global oraclever 23.7
%global oraclemax 24
%global oraclelib 23.1
%global oracledir 23
-%endif
# Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests
%bcond_without lsws
@@ -135,7 +128,7 @@
#global gh_date 20220530
%global gh_owner php
%global gh_project php-src
-%global upver 8.2.27
+%global upver 8.2.28
#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
@@ -210,6 +203,10 @@ Patch91: php-7.2.0-oci8conf.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
Patch300: php-7.4.0-datetests.patch
+# for pcre2 10.45 (F42)
+Patch301: php-8.2.28-pcretests.patch
+# for zlib-ng
+Patch302: php-8.2.28-zlibtests.patch
# WIP
@@ -647,14 +644,7 @@ License.
Summary: A module for PHP applications that use OCI8 databases
# All files licensed under PHP version 3.01
License: PHP-3.01
-%ifarch aarch64
-BuildRequires: oracle-instantclient%{oraclever}-devel
-# Should requires libclntsh.so.19.1()(aarch-64), but it's not provided by Oracle RPM.
-Requires: libclntsh.so.%{oraclelib}
-AutoReq: 0
-%else
BuildRequires: (oracle-instantclient-devel >= %{oraclever} with oracle-instantclient-devel < %{oraclemax})
-%endif
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
Provides: %{?scl_prefix}php-pdo_oci
@@ -996,6 +986,8 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
# Fixes for tests
%patch -P300 -p1 -b .datetests
+%patch -P301 -p1 -b .pcretests
+%patch -P302 -p1 -b .zlibtests
# WIP patch
@@ -1871,6 +1863,10 @@ fi
%changelog
+* Wed Mar 12 2025 Remi Collet <remi@remirepo.net> - 8.2.28-1
+- Update to 8.2.28 - http://www.php.net/releases/8_2_28.php
+- use oracle client library version 23.7 on x86_64 and arm64
+
* Tue Dec 17 2024 Remi Collet <remi@remirepo.net> - 8.2.27-1
- Update to 8.2.27 - http://www.php.net/releases/8_2_27.php