summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-25 08:07:45 +0100
committerRemi Collet <remi@php.net>2022-11-25 08:07:45 +0100
commit648b49c0ae762c9df007134e63d785d871ece2c9 (patch)
tree4120d3cb8925ffada0c2a3e1cb23f9152fa3f735
parenta692a4e33c5e82baa0ba65b7d7d80ec0f52effcc (diff)
test build for GH-9997
-rw-r--r--php.spec9
-rw-r--r--upstream.patch38
2 files changed, 46 insertions, 1 deletions
diff --git a/php.spec b/php.spec
index afd5d9d..f66a7af 100644
--- a/php.spec
+++ b/php.spec
@@ -129,7 +129,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 20%{?dist}
+Release: 21%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -192,6 +192,7 @@ Patch47: php-8.1.0-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: upstream.patch
# Security fixes (200+)
@@ -968,6 +969,9 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch91 -p1 -b .remi-oci8
# upstream patches
+%if 0%{?rhel} == 7
+%patch100 -p1 -R
+%endif
# security patches
@@ -1848,6 +1852,9 @@ fi
%changelog
+* Thu Nov 24 2022 Remi Collet <remi@remirepo.net> - 8.2.0~rc7-20
+- test build for GH-9997
+
* Wed Nov 23 2022 Remi Collet <remi@remirepo.net> - 8.2.0~rc7-19
- update to 8.2.0RC7
diff --git a/upstream.patch b/upstream.patch
new file mode 100644
index 0000000..a1d65ba
--- /dev/null
+++ b/upstream.patch
@@ -0,0 +1,38 @@
+From 1ef65c1cf030ac5173fb388795f82e3d14a70c6b Mon Sep 17 00:00:00 2001
+From: Jakub Zelenka <bukka@php.net>
+Date: Mon, 17 Oct 2022 20:38:40 +0100
+Subject: [PATCH] Clean up OpenSSL engine list when OpenSSL 1.0.2 used
+
+Attempt to fix GH-8620.
+---
+ NEWS | 4 ++++
+ ext/openssl/openssl.c | 9 +++++++++
+ 2 files changed, 13 insertions(+)
+
+diff --git a/ext/openssl/openssl.c b/ext/openssl/openssl.c
+index 81cef7edbfca..0f937f8c6de0 100644
+--- a/ext/openssl/openssl.c
++++ b/ext/openssl/openssl.c
+@@ -61,6 +61,10 @@
+ #include <openssl/param_build.h>
+ #endif
+
++#if OPENSSL_VERSION_NUMBER < 0x10100000L && !defined(OPENSSL_NO_ENGINE)
++#include <openssl/engine.h>
++#endif
++
+ /* Common */
+ #include <time.h>
+
+@@ -1312,6 +1316,11 @@ PHP_MSHUTDOWN_FUNCTION(openssl)
+ #if OPENSSL_VERSION_NUMBER < 0x10100000L || defined (LIBRESSL_VERSION_NUMBER)
+ EVP_cleanup();
+
++#ifndef OPENSSL_NO_ENGINE
++ /* Free engine list initialized by OPENSSL_config */
++ ENGINE_cleanup();
++#endif
++
+ /* prevent accessing locking callback from unloaded extension */
+ CRYPTO_set_locking_callback(NULL);
+ /* free allocated error strings */