summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-20 16:51:26 +0100
committerRemi Collet <remi@php.net>2022-12-20 16:51:26 +0100
commit1edd8c0d680fc7db859cc18738822b18d4713450 (patch)
tree6e6500c118a20003a1b24c284c0c081a921205c5
parenta2c63c8845e5ecfc10f120fbfc139ae2d8ad5aee (diff)
add upstream patch for failing test
-rw-r--r--failed.txt14
-rw-r--r--php.spec7
-rw-r--r--upstream.patch22
3 files changed, 34 insertions, 9 deletions
diff --git a/failed.txt b/failed.txt
index d9bddd0..1a0a647 100644
--- a/failed.txt
+++ b/failed.txt
@@ -2,16 +2,14 @@
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
-/var/lib/mock/scl82el7x/build.log:Tests failed : 1
-/var/lib/mock/scl82el8x/build.log:Tests failed : 1
-/var/lib/mock/scl82el9x/build.log:Tests failed : 1
-/var/lib/mock/scl82fc35x/build.log:Tests failed : 1
-/var/lib/mock/scl82fc36x/build.log:Tests failed : 1
-/var/lib/mock/scl82fc37x/build.log:Tests failed : 1
+/var/lib/mock/scl82el7x/build.log:Tests failed : 0
+/var/lib/mock/scl82el8x/build.log:Tests failed : 0
+/var/lib/mock/scl82el9x/build.log:Tests failed : 0
+/var/lib/mock/scl82fc35x/build.log:Tests failed : 0
+/var/lib/mock/scl82fc36x/build.log:Tests failed : 0
+/var/lib/mock/scl82fc37x/build.log:Tests failed : 0
-all:
- 3 Compatibility of values of same name trait constants is checked after their constant expressions are evaluated [Zend/tests/traits/constant_016.phpt]
(1) proc_open give erratic test results :(
diff --git a/php.spec b/php.spec
index 1924090..317e6f8 100644
--- a/php.spec
+++ b/php.spec
@@ -128,7 +128,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 2%{?dist}
+Release: 3%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -191,6 +191,7 @@ Patch47: php-8.1.0-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: upstream.patch
# Security fixes (200+)
@@ -967,6 +968,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1
# security patches
@@ -1847,6 +1849,9 @@ fi
%changelog
+* Tue Dec 20 2022 Remi Collet <remi@remirepo.net> - 8.2.1~RC1-3
+- add upstream patch for failing test
+
* Mon Dec 19 2022 Remi Collet <remi@remirepo.net> - 8.2.1~RC1-2
- php-fpm.conf: move include directive after [global] section
https://github.com/remicollet/remirepo/issues/225
diff --git a/upstream.patch b/upstream.patch
new file mode 100644
index 0000000..ffd13b6
--- /dev/null
+++ b/upstream.patch
@@ -0,0 +1,22 @@
+From bfa56cf62bfdb07afa93c63ec263ce24a591261d Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 20 Dec 2022 15:24:15 +0100
+Subject: [PATCH] Fix #10133 set variables_order en ensure $ENV is set
+
+---
+ Zend/tests/traits/constant_016.phpt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/Zend/tests/traits/constant_016.phpt b/Zend/tests/traits/constant_016.phpt
+index 9cb2b29bcc09..0754c1571637 100644
+--- a/Zend/tests/traits/constant_016.phpt
++++ b/Zend/tests/traits/constant_016.phpt
+@@ -2,6 +2,8 @@
+ Compatibility of values of same name trait constants is checked after their constant expressions are evaluated
+ --ENV--
+ ENSURE_CONSTANT_IS_DEFINED_AT_RUNTIME=1
++--INI--
++variables_order=EGPCS
+ --FILE--
+ <?php
+