summaryrefslogtreecommitdiffstats
path: root/php81.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php81.spec')
-rw-r--r--php81.spec21
1 files changed, 13 insertions, 8 deletions
diff --git a/php81.spec b/php81.spec
index aadf4b6..611c0cd 100644
--- a/php81.spec
+++ b/php81.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php81 SCL metapackage
#
-# Copyright (c) 2018-2021 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2018-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -26,8 +26,8 @@
Summary: Package that installs PHP 8.1
Name: %scl_name
Version: 8.1
-Release: 2%{?dist}
-License: GPLv2+
+Release: 3%{?dist}
+License: GPL-2.0-or-later
Source0: macros-build
Source1: README
@@ -161,7 +161,7 @@ cp %{SOURCE2} .
# generate a helper script that will be used by help2man
cat >h2m_helper <<'EOF'
#!/bin/bash
-[ "$1" == "--version" ] && echo "%{scl_name} %{version} Software Collection" || cat README
+[ "$1" == "--version" ] && echo "%{scl_name} Software Collection (PHP %{version})" || cat README
EOF
chmod a+x h2m_helper
@@ -173,7 +173,7 @@ help2man -N --section 7 ./h2m_helper -o %{scl_name}.7
install -D -m 644 enable %{buildroot}%{_scl_scripts}/enable
install -D -m 644 envmod %{buildroot}%{_root_datadir}/Modules/modulefiles/%{scl_name}
install -D -m 644 scldev %{buildroot}%{macrosdir}/macros.%{scl_name_base}-scldevel
-install -D -m 644 %{scl_name}.7 %{buildroot}%{_mandir}/man7/%{scl_name}.7
+install -D -m 644 %{scl_name}.7 %{buildroot}%{_root_mandir}/man7/%{scl_name}.7
install -d -m 755 %{buildroot}%{_datadir}/licenses
install -d -m 755 %{buildroot}%{_datadir}/doc/pecl
@@ -185,7 +185,7 @@ install -d -m 755 %{buildroot}%{_localstatedir}/lib/pear/pkgxml
cat %{buildroot}%{_root_sysconfdir}/rpm/macros.%{scl}-config
# Add the scl_package_override macro
-sed -e 's/@SCL@/%{scl}/g' %{SOURCE0} \
+sed -e 's/@SCL@/%{scl}/g;s:@PREFIX@:/opt/%{scl_vendor}:;s/@VENDOR@/%{scl_vendor}/' %{SOURCE0} \
| tee -a %{buildroot}%{_root_sysconfdir}/rpm/macros.%{scl}-config
# Move in correct location, if needed
@@ -232,7 +232,7 @@ restorecon -R %{_localstatedir} &>/dev/null || :
%license LICENSE
%doc README
%scl_files
-%{_mandir}/man7/%{scl_name}.*
+%{_root_mandir}/man7/%{scl_name}.*
%{?_licensedir:%{_datadir}/licenses}
%{_datadir}/tests
%{_root_datadir}/Modules/modulefiles/%{scl_name}
@@ -258,6 +258,11 @@ restorecon -R %{_localstatedir} &>/dev/null || :
%changelog
+* Thu Mar 9 2023 Remi Collet <remi@remirepo.net> 8.1-3
+- define %%scl_vendor and %%_scl_prefix in macros.php81-config
+- move man page out of scl tree
+- improve the man page
+
* Fri Jul 9 2021 Remi Collet <remi@remirepo.net> 8.1-2
- add weak dependencies on commonly used SAPI and extensions:
fpm, mbstring, opcache, pdo, sodium and xml