summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-27 08:41:53 +0200
committerRemi Collet <remi@php.net>2021-10-27 08:41:53 +0200
commit8477b7791e3ced39b04754ac1931bb84638155a1 (patch)
tree74b9c0d2aea7e652fd2fb768b835aed0a0dbde6e /php.spec
parent6afe5d0185fb00b3e6c8892a4c5ce67a998dc7e8 (diff)
update to 8.1.0RC5
build using system libxcrypt (Fedora only)
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec28
1 files changed, 24 insertions, 4 deletions
diff --git a/php.spec b/php.spec
index 46227c0..1e51be1 100644
--- a/php.spec
+++ b/php.spec
@@ -82,12 +82,22 @@
%bcond_with libpcre
%endif
-%if 0%{?fedora} >= 33
+# Using qdbm from "remi" for now, see https://bugzilla.redhat.com/2017308
+%if 0%{?fedora} >= 33 || 0%{?rhel} >= 8
%bcond_without qdbm
%else
%bcond_with qdbm
%endif
+# TODO change when 8.5 released (libxcrypt 4.1.1-6)
+%if 0%{?fedora} >= 33 || 0%{?rhel} >= 9
+# switch to bundled library using --without libxcrypt
+%bcond_without libxcrypt
+%else
+# switch to system library using --with libxcrypt
+%bcond_with libxcrypt
+%endif
+
%bcond_without dtrace
# build with system libgd (gd-last in remi repo)
@@ -114,13 +124,13 @@
%global gh_owner php
%global gh_project php-src
%global upver 8.1.0
-%global rcver RC4
-%global lower rc4
+%global rcver RC5
+%global lower rc5
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -214,6 +224,9 @@ BuildRequires: pkgconfig(libpcre2-8) >= 10.30
%else
Provides: bundled(pcre2) = 10.32
%endif
+%if %{with libxcrypt}
+BuildRequires: pkgconfig(libxcrypt)
+%endif
BuildRequires: bzip2
BuildRequires: perl
BuildRequires: autoconf
@@ -1162,6 +1175,9 @@ ln -sf ../configure
%if %{with libpcre}
--with-external-pcre \
%endif
+%if %{with libxcrypt}
+ --with-external-libcrypt \
+%endif
--with-zlib \
--with-layout=GNU \
--with-kerberos \
@@ -1831,6 +1847,10 @@ fi
%changelog
+* Tue Oct 26 2021 Remi Collet <remi@remirepo.net> - 8.1.0~rc5-1
+- update to 8.1.0RC5
+- build using system libxcrypt (Fedora only)
+
* Tue Oct 26 2021 Remi Collet <remi@remirepo.net> - 8.1.0~rc4-2
- dba: enable qdbm backend