summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec23
1 files changed, 14 insertions, 9 deletions
diff --git a/php.spec b/php.spec
index 661d049..aba9887 100644
--- a/php.spec
+++ b/php.spec
@@ -27,7 +27,7 @@
%global zendver 20190128
%global pdover 20170320
# Extension version
-%global oci8ver 2.2.0
+%global oci8ver 3.0.0
# Adds -z now to the linker flags
%global _hardened_build 1
@@ -102,13 +102,13 @@
%global gh_owner php
%global gh_project php-src
%global upver 8.0.0
-%global rcver alpha2
+%global rcver alpha3
%global lower %{rcver}
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 25%{?dist}
+Release: 26%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -160,13 +160,13 @@ Patch43: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
Patch45: php-7.4.0-ldap_r.patch
# drop "Configure command" from phpinfo output
-Patch47: php-5.6.3-phpinfo.patch
+# and only use gcc (instead of full version)
+Patch47: php-8.0.0-phpinfo.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-upstream.patch
# Security fixes (200+)
@@ -782,9 +782,9 @@ Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 50.1
-BuildRequires: pkgconfig(icu-io) >= 50.1
-BuildRequires: pkgconfig(icu-uc) >= 50.1
+BuildRequires: pkgconfig(icu-i18n) >= 65
+BuildRequires: pkgconfig(icu-io) >= 65
+BuildRequires: pkgconfig(icu-uc) >= 65
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -887,7 +887,6 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .up
# security patches
@@ -1029,6 +1028,8 @@ export PHP_BUILD_SYSTEM=$(cat /etc/redhat-release | sed -e 's/ Beta//')
%if 0%{?vendor:1}
export PHP_BUILD_PROVIDER="%{vendor}"
%endif
+export PHP_BUILD_COMPILER="$(gcc --version | head -n1)"
+export PHP_BUILD_ARCH="%{_arch}"
# Force use of system libtool:
libtoolize --force --copy
@@ -1752,6 +1753,10 @@ fi
%changelog
+* Tue Jul 21 2020 Remi Collet <remi@remirepo.net> - 8.0.0~alpha3-26
+- update to 8.0.0alpha3
+- oci8 version is now 3.0.0
+
* Fri Jul 10 2020 Remi Collet <remi@remirepo.net> - 8.0.0~alpha2-25
- rebuild using ICU 65