summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec20
1 files changed, 12 insertions, 8 deletions
diff --git a/php.spec b/php.spec
index 6d656ac..3fe3b97 100644
--- a/php.spec
+++ b/php.spec
@@ -98,8 +98,8 @@
#global gh_date 20200615
%global gh_owner php
%global gh_project php-src
-%global upver 8.0.11
-#global rcver RC1
+%global upver 8.0.12
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -790,9 +790,9 @@ Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 65
-BuildRequires: pkgconfig(icu-io) >= 65
-BuildRequires: pkgconfig(icu-uc) >= 65
+BuildRequires: pkgconfig(icu-i18n) >= 69
+BuildRequires: pkgconfig(icu-io) >= 69
+BuildRequires: pkgconfig(icu-uc) >= 69
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -1480,9 +1480,9 @@ ln -s %{_bindir}/lsphp $RPM_BUILD_ROOT%{_root_bindir}/ls%{scl}
TESTCMD="$RPM_BUILD_ROOT%{_bindir}/php --no-php-ini"
# Ensure all provided extensions are really there
-for mod in core date filter hash libxml openssl pcntl pcre readline reflection session spl standard zlib
+for mod in core date filter hash json libxml openssl pcntl pcre readline reflection session spl standard zlib
do
- $TESTCMD --modules | grep -qi $mod
+ $TESTCMD --modules | grep -i "$mod\$"
done
TESTCMD="$TESTCMD --define extension_dir=$RPM_BUILD_ROOT%{_libdir}/php/modules"
@@ -1542,7 +1542,7 @@ do
ini=20-${mod}.ini;;
esac
- $TESTCMD --modules | grep -qi $mod
+ $TESTCMD --modules | grep -i "$mod\$"
# some extensions have their own config file
if [ -f ${ini} ]; then
@@ -1816,6 +1816,10 @@ fi
%changelog
+* Wed Oct 6 2021 Remi Collet <remi@remirepo.net> - 8.0.12~RC1-1
+- update to 8.0.12RC1
+- use libicu version 69
+
* Wed Sep 22 2021 Remi Collet <remi@remirepo.net> - 8.0.11-1
- Update to 8.0.11 - http://www.php.net/releases/8_0_11.php