summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-5.6.3-phpinfo.patch29
-rw-r--r--php-8.0.0-phpinfo.patch44
-rw-r--r--php.spec23
3 files changed, 58 insertions, 38 deletions
diff --git a/php-5.6.3-phpinfo.patch b/php-5.6.3-phpinfo.patch
deleted file mode 100644
index 086be15..0000000
--- a/php-5.6.3-phpinfo.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-
-Drop "Configure Command" from phpinfo as it doesn't
-provide any useful information.
-The available extensions are not related to this command.
-
-diff -up php-7.0.0RC1/ext/standard/info.c.phpinfo php-7.0.0RC1/ext/standard/info.c
---- php-7.0.0RC1/ext/standard/info.c.phpinfo 2015-08-18 23:39:24.000000000 +0200
-+++ php-7.0.0RC1/ext/standard/info.c 2015-08-22 07:56:18.344761928 +0200
-@@ -870,9 +870,6 @@ PHPAPI void php_print_info(int flag)
- #ifdef ARCHITECTURE
- php_info_print_table_row(2, "Architecture", ARCHITECTURE);
- #endif
--#ifdef CONFIGURE_COMMAND
-- php_info_print_table_row(2, "Configure Command", CONFIGURE_COMMAND );
--#endif
-
- if (sapi_module.pretty_name) {
- php_info_print_table_row(2, "Server API", sapi_module.pretty_name );
-diff -up php-7.0.0RC1/ext/standard/tests/general_functions/phpinfo.phpt.phpinfo php-7.0.0RC1/ext/standard/tests/general_functions/phpinfo.phpt
---- php-7.0.0RC1/ext/standard/tests/general_functions/phpinfo.phpt.phpinfo 2015-08-18 23:39:22.000000000 +0200
-+++ php-7.0.0RC1/ext/standard/tests/general_functions/phpinfo.phpt 2015-08-22 07:56:18.344761928 +0200
-@@ -20,7 +20,6 @@ PHP Version => %s
-
- System => %s
- Build Date => %s%a
--Configure Command => %s
- Server API => Command Line Interface
- Virtual Directory Support => %s
- Configuration File (php.ini) Path => %s
diff --git a/php-8.0.0-phpinfo.patch b/php-8.0.0-phpinfo.patch
new file mode 100644
index 0000000..e86af79
--- /dev/null
+++ b/php-8.0.0-phpinfo.patch
@@ -0,0 +1,44 @@
+
+Drop "Configure Command" from phpinfo as it doesn't
+provide any useful information.
+The available extensions are not related to this command.
+
+Replace full GCC name by gcc in php -v output
+
+diff -up ./ext/standard/info.c.phpinfo ./ext/standard/info.c
+--- ./ext/standard/info.c.phpinfo 2020-07-21 10:49:31.000000000 +0200
++++ ./ext/standard/info.c 2020-07-21 11:41:56.295633523 +0200
+@@ -804,9 +804,6 @@ PHPAPI ZEND_COLD void php_print_info(int
+ #ifdef ARCHITECTURE
+ php_info_print_table_row(2, "Architecture", ARCHITECTURE);
+ #endif
+-#ifdef CONFIGURE_COMMAND
+- php_info_print_table_row(2, "Configure Command", CONFIGURE_COMMAND );
+-#endif
+
+ if (sapi_module.pretty_name) {
+ php_info_print_table_row(2, "Server API", sapi_module.pretty_name );
+diff -up ./ext/standard/tests/general_functions/phpinfo.phpt.phpinfo ./ext/standard/tests/general_functions/phpinfo.phpt
+--- ./ext/standard/tests/general_functions/phpinfo.phpt.phpinfo 2020-07-21 10:49:31.000000000 +0200
++++ ./ext/standard/tests/general_functions/phpinfo.phpt 2020-07-21 11:41:56.296633522 +0200
+@@ -17,7 +17,6 @@ PHP Version => %s
+
+ System => %s
+ Build Date => %s%a
+-Configure Command => %s
+ Server API => Command Line Interface
+ Virtual Directory Support => %s
+ Configuration File (php.ini) Path => %s
+diff -up ./sapi/cli/php_cli.c.phpinfo ./sapi/cli/php_cli.c
+--- ./sapi/cli/php_cli.c.phpinfo 2020-07-21 11:43:38.812475300 +0200
++++ ./sapi/cli/php_cli.c 2020-07-21 11:43:45.783464540 +0200
+@@ -643,8 +643,7 @@ static int do_cli(int argc, char **argv)
+ "NTS "
+ #endif
+ #ifdef COMPILER
+- COMPILER
+- " "
++ "gcc "
+ #endif
+ #ifdef ARCHITECTURE
+ ARCHITECTURE
diff --git a/php.spec b/php.spec
index 661d049..aba9887 100644
--- a/php.spec
+++ b/php.spec
@@ -27,7 +27,7 @@
%global zendver 20190128
%global pdover 20170320
# Extension version
-%global oci8ver 2.2.0
+%global oci8ver 3.0.0
# Adds -z now to the linker flags
%global _hardened_build 1
@@ -102,13 +102,13 @@
%global gh_owner php
%global gh_project php-src
%global upver 8.0.0
-%global rcver alpha2
+%global rcver alpha3
%global lower %{rcver}
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 25%{?dist}
+Release: 26%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -160,13 +160,13 @@ Patch43: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
Patch45: php-7.4.0-ldap_r.patch
# drop "Configure command" from phpinfo output
-Patch47: php-5.6.3-phpinfo.patch
+# and only use gcc (instead of full version)
+Patch47: php-8.0.0-phpinfo.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-upstream.patch
# Security fixes (200+)
@@ -782,9 +782,9 @@ Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 50.1
-BuildRequires: pkgconfig(icu-io) >= 50.1
-BuildRequires: pkgconfig(icu-uc) >= 50.1
+BuildRequires: pkgconfig(icu-i18n) >= 65
+BuildRequires: pkgconfig(icu-io) >= 65
+BuildRequires: pkgconfig(icu-uc) >= 65
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -887,7 +887,6 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .up
# security patches
@@ -1029,6 +1028,8 @@ export PHP_BUILD_SYSTEM=$(cat /etc/redhat-release | sed -e 's/ Beta//')
%if 0%{?vendor:1}
export PHP_BUILD_PROVIDER="%{vendor}"
%endif
+export PHP_BUILD_COMPILER="$(gcc --version | head -n1)"
+export PHP_BUILD_ARCH="%{_arch}"
# Force use of system libtool:
libtoolize --force --copy
@@ -1752,6 +1753,10 @@ fi
%changelog
+* Tue Jul 21 2020 Remi Collet <remi@remirepo.net> - 8.0.0~alpha3-26
+- update to 8.0.0alpha3
+- oci8 version is now 3.0.0
+
* Fri Jul 10 2020 Remi Collet <remi@remirepo.net> - 8.0.0~alpha2-25
- rebuild using ICU 65