summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-18 09:27:11 +0200
committerRemi Collet <remi@php.net>2021-10-18 09:27:11 +0200
commit01d12d8f8152f1e1e9469ba4677973b3b6538c72 (patch)
tree1df9c1b1048fac045c76e2887efbacdac78cd71a /php.spec
parenta5e768e160bdf3c0b9fad7f5755ff7402ed48835 (diff)
build using system libxcrypt
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec23
1 files changed, 22 insertions, 1 deletions
diff --git a/php.spec b/php.spec
index 3fe3b97..5502293 100644
--- a/php.spec
+++ b/php.spec
@@ -73,6 +73,7 @@
%bcond_without tidy
%bcond_without sqlite3
%bcond_without enchant
+
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# switch to bundled library using --without libpcre
%bcond_without libpcre
@@ -81,6 +82,14 @@
%bcond_with libpcre
%endif
+%if 0%{?fedora} >= 33 || 0%{?rhel} >= 8
+# switch to bundled library using --without libxcrypt
+%bcond_without libxcrypt
+%else
+# switch to system library using --with libxcrypt
+%bcond_with libxcrypt
+%endif
+
%bcond_without dtrace
# build with system libgd (gd-last in remi repo)
@@ -104,7 +113,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -168,6 +177,8 @@ Patch48: php-8.0.10-snmp-sha.patch
# switch phar to use sha256 signature by default, from 8.1
# implement openssl_256 and openssl_512 for phar signatures, from 8.1
Patch49: php-8.0.10-phar-sha.patch
+# use system libxcrypt
+Patch50: php-8.0.12-crypt.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
@@ -204,6 +215,9 @@ BuildRequires: pkgconfig(libpcre2-8) >= 10.30
%else
Provides: bundled(pcre2) = 10.32
%endif
+%if %{with libxcrypt}
+BuildRequires: pkgconfig(libxcrypt)
+%endif
BuildRequires: bzip2
BuildRequires: perl
BuildRequires: autoconf
@@ -939,6 +953,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch47 -p1 -b .phpinfo
%patch48 -p1 -b .sha
%patch49 -p1 -b .pharsha
+%patch50 -p1 -b .libxcrypt
%patch91 -p1 -b .remi-oci8
@@ -1150,6 +1165,9 @@ ln -sf ../configure
%if %{with libpcre}
--with-external-pcre \
%endif
+%if %{with libxcrypt}
+ --with-external-libcrypt \
+%endif
--with-zlib \
--with-layout=GNU \
--with-kerberos \
@@ -1816,6 +1834,9 @@ fi
%changelog
+* Mon Oct 18 2021 Remi Collet <remi@remirepo.net> - 8.0.12~RC1-2
+- build using system libxcrypt
+
* Wed Oct 6 2021 Remi Collet <remi@remirepo.net> - 8.0.12~RC1-1
- update to 8.0.12RC1
- use libicu version 69