summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README18
-rw-r--r--macros-build6
-rw-r--r--php74.spec51
3 files changed, 44 insertions, 31 deletions
diff --git a/README b/README
index 98cb9ef..e808e0b 100644
--- a/README
+++ b/README
@@ -23,12 +23,14 @@ which adds support for the PHP language to Apache HTTP server.
The %{?scl_prefix}php-fpm package provides the FastCGI process manager
which adds support for the PHP language to FastCGI compatible servers.
-FastCGI process manager (php-fpm) listens on local network soket
-(by default port 9000).
+FastCGI process manager (php-fpm) listens on local soket
+(by default %{_localstatedir}/run/php-fpm/www.sock).
When working with %{scl_name} collection, use the "scl" utility (see
scl(1) for usage) to enable the scl environment properly.
+You can alternatively use the "module" utility (see module(1) for usage).
+
Configuration for the %{scl_name} software collection is located under %{_sysconfdir}.
Examples:
@@ -46,9 +48,11 @@ scl enable %{scl_name} 'man php'
Show man pages for php command, which is part of the %{scl_name} software
collection.
-%if 0%{?rhel} >= 7
+module load %{scl_name}
+ Enable %{scl_name} software collection in current interactive shell.
+
+module unload %{scl_name}
+ Disable %{scl_name} software collection in current interactive shell.
+
systemctl start %{?scl_prefix}php-fpm
-%else
-service %{?scl_prefix}php-fpm start
-%endif
- Starts the php-fpm server from %{scl_name} software collection. \ No newline at end of file
+ Starts the php-fpm server from %{scl_name} software collection.
diff --git a/macros-build b/macros-build
index 03ff02d..c7cab7c 100644
--- a/macros-build
+++ b/macros-build
@@ -1,9 +1,13 @@
-%_sclreq (%{scl_vendor})
+%scl_vendor @VENDOR@
+%_scl_prefix @PREFIX@
+%_sclreq (@VENDOR@)
%scl_package_override() %{expand:
%{?@SCL@___pear:%global __pear %@SCL@___pear}
%{?@SCL@___pecl:%global __pecl %@SCL@___pecl}
%{?@SCL@___php:%global __php %@SCL@___php}
+ %{?@SCL@___phpize:%global __phpize %@SCL@___phpize}
+ %{?@SCL@___phpconfig:%global __phpconfig %@SCL@___phpconfig}
%{?@SCL@_pecl_xmldir:%global pecl_xmldir %@SCL@_pecl_xmldir}
%global pear_metadir %@SCL@_pear_metadir
%global pear_xmldir %@SCL@_pear_xmldir
diff --git a/php74.spec b/php74.spec
index 9af6ce0..23b7530 100644
--- a/php74.spec
+++ b/php74.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php74 SCL metapackage
#
-# Copyright (c) 2018-2019 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2018-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -18,14 +18,6 @@
%global nfsmountable 1
%endif
-%if 0%{?fedora} >= 20 && 0%{?fedora} < 27
-# Requires scl-utils v2 for SCL integration, dropped in F29
-%global with_modules 1
-%else
-# Works with file installed in /usr/share/Modules/modulefiles/
-%global with_modules 0
-%endif
-
%scl_package %scl
# do not produce empty debuginfo package
@@ -33,9 +25,9 @@
Summary: Package that installs PHP 7.4
Name: %scl_name
-Version: 1.0
-Release: 1%{?dist}
-License: GPLv2+
+Version: 7.4
+Release: 3%{?dist}
+License: GPL-2.0-or-later
Source0: macros-build
Source1: README
@@ -101,6 +93,7 @@ Conflicts: php56-syspaths
Conflicts: php70-syspaths
Conflicts: php71-syspaths
Conflicts: php72-syspaths
+Conflicts: php73-syspaths
%description syspaths
System-wide wrappers for the %{name}-php-cli package.
@@ -157,7 +150,7 @@ cp %{SOURCE2} .
# generate a helper script that will be used by help2man
cat >h2m_helper <<'EOF'
#!/bin/bash
-[ "$1" == "--version" ] && echo "%{scl_name} %{version} Software Collection" || cat README
+[ "$1" == "--version" ] && echo "%{scl_name} Software Collection (PHP %{version})" || cat README
EOF
chmod a+x h2m_helper
@@ -167,13 +160,9 @@ help2man -N --section 7 ./h2m_helper -o %{scl_name}.7
%install
install -D -m 644 enable %{buildroot}%{_scl_scripts}/enable
-%if %{with_modules}
-install -D -m 644 envmod %{buildroot}%{_scl_scripts}/%{scl_name}
-%else
install -D -m 644 envmod %{buildroot}%{_root_datadir}/Modules/modulefiles/%{scl_name}
-%endif
install -D -m 644 scldev %{buildroot}%{macrosdir}/macros.%{scl_name_base}-scldevel
-install -D -m 644 %{scl_name}.7 %{buildroot}%{_mandir}/man7/%{scl_name}.7
+install -D -m 644 %{scl_name}.7 %{buildroot}%{_root_mandir}/man7/%{scl_name}.7
install -d -m 755 %{buildroot}%{_datadir}/licenses
install -d -m 755 %{buildroot}%{_datadir}/doc/pecl
@@ -185,7 +174,7 @@ install -d -m 755 %{buildroot}%{_localstatedir}/lib/pear/pkgxml
cat %{buildroot}%{_root_sysconfdir}/rpm/macros.%{scl}-config
# Add the scl_package_override macro
-sed -e 's/@SCL@/%{scl}/g' %{SOURCE0} \
+sed -e 's/@SCL@/%{scl}/g;s:@PREFIX@:/opt/%{scl_vendor}:;s/@VENDOR@/%{scl_vendor}/' %{SOURCE0} \
| tee -a %{buildroot}%{_root_sysconfdir}/rpm/macros.%{scl}-config
# Move in correct location, if needed
@@ -232,12 +221,10 @@ restorecon -R %{_localstatedir} &>/dev/null || :
%license LICENSE
%doc README
%scl_files
-%{_mandir}/man7/%{scl_name}.*
+%{_root_mandir}/man7/%{scl_name}.*
%{?_licensedir:%{_datadir}/licenses}
%{_datadir}/tests
-%if ! %{with_modules}
%{_root_datadir}/Modules/modulefiles/%{scl_name}
-%endif
%files build
@@ -260,6 +247,24 @@ restorecon -R %{_localstatedir} &>/dev/null || :
%changelog
+* Wed Apr 26 2023 Remi Collet <remi@remirepo.net> 7.4-3
+- redefine %%__phpize and %%__phpconfig
+
+* Thu Mar 9 2023 Remi Collet <remi@remirepo.net> 7.4-2
+- define %%scl_vendor and %%_scl_prefix in macros.php74-config
+- move man page out of scl tree
+- improve the man page
+
+* Tue Nov 9 2021 Remi Collet <remi@remirepo.net> 7.4-1
+- EL-9 build
+
+* Thu Apr 9 2020 Remi Collet <remi@remirepo.net> 1.0-3
+- add conflict between php73-syspaths and php74-syspaths
+
+* Thu Aug 22 2019 Remi Collet <remi@remirepo.net> 1.0-2
+- fix error: Macro %%undefine is a built-in
+ see https://bugzilla.redhat.com/1744583
+
* Mon May 20 2019 Remi Collet <remi@remirepo.net> 1.0-1
- initial package for 7.4